Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RIP Configs

Dear Friendzs,

I am configuring RIP on a L3 Switch cisco 4507. But only taking "IP supernet pool" under network command. I have to advertised two pool in RIP which are as:-

10.10.100.200 255.255.255.248

10.10.100.208 255.255.255.252

Command are given as :-

Router Rip

version 2

network 10.10.100.200

network 10.10.100.208

After executing above commands, while cheking on "Sh Run" output.It reflecting like --->

Router Rip

version 2

network 10.0.0.0

Please check and correct where i am wrong in configuration.

6 REPLIES

Re: RIP Configs

Disable auto-summary:

router rip

no auto-summary

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

Re: RIP Configs

Hii John,

I have done what u suggested, still showing the same output.

router rip

version 2

network 10.0.0.0

no auto-summary

Hall of Fame Super Silver

Re: RIP Configs

Hello Jimmy,

as Joseph has noted RIP converts network commands to major network boundary.

This happens for both RIPv1 and RIPv2.

If it is your desire to have RIPv2 running only on selected interfaces of major network 10/8 you need to use the passive-interface command.

It is the only tool left to you.

if there are many interfaces to be left passive you can use

router rip

passive-interface default

no passive-interface intf1

no passive-interface intf2

see

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_ip_prot_indep_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1056595

Be aware that because RIPv2 still misses neighbor state concept your router can hear RIP routes on passive interfaces.

To avoid this the only tool for RIPV2 is a mismatching authentication configuration so that these updates are not accepted.

see

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_cfg_info_prot_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1055128

OSPF and EIGRP allows to specify a wildcard mask to mean only subsets of major networks should be running.

Hope to help

Giuseppe

Community Member

Re: RIP Configs

HI Giuseppe,

No, this is not necessary to run rip v2. only looking for as requested, i.e on output only given subneteed will reflect.

regards

Super Bronze

Re: RIP Configs

Some while back, while doing some RIPv2 testing, I recall I discovered the same, i.e. Cisco RIPv2 converts "router RIP" configured network statement addresses to their classful boundaries. It's been a while, so I don't recall all the details, but don't believe I found a work around, and also believe results weren't tied to usage of auto-summary or not (which I think dealt with what RIP advertized).

I do recall I was disappointed that RIPv2 didn't work more like OSPF/EIGRP, although it could do a bit more than RIPv1. For instance, you can deal with discontinous subnets, but also recall I had to play with different classful subnets on transit links to advertize just some intended summaries.

Perhaps someone with extensive Cisco RIPv2 could add to this discussion.

Re: RIP Configs

I completely misread your question yesterday when I answered you. You're seeing "network 10.0.0.0" under the running config for your 10.x.x.x networks, and like the others said, that's normal.

I thought you were being summarized in your routing table and you weren't seeing your specific networks which is what auto-summary would fix. With auto-summary, you would see something like:

R 10.0.0.0/8 via

But with auto-summary turned off you would see something like:

10.0.0.0/24 is subnetted

R 10.15.15.0 via

Sorry for the confusion. Also, if RIP isn't a requirement, I would suggest going with OSPF or EIGRP. If you have equipment other than Cisco, OSPF would be your best bet since it's a standard. If you have ALL Cisco equipment, then you can use EIGRP (Cisco proprietary).

HTH,

John

HTH, John *** Please rate all useful posts ***
185
Views
0
Helpful
6
Replies
CreatePlease to create content