Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

rip into ospf redistribution

Hello, I have two routers. Taupo  router is running RIP version2. Huntly Router is running OSPF. They are  both communicating using Frame Relay.

I want to redistribute RIP routes from Taupo into Huntly. I have attached my relevant running-config details for each router.

Can anyone please tell me where I am going wrong, as this is not working.

I  have also attached an image of the network. The two routers I am  talking about here are on the ones on the far right hand side.

Thanks for any help.

Taupo router:

router rip

version 2

redistribute ospf 43 metric 1

network 172.26.0.0

no auto-summary

Huntly Router:

router ospf 43

log-adjacency-changes

passive-interface FastEthernet0/0

passive-interface FastEthernet0/0.15

passive-interface FastEthernet0/0.25

passive-interface FastEthernet0/0.86

network 172.26.252.4 0.0.0.3 area 0

network 172.26.15.0 0.0.0.127 area 0

network 172.26.25.0 0.0.0.127 area 0

network 172.26.86.0 0.0.0.15 area 0

!

ip classless

Everyone's tags (3)
4 REPLIES
Hall of Fame Super Silver

Re: rip into ospf redistribution

Hello Philip,

>> I want to redistribute RIP routes from Taupo into Huntly OSPF

in your current configuration you are actually doing the opposite:

router rip

version 2

>>>>redistribute ospf 43 metric 1

network 172.26.0.0

no auto-summary

you are redistributing OSPF routes from OSPF process-id 43 into RIP with a seed metric of 1.

if you want to redistribute RIP routes into OSPF you need to do the following:

router rip

no redistribute ospf 43

router ospf 43

redistribute rip subnets metric 50

Note: the subnets keyword is important to avoid an automatic summarization to major networks ( Class A, B.C)  that OSPF would do otherwise.

First router has to be OSPF neighbor of the second router on the interface connecting the two device.

if so this change is enough

redistribute command has to be configured under the protocol that will receive the routes and not under the protocol that is exporting the routes.

Hope to help

Giuseppe

New Member

Re: rip into ospf redistribution

Thank you Giuseppe, that is very good information, but I still canot get it to work.

Can you see what I am doing wrong below ? I made some changes based on what you told me.

This is my router that is running OSPF. I want this router to receive RIP subnets from the other router:

router ospf 43

log-adjacency-changes

redistribute rip metric 50 subnets

passive-interface FastEthernet0/0

passive-interface FastEthernet0/0.15

passive-interface FastEthernet0/0.25

passive-interface FastEthernet0/0.86

network 172.26.252.4 0.0.0.3 area 0

network 172.26.15.0 0.0.0.127 area 0

network 172.26.25.0 0.0.0.127 area 0

network 172.26.86.0 0.0.0.15 area 0

!

ip classless

This is my second router that is running RIP. I want this router to send it's RIP routes to the first router above:

router rip

version 2

network 172.26.0.0

no auto-summary

!

ip classless

Purple

Re: rip into ospf redistribution

Hi,

the redistribution router MUST run the 2 protocols otherwise it can't redistribute aand from your config snippets I don't see any RIP configured on Huntly.

Then you won't see the redistributed routes on the redistribution router but on a router which is in the routing domain you are redistributing into.

They will appear as OE2 routes on Hamilton and Waii if they run OSPF.

Regards.

Alain

Don't forget to rate helpful posts.
Hall of Fame Super Silver

rip into ospf redistribution

Hello Philip,

>> This is my router that is running OSPF. I want this router to receive RIP subnets from the other router:

====>   so it must run RIP too, and to have a common link with the other router to become RIP neighbor, and to receive the RIP routes

A router running both routing protocols is needed that will act as ASBR, (Autonomous system Boundary Router) sort of translator.

You cannot translate from french to english if you don't speak both!

Hope to help

Giuseppe

3958
Views
0
Helpful
4
Replies
CreatePlease to create content