Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Rip (LNS->CE) in VRF

Trying to get our LNS (7200) to exchange routes with L2TP DSL connection without success - I have the following:

CE: (Not NAT Enabled, Assigned 10.0.0.2 to Dialer Int, and placed in vrf TEST10 via Radius)

interface Ethernet0

description LAN

ip address 192.168.1.1 255.255.255.0

no keepalive

!

!

router rip

version 2

redistribute static

network 10.0.0.0

network 192.168.1.0

neighbor 10.0.0.1

no auto-summary

!

test#show ip rip database

0.0.0.0/0 auto-summary

0.0.0.0/0 redistributed

[1] via 0.0.0.0,

10.0.0.0/8 auto-summary

10.0.0.1/32 directly connected, Dialer1

10.0.0.2/32 directly connected, Dialer1

192.168.1.0/24 auto-summary

192.168.1.0/24 directly connected, Ethernet0

Then on PE:

ip vrf TEST10

rd 17766:10

route-target export 17766:10

route-target import 17766:10

maximum routes 256 75

!

!

interface Loopback10

ip vrf forwarding TEST10

ip address 10.0.0.1 255.255.255.0

!

!

interface Loopback1

description BNE-LNS-1 Interface

ip address 203.149.76.243 255.255.255.255

!

!

interface Virtual-Template1

description L2TP-1 Termination

ip unnumbered Loopback1

qos pre-classify

ppp authentication chap callin

!

!

router rip

version 2

neighbor 10.0.0.2

!

address-family ipv4 vrf TEST10

redistribute bgp 17766 metric 2

network 10.0.0.0

network 192.168.1.0

network 203.149.76.0

no auto-summary

version 2

exit-address-family

!

router bgp 17766

address-family ipv4 vrf TEST10

redistribute connected

redistribute static

redistribute rip

no auto-summary

no synchronization

exit-address-family

#sh ip rip database vrf TEST10

10.0.0.0/8 auto-summary

10.0.0.0/24 directly connected, Loopback10

10.0.0.2/32 directly connected, Virtual-Access7

10.0.3.0/24 redistributed

[2] via 203.149.76.248,

10.0.5.0/24 redistributed

[2] via 203.149.76.249,

10.0.6.0/24 redistributed

[2] via 203.149.76.250,

10.0.7.0/24 redistributed

[2] via 203.149.76.247,

If I add a static route for 192.168.1.0/24 -> 10.0.0.2 (vrf TEST10), I can successfully get to CE LAN from PE

Any suggestions greatly appreciated.

Regards,

MB

1 REPLY
Bronze

Re: Rip (LNS->CE) in VRF

Try this link for troubleshooting a similar configuration connectivity.

http://www.cisco.com/warp/public/121/mpls_bgp_rip.html

139
Views
0
Helpful
1
Replies
CreatePlease login to create content