Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RIP routing problem

Hi,

Situation:

4 routers. 2 c1751-V and 2 c805.

Star topology.

One of the two c1751 is the central router with 3 serial interfaces:

PlC - s0/0:0 - 2Mbps - s0/0:0 Pl1

PlC - S1/0 - 64kbps - s0 Pl2

PlC - s1/1 - 64kbps - s0 Pl3.

IP-s:

PlC fa0/0: 192.168.1.0/24

PlC s0/0:0: 192.168.98.113/30

PlC s1/0: 192.168.98.117/30

PlC s1/1: 192.168.98.121/30

Pl1 fa0/0: 10.2.20.0/24

Pl1 s0/0:0 192.168.98.114/30

Pl2 eth0: 10.2.30.0/24

Pl2 s0: 192.168.98.118/30

Pl3 eth0: 10.2.40.0/24

Pl3 s0: 192.168.98.122/30.

I'd like a very simple config. I want to see every network each router.

My problem is: the branch routers can't see the 10 network!

Exctract from the routing table of PlC:

192.168.98.0/30 is subnetted, 3 subnets

C 192.168.98.120 is directly connected, Serial1/1

C 192.168.98.112 is directly connected, Serial0/0:0

C 192.168.98.116 is directly connected, Serial1/0

R 10.0.0.0/8 [120/1] via 192.168.98.122, 00:00:26, Serial1/1

[120/1] via 192.168.98.118, 00:00:09, Serial1/0

[120/1] via 192.168.98.114, 00:00:18, Serial0/0:0

C 192.168.1.0/24 is directly connected, FastEthernet0/0

And here is the Pl1 routing table:

192.168.98.0/30 is subnetted, 3 subnets

R 192.168.98.120 [120/1] via 192.168.98.113, 00:00:00, Serial0/0:0

C 192.168.98.112 is directly connected, Serial0/0:0

R 192.168.98.116 [120/1] via 192.168.98.113, 00:00:00, Serial0/0:0

10.0.0.0/24 is subnetted, 1 subnets

C 10.2.20.0 is directly connected, FastEthernet0/0

R 192.168.1.0/24 [120/1] via 192.168.98.113, 00:00:00, Serial0/0:0

RIP config on PlC:

router rip

version 2

passive-interface FastEthernet0/0

network 192.168.1.0

network 192.168.98.0

no auto-summary

RIP config on Pl1:

router rip

version 2

redistribute connected

network 10.0.0.0

network 192.168.98.0

What can I do wrong?

I tried out many config without success.

TIA,

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: RIP routing problem

On your branch routers

router rip

no auto-summary

Jon

7 REPLIES
Hall of Fame Super Blue

Re: RIP routing problem

On your branch routers

router rip

no auto-summary

Jon

New Member

Re: RIP routing problem

Hi,

Just those two lines or no auto-summary was missing from my config?

TIA,

Hall of Fame Super Blue

Re: RIP routing problem

Sorry for the confusion. Just add "no auto-summary" to the existing rip configuration.

Jon

New Member

Re: RIP routing problem

Hi,

Never mind!

Thanks for your help!

I made a new config with and without my previous commands and now it is working. :-)

I removed redistribute connected lines, too.

Best regards,

New Member

Re: RIP routing problem

Hi,

My next problem related to the previous hw configuration but the WAN part was absolutelly different and I don't understand what was the problem.

Topology is the same.

Addresses of the WAN interfaces were:

PlC s0/0:0: 10.1.1.1/24

PlC s1/0: 10.1.1.2/24

PlC s1/1: 10.1.1.3/24

Pl1 s0/0:0 10.1.1.4/24

Pl2 s0: 10.1.1.5/24

Pl3 s0: 10.1.1.6/24.

PlC and Pl1 don't ping each other. Pl2,3 could ping PlC.

RIP was switched of. The config full of static routes.

I hate this config and I changed to the mentioned config which is working perfectly. I'd like to know what is the problem at this "shared" WAN IP addresses.

TIA,

Hall of Fame Super Blue

Re: RIP routing problem

Are you using frame-relay on the WAN ?

New Member

Re: RIP routing problem

Where the ping doesn't work is a G.704 mode over SDH P-P connection with VWIC2-1MFT T1/E1 card.

PlC-Pl2;3 is going to an NTU which are connected to the same SDH with WIC-2T.

On the routers there aren't any FR related config.

TIA,

150
Views
0
Helpful
7
Replies