Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RIP updates do not appear in the RIP Database

I've enabled RIP on a vlan segment. I am receiving RIP updates from 3 routers on the segment as verified with "debug ip rip" but the updates from 1 of the routers never make it into the RIP database. Updates from the other 2 routers do make it into the DB. I do not have any filters set in rip (yet...)

Any reason why this would be happening, and how can I resolve it.

5 REPLIES
Silver

Re: RIP updates do not appear in the RIP Database

do you have a split horizon senario?

Hall of Fame Super Silver

Re: RIP updates do not appear in the RIP Database

Hello Anthony,

are the updates sent by the third router the same as the other two but with an higher metric (hop count)

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: RIP updates do not appear in the RIP Database

Anthony

If the good suggestion from Giuseppe is not the solution, then it would be helpful if you would post the debug rip output so that we can see some of the details of what is advertised and accepted and what is advertised but not accepted.

HTH

Rick

Community Member

Re: RIP updates do not appear in the RIP Database

Here is the debug ip rip output. The updates received on vlan 50 are being entered into the RIP database, but the updates received on vlan 110 are not being entered into the RIP Database. I am only sending updates on vlan110

26w4d: RIP: received v2 update from 10.10.10.11 on Vlan110

26w4d: 172.20.1.0/24 via 0.0.0.0 in 1 hops

26w4d: 208.224.251.0/24 via 0.0.0.0 in 1 hops

26w4d: 209.208.175.0/24 via 0.0.0.0 in 1 hops

26w4d: RIP: received v2 update from 10.50.0.15 on Vlan50

26w4d: 69.184.0.0/26 via 0.0.0.0 in 5 hops

26w4d: 69.184.1.0/26 via 0.0.0.0 in 4 hops

26w4d: 69.184.4.0/26 via 0.0.0.0 in 5 hops

26w4d: 69.184.5.0/26 via 0.0.0.0 in 4 hops

26w4d: RIP: received v2 update from 10.50.0.14 on Vlan50

26w4d: 69.184.0.0/26 via 0.0.0.0 in 4 hops

26w4d: 69.184.1.0/26 via 0.0.0.0 in 5 hops

26w4d: 69.184.4.0/26 via 0.0.0.0 in 4 hops

26w4d: 69.184.5.0/26 via 0.0.0.0 in 5 hops

26w4d: RIP: sending v2 update to 224.0.0.9 via Vlan110 (10.10.10.2)

26w4d: RIP: build update entries

26w4d: 10.31.0.0/16 via 0.0.0.0, metric 1, tag 0

26w4d: 10.32.0.0/16 via 0.0.0.0, metric 1, tag 0

Hall of Fame Super Gold

Re: RIP updates do not appear in the RIP Database

Anthony

Thannk you for the additional information. It does confirm that the problem is not overlapping addresses with RIP advertisements from the other routers. But it does not point clearly to what the problem is. Can you verify that the prefixes advertised on vlan110 (172.20.1.0, 208.224.251.0, and 209.208.175.0) are not learned from some other source (other protocol)? Could you post the router config and perhaps the output of show ip interface brief?

HTH

Rick

209
Views
0
Helpful
5
Replies
CreatePlease to create content