Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RIP

Hi fellas!

Hi a doubt about rip protocol.

I have one router 1811 with IOS 12.4 and a switch 3550 with ip routing capabilities.

In the router side

router rip

ver 2

network 20.0.0.0

network 172.16.0.0

In the switch side

router rip

ver 2

network 20.0.0.0

network 10.0.0.0

also in the switch 2 ports are configured with "no switchport"with the respetive ip addres for each network.

The question, why doesn't work when I send ping from one computer to other?

Thx for your cooperation!

5 REPLIES
Community Member

Re: RIP

Dear Cabrera,

Your Configuration is ok.

On switch you have said there are two nos of ports are configured with ""no switchport"" cmd. It means this two ports are now L3 Ports. so both the ports have now different Network.

If I have understand correctly what you said than I suggest:

Create Vlan 3 for Hosts with Ip address say : 10.0.0.0

Create Vlan 2  or  intterface with no switchport cmd to connect to router with 20.0.0.0

Now these two ports are configured with

int fa0/1

switchport mode access

switchport access vlan 3

fa0/2

switchport mode access

switchport access vlan 3

Port connected to Router :

if Vlan than

int fa0/15

switchport mode access

switchport access vlan 2

if port with noswitch port cmd

than

int fa0/15

no switchport

ip add 20.0.0.1 255.0.0.0

or................

If you have no vlan than said both port should be in different NW and both NW must be advertised in RIP v2.

This will also works

Hope this will help you.

Do not forget to rate the post if it will help you.

Regards,

Cisco Employee

Re: RIP

Hello,

What are the default gateways of the computers? On the switch side it should point to the 20.x.x.x address on the switch and on the router side it should be 172.16.x.x. You can verify the working of the routing protocol by checking the routing table of each device to make sure that they are seeing the route from the other device (show ip route).

Hope this helps.

Regards,

NT

Community Member

Re: RIP

HI,Josue Cabrera!

Can you provide the topology to describe how is your device connect and post the route table here?

Tks,

Best regards!

sky.h

Community Member

Re: RIP

My friends!!!

thanks for u support....

I don´t have visio to draw the diagram... I hope this description help.

LAN (172.16.0.0)<------>Router (R1)<-------->SW <--------->LAN (10.0.0.0)

I check and re-check the configuration and seems ok...

Note: when send a ping from one pc (172.16.0.0) to other pc in network (10.0.0.0) I see packet loss.

Community Member

Re: RIP

Hi,Josue Cabrera.

1.By default, IP routing is disabled on the 3550 switch.Have you enable it?

2.Can you ping succeed  from the PC(172.16.X.X) to the Router's 20.X.X.X interface and The Switch's 20.X.X.X interface?

Best regareds,

sky.h

460
Views
0
Helpful
5
Replies
CreatePlease to create content