Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RIP2 and Default Gateways

I am following the example in the "Cisco-Configuring a Gateway of Last Resort Using IP Commands" document, but am not having much luck.

I have RIP2 working and distributing routes for the locally connected subnets but I cannot get the host to distribute it's default gateway to my remote.

Before anyone asks why I am using RIP2, I have some legacy devices out there that don't support anything else all that well..

I set the ip default-network on the host router and the show ip route command lists the proper gateway of last resort, but it never makes it to the remote.

I am sure I'm missing something simple, but can't seem to nail it down.

At the moment I don't have the host and remote in the live network. They are connected via a T1 crossover cable and a pc is attached to an Ethernet port on each router.

Any suggestions would be appreciated.

Denny

23 REPLIES

Re: RIP2 and Default Gateways

Denny,

It would be nice to see the configs on both routers.

New Member

Re: RIP2 and Default Gateways

The config for the host router is listed below.This router is just running the IPBase. I don't have access to the remote routers config, since I'm responding from home.

The remote router has an extremeley basic configuration as well. The only difference is it has the FW feature set. I'm not sure if this would affect this, but I wouldn't think so. These just came out of the box and I enabled a FastEthernet port and a serial port on each to play with RIP2 beforing replacing our legacy host router with this one.

I had them pinging each other via static routes to verify connectitivity, then removed the static routes and enabled RIP2.

The routing updates for each others FastEthenet subnets came across properly, I just need the host routers default gateway to transfer to the remote router.

Thank you for taking a look

Building configuration...

Current configuration : 1843 bytes

!

version 12.3

no service timestamps debug uptime

no service timestamps log uptime

no service password-encryption

!

hostname PHX2811

!

boot-start-marker

boot-end-marker

!

card type t1 0 0

no logging buffered

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

!

ip name-server 192.168.20.17

ip name-server 192.168.20.27

no ftp-server write-enable

!

!

controller T1 0/0/0

framing esf

linecode b8zs

channel-group 1 timeslots 1-24

!

controller T1 0/0/1

framing esf

clock source internal

linecode b8zs

channel-group 1 timeslots 1-24

!

!

interface FastEthernet0/0

description $ETH-LAN$

ip address 192.168.4.2 255.255.255.0

duplex half

speed auto

no cdp enable

no mop enabled

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

no cdp enable

!

interface Serial0/0/0:1

no ip address

!

interface Serial0/0/1:1

ip unnumbered FastEthernet0/0

!

interface BRI1/0

no ip address

shutdown

!

interface BRI1/1

no ip address

shutdown

!

interface BRI1/2

no ip address

shutdown

!

interface BRI1/3

no ip address

shutdown

!

interface BRI1/4

no ip address

shutdown

!

interface BRI1/5

no ip address

shutdown

!

interface BRI1/6

no ip address

shutdown

!

interface BRI1/7

no ip address

shutdown

!

router rip

version 2

network 192.168.4.0

network 192.168.20.0

!

ip classless

ip default-network 192.168.20.0

ip route 0.0.0.0 0.0.0.0 192.168.4.1

ip route 192.168.20.0 255.255.255.0 192.168.4.1

!

ip http server

!

!

control-plane

!

scheduler allocate 20000 1000

no process cpu extended

no process cpu autoprofile hog

!

end

Silver

Re: RIP2 and Default Gateways

can you give a default-information originate under router rip and see if it works??

Hall of Fame Super Silver

Re: RIP2 and Default Gateways

I suspect that default-information originate will work. I believe that partly Denny wants something that works, but he also wants to know why his configuration with default-network is not working. I believe that the answer is that the router is not learning the 192.168.20.0 via RIP but sees it as a local static route. If there is some classful network that the router is learning via RIP I believe that it would work as a default-network, but not a locally originated route.

Assuming that the router has a RIP neighbor on the FastEthernet 0/0 interface, if the router is learning some classful network from that neighbor, then try using that classful network as the default-network. Otherwise you probably should use default-information originate.

HTH

Rick

New Member

Re: RIP2 and Default Gateways

First I would like to thank both of you for responding.

The default gateway for this router is a Cisco Pix, which as I recall will not advertise routes, so a static is requried.

I will try the default information originate and see if that solves my problem.

Thanks,

New Member

Re: RIP2 and Default Gateways

Is this default-information originate supposed to be setup on the host or the remote?

I set it up on the host and the default route is still not being distributed to the remote.

Using Cisco Document ID 16448 I was able to get the remote to use the host as it's default gateway by setting the "ip default-network 192.168.4.0" on the remote. When RIP distributes the routes this seems to set the gateway of last resort to my host router.

Although this does work, it seems to go against the benefits of using a routing protocol. Should the network addressing (192.168.4.0) change, we'd have to go back and change the ip default-network on each remote to force them to use the host as their default gateway.

What we are ultimately trying to do is use floating static routes to enable DDR backup. The host will initiate all the dialing to the remotes.

Hall of Fame Super Silver

Re: RIP2 and Default Gateways

Denny

The default-information originate is set up on the host. It occurs to me that it will get the host to advertise a gateway of last resort to the remote - assuming that the host has learned a default route. It might help us understand better if you would post the output of show ip route on the host router. Or if the routing table is extensive just post the header info of the display and any default route (or not) that show up in the table.

HTH

Rick

New Member

Re: RIP2 and Default Gateways

The host has a static default route. Here is show route

PHX2811#show ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.4.1 to network 0.0.0.0

C 192.168.4.0/24 is directly connected, FastEthernet0/0

S* 0.0.0.0/0 [1/0] via 192.168.4.1

PHX2811#

Gold

Re: RIP2 and Default Gateways

"I set the ip default-network on the host router and the show ip route command lists the proper gateway of last resort, but it never makes it to the remote."

Try using a default route (0.0.0.0 0.0.0.0) rather than the default-network command. First, only EIGRP and IGRP actually support the default-network, as far as propagating it through the routing protocol. Second, the default-network command is being removed from IOS at some point in the (near) future.

:-)

Russ.W

New Member

Re: RIP2 and Default Gateways

Hi Russ,

On the host router (the one that I want to advertise as the default gateway to the remotes)this is what I have and that's it..

0.0.0.0 0.0.0.0 192.168.4.1

It is not distributing this to my remote. It is distributing the 192.168.4.0 255.255.255.0 route but not the default gateway.

Perhaps I have a bugged version IOS installed..

12.3(14)T4

Bronze

Re: RIP2 and Default Gateways

RIPv2 is supposed to redistribute default routes automatically.

You can turn on RIP debugging to see what your router is actually sending.

debug ip rip

or

debug ip rip event

Daniel

New Member

Re: RIP2 and Default Gateways

Yeah, I think I'm going to try a different version IOS. It really sucks when you follow the examples and it doesnt work..

Re: RIP2 and Default Gateways

As suggested, its wise to do a debug ip rip, before doing the upgrade.

New Member

Re: RIP2 and Default Gateways

I did debug ip rip and debug ip rip events and it does not appear the host router is distributing the default gateway.. I tried the IOS upgrade as well 12.14(T4) with the same results. Actually this debug output if from this latest IOS version.

Here is a snapshot of the output of debug and below that is the host routers show ip routes

192.168.23.0/24 via 0.0.0.0, metric 2, tag 0

RIP: Update contains 1 routes

RIP: Update queued

RIP: Update sent via FastEthernet0/0

RIP: received v2 update from 192.168.23.1 on Serial0/0/1:1

192.168.23.0/24 via 0.0.0.0 in 1 hops

RIP: Update contains 1 routes

RIP: sending v2 update to 224.0.0.9 via Serial0/0/1:1 (192.168.4.2)

RIP: build update entries

192.168.4.0/24 via 0.0.0.0, metric 1, tag 0

RIP: Update contains 1 routes

RIP: Update queued

RIP: Update sent via Serial0/0/1:1

RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.4.2)

RIP: build update entries

192.168.23.0/24 via 0.0.0.0, metric 2, tag 0

RIP: Update contains 1 routes

RIP: Update queued

RIP: Update sent via FastEthernet0/0

PHX2811#show ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.4.1 to network 0.0.0.0

C 192.168.4.0/24 is directly connected, FastEthernet0/0

R 192.168.23.0/24 [120/1] via 192.168.23.1, 00:00:15, Serial0/0/1:1

S* 0.0.0.0/0 [1/0] via 192.168.4.1

PHX2811#

Silver

Re: RIP2 and Default Gateways

Could you remove the default-netowrk (if it is there) in the host router (retain only the 0.0.0.0 Route) and check ? Can you show the RIP debug and the routing table in the remote router

Gold

Re: RIP2 and Default Gateways

"RIPv2 is supposed to redistribute default routes automatically."

Not in later versions of code.... I'm not certain when it changed, but sometime around when the RIP database went in. You must redistribute all routes, including the default, for RIP to redistribute it.

Russ.W

New Member

Re: RIP2 and Default Gateways

Hello,

I've tried

Redistribute Static (on the host)

Default-information originate (on the host)

IP Default-network (on the remote)

The IP Default-Network on the remote did work, but should the default gateway ever change on the host then I would have to go in and reconfigure all of those remotes with the new IP Default-Network.

The Default-information originate with a route map setup on the host router looked like it was working. While running debug ip rip I could see 0.0.0.0 being built, but the debug ip rip on the remote never showed it coming across.

I've been fighting with this for two weeks, so I am throwing in the towel and opening a ticket with the TAC.

Thank you all for your suggestions..

Denny

Hall of Fame Super Silver

Re: RIP2 and Default Gateways

Denny

When you tried to do redistribute static did you have a default metric configured? A valid default metric is generally essential to successful redistribution.

HTH

Rick

New Member

Re: RIP2 and Default Gateways

I didn't, but that was the first thing the TAC suggested I try.

Unfortunately that didn't work either..

Hall of Fame Super Silver

Re: RIP2 and Default Gateways

Denny

I do not want to replicate what the TAC is doing. But perhaps you could post the configs with the static default and the redistribute static for us to look at.

HTH

Rick

New Member

Re: RIP2 and Default Gateways

The TAC was able to figure it out.

He was able to duplicate my problem in his lab and duplicated my problem.

The one command that fixed it

"NO AUTO-SUMMARY" on both routers under the Router Rip section.

Thank you all for you suggestions and help with this problem.

Now I can move on to DDR backups using floating static routes..

Hall of Fame Super Silver

Re: RIP2 and Default Gateways

Denny

Thanks for closing the loop and letting us know what the resolution of the problem was. It is very helpful in the forum when we can associate the solution with the problem that we have been looking at.

I will admit that I am surprised that no auto-summary was the solution. I will have to think a bit about why auto-summary would interfere with redistribution of the default route.

HTH

Rick

lh
New Member

Re: RIP2 and Default Gateways

Hi our there

I have had this problem with RIP and defaul-information originate

I tried the no-autosummary - and it didn't work :(

Though, I found a way to get it work :)

It seems that typing the command "default-information originate" does not put the 0.0.0.0/0 in the RIP database :) - sh ip rip database

if I make a "clear ip route *" the 0.0.0.0/0 get into the RIP database, and everything does function.

This was tested on ver.12.2(30) (jk8s-mz version)

Why the clear ip route is needed, I don't understand - A bug in the IOS :)

Lennart

863
Views
0
Helpful
23
Replies