cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1328
Views
18
Helpful
17
Replies

route advertisement issue

Hi,

I am using 6 routers in gns3 and there is a problem in route advertisements.

R2 is in AS 200, R3,R4,R5 are in AS 100 and R6 is in AS 300,

R2-> R3 eBGP

R3,R4,R5 are in same AS, iBPG(using Route reflector instead of fullmesh iBGP)

R5-> R6 eBGP.

R3 to R4 i have used next-hop-self and same with R5 to R4.

Syn is off.

Now the problem is R4 is not advertising eBGP routes to either side, so there is no reachability from R2 to R6.

Please help me with this, Where i have gone wrong, and what changes can i make to make this work.

Below are the configs and topology i have used.

config for R6 (cannot attach more than 5 files, so m adding config of R6 here)

!

interface Loopback0

ip address 6.6.6.6 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface GigabitEthernet1/0

ip address 86.96.2.1 255.255.255.252

negotiation auto

!

router bgp 300

no synchronization

bgp log-neighbor-changes

network 86.96.2.0 mask 255.255.255.252

neighbor 5.5.5.5 remote-as 100

neighbor 5.5.5.5 ebgp-multihop 2

neighbor 5.5.5.5 update-source Loopback0

no auto-summary

!

ip route 5.5.5.5 255.255.255.255 GigabitEthernet1/0 250

!

interface Loopback0

ip address 6.6.6.6 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface GigabitEthernet1/0

ip address 86.96.2.1 255.255.255.252

negotiation auto

!

router bgp 300

no synchronization

bgp log-neighbor-changes

network 86.96.2.0 mask 255.255.255.252

neighbor 5.5.5.5 remote-as 100

neighbor 5.5.5.5 ebgp-multihop 2

neighbor 5.5.5.5 update-source Loopback0

no auto-summary

!

ip route 5.5.5.5 255.255.255.255 GigabitEthernet1/0 250

17 Replies 17

Vivek Ganapathi
Level 4
Level 4

Below are the two thing you have missed.

  • On R3, if you were to receive a route 86.96.2.0/30 , you would notice that the Next Hop would be set to R5's loopback0. You will need to have a static route to 5.5.5.5 pointing towards R4.
  • On R5 if you were to receive a route 86.96.1.0/30, you would notice that the Next Hop would be set to R3's loopback0. You will need to have a static route to 3.3.3.3 pointing towards R4.

Apart from that, i noticed on R2 on your config upload, you have the below statements which is not required.

ip route 86.96.1.0 255.255.255.252 GigabitEthernet1/0
ip route 86.96.1.0 255.255.255.252 192.168.1.1

Note : Just wanted to highlight something here. If you were not having static routes to reach the next-hop, then you were to rely upon BGP's next-hop-self command. Using BGP's next-hop-self on a RR will have no effect (as of 12.4 release). You may need to use a route-map feature to set the next-hop manually. Though in your situation using a static route has no harm.

Hope this helps.

Regards

Vivek

Hi Vivek,

i got your point but what is a good practice, using static routes or an IGP.

i will try with static routes and find if there is any issue.

Hi,

There is no specific good practices defined i believe. It's solely upto to the implementors strategy. Running an IGP is a good option, it would avoid using the route-reflector feature.

Overall, there is no hard & fast rule.

Thanks

Vivek

also, note that IGP is an extra overhead on your router's CPU.

it all depends upon what all routes your router will accept. if you have specific route-maps to accept only required routes via BGP, you could use an IGP, but from what I have seen and worked on, it is all static from CE to PE.

Hi Vivek,

Running an IGP is a good option, it would avoid using the route-reflector feature.

I don't see the relationship between them whatsoever. As far as I know RR are used to circumvent the iBGP split-horizon rule not to solve the next-hop unreachability which is the role of a routing protocol or static routes.

Regards.

Alain

.

Don't forget to rate helpful posts.

Hi Alain,

If i were to run an IGP protocol between all the routers internally (Assuming R3->R4->R5), then i dont need R4 to be a route-reflector. Yes it is to circumvent the iBGP split horizon which says not to allow the routes learnt via iBGP to be advertised back to an iBGP peer. Herein, by running the IGP between those devices, i would not have the split horizon issue at all. R3->R5 will be iBGP peer via R4.

Thats what i meant to say "By running IGP i would avoid configuring the route-reflector. Hope my understanding is right. Do comment incase it is not.

Thanks

Vivek

Hi Vivek,

my understanding is that to avoid running a RR you have to run a full mesh of iBGP  and in all cases you've got to have next-hop reachability which is provided by IGP or static routing.

Please comment if you think my understanding is incorrect.

Alain.

Don't forget to rate helpful posts.

Thanks for the reply Alain. You are absolutely correct. To avoid running a RR, we need to run a iBGP full mesh.

Does my thinking still holds good? Running IGP between three routers can avoid using an RR. As RR is used to tackle the BGP split horizon rule which says i cannot advertised a route learnt via iBGP back to another iBGP peer. Now, by running an IGP (i.e EIGRP/OSPF) between routers, i won't step on that rule because i am no longer learning a route via iBGP & neither advertising to an iBGP peer.

I have attached a diagram (swiftly created) so lil shabby

I may be wrong in my understanding, please do correct me as well.

Vivek.

Hi,

Your config won't need any RR indeed but you'll have to redistribute BGP into OSPF if you want R4 subnet to communicate with either external ASes and you will lose the possibility of doing traffic engineering for outgoing traffic using BGP policies.

Regards.

Alain

Don't forget to rate helpful posts.

Right Alain. Outbound will be using OSPF cost metric to determine the primary path. But for inbound, we can go with AS path prepending.

Hi Vivek,

consider we are using only bgp then definately we need ibgp sessions in same AS, so in this scenario either we should  have iBGP full mesh or Route-reflectors for routes to be advertised from ibgp peer to another ibgp peer as per understanding so far. Is there any other alternative other than RR and iBGP full mesh???

Hi Syed,

Thats exactly what Myself & Alain were discussing. If you don't need RR & iBGP, then just go with running an Interior Gateway routing protocol (i.e EIGRP or OSPF) internally. The only issue with this would be that you have to rely upon the traffic engineering for your outbound using EIGRP or OSPF. Whereas for your inbound you can still do it with BGP.

Hope you are clear with this. Do let me know incase you need more clarity.

Regards

Vivek

One more doubt i had about Route-reflector is can we have a single router as client for 2 different router-reflectors,

ex,   R1 connected to R2 and R2 connected to R3 and R3 connected to R4 and R4 back to R1

   Now R1 is connected to eBGP peer and R3 is also connected to eBGP peer.

so according to me R2 and R4 should be RR and R1 and R3 should be RR-client, 

Am i right.

can some one clear this doubt please.

Review Cisco Networking products for a $25 gift card