Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route data and voice over separate Wan connections

Our network has about 20 sites, most sites are setup with a single router connected to two different carriers MPLS VPNs via T1s.  We use OSPF with a single area that is re-distributed by the carriers via BGP.

The ospf configuration on the routers is typically:

router ospf 1000

log-adjacency-changes

network 10.10.0.0 0.0.255.255 area 0

The Ethernet connection to the internal site network would be typically:

interface Ethernet0/0

no ip address

ip helper-address 10.10.38.51

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting access-violations

ip route-cache flow

full-duplex

no cdp enable

!

interface Ethernet0/0.41

encapsulation dot1Q 41

ip address 10.10.9.1 255.255.255.0

ip helper-address 10.10.38.51

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting access-violations

no cdp enable

interface Ethernet0/0.83

description Voice__Vlan

encapsulation dot1Q 83

ip address 10.10.83.1 255.255.255.0

ip helper-address 10.10.38.51

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting access-violations

no cdp enable interface Ethernet0/0
no ip address
ip helper-address 10.10.38.51
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting access-violations
ip route-cache flow
full-duplex
no cdp enable
!

We would like to route traffic destined for the data subnet to go thru one carrier primarily with fail over to the other carrier and route the traffic destined for the voice subnet thru the other carrier primarily with fail over to the carrier primarily used by the data subnet.  Ideally, it would be best if this fail over process was automatic, however if that's not possible I think we could manage with a manual process.  We don't have out of band management for every location, so any changes/fail over scenario would ideally not require it.  I have looked at some material in regards to distribute-list, route-map and assigning ospf areas per interface, but haven't really seen anything ties in exactly with my scenario.  I would appreciate if someone could provide a suggested configuration or point to a link that matches the scenario I have laid out.

9 REPLIES

Route data and voice over separate Wan connections

Hi Ken,

Before suggesting solution, would like to know what is the status of your  routing table under normal circumstances.

What I mean to ask is as you said that you have 2 MPLS providers and you running bgp with them and then redistributing BGP into OSPF.

Can you post the output of below commands highlighting the Data and Voice Subnets.

show run | sec bgp

show run | sec ospf

show ip bgp

show ip route

Regards,

Smitesh

New Member

Route data and voice over separate Wan connections

Hi Smitesh,

I don't have access to the carrier routers, so I can't do a "sho ip bgp", however one of the carriers allows you to see part of the router config associated with your locations via web interface.  The "sho run | sec ospf" display the same ospf info as I previously published.

Carrier's config with bgp :

!---------------Interface Configuration Data from Last File Backup---------------
interface Serial5/1/1/24:0
description FMS76776364/47505182-O, By VPNSC: Job Id# = 137801
ip vrf forwarding V7636:company19
ip address 10.10.233.133 255.255.255.252
no ip directed-broadcast
no cdp enable
service-policy output ipcos-company19-47505162-Q1C1

!-----------Policy Map Config Section for ipcos-company19-47505162-Q1C1------------
policy-map ipcos-company19-47505162-Q1C1
  class dscp46
    priority
   police rate percent 50
  class dscp26
    bandwidth percent 5
  class dscp24
    bandwidth percent 20
  class dscp22
    bandwidth percent 10

!----------------------Class Map Config Section for dscp46-----------------------
class-map match-any dscp46
  match ip dscp 46

!----------------------Class Map Config Section for dscp26-----------------------
class-map match-any dscp26
  match ip dscp 26

!----------------------Class Map Config Section for dscp24-----------------------
class-map match-any dscp24
  match ip dscp 24

!----------------------Class Map Config Section for dscp22-----------------------
class-map match-any dscp22
  match ip dscp 22

!----------------------VRF Config Section for V7636:company19----------------------
ip vrf V7636:company19
rd 1803:6547
export map Management
route-target export 1803:4413
route-target import 1803:4413
maximum routes 4000 80

!----------------Address Family Config Section for V7636:company19-----------------
router bgp 1803
address-family ipv4 vrf V7636:company19
redistribute connected
redistribute static
redistribute ospf 4413 vrf V7636:company19 match internal external 1 external 2
maximum-paths import 4
no synchronization
bgp dampening 15 1500 3000 30
exit-address-family

!--------------------Applicable Router Process Configuration---------------------
router ospf 4413 vrf V7636:company19
log-adjacency-changes
redistribute bgp 1803 subnets
network 10.10.233.132 0.0.0.3 area 0
default-information originate

------------------------------------------------------------------------------------------------------

location-wan-1#sho ip ospf

Routing Process "ospf 1000" with ID 10.10.255.103

Start time: 00:00:22.804, Time elapsed: 1w4d

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

Supports area transit capability

Router is not originating router-LSAs with maximum metric

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Incremental-SPF disabled

Minimum LSA interval 5 secs

Minimum LSA arrival 1000 msecs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 268. Checksum Sum 0x8C1F55

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Number of areas transit capable is 0

External flood list length 0

    Area BACKBONE(0)

        Number of interfaces in this area is 5 (1 loopback)

        Area has no authentication

        SPF algorithm last executed 00:00:05.572 ago

        SPF algorithm executed 99676 times

        Area ranges are

        Number of LSA 177. Checksum Sum 0x5ABE76

        Number of opaque link LSA 0. Checksum Sum 0x000000

        Number of DCbitless LSA 1

        Number of indication LSA 0

        Number of DoNotAge LSA 0

        Flood list length 0

-------------------------------------------------------------------------------------------

location-wan-1#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.10.248.25 to network 0.0.0.0

     68.0.0.0/32 is subnetted, 2 subnets
O E2    68.28.18.135 [110/50] via 10.10.233.133, 00:00:03, Serial0/1/0
O E2    68.28.2.135 [110/50] via 10.10.233.133, 00:00:03, Serial0/1/0
     192.168.224.0/28 is subnetted, 1 subnets
O       192.168.224.0 [110/83] via 10.10.248.25, 00:00:03, Serial0/0/0
     206.57.50.0/32 is subnetted, 1 subnets
O E2    206.57.50.102 [110/0] via 10.10.248.25, 00:00:03, Serial0/0/0

     208.50.43.0/32 is subnetted, 1 subnets
O E2    208.50.43.10 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
     159.63.0.0/32 is subnetted, 1 subnets
O E2    159.63.230.128 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
     172.16.0.0/32 is subnetted, 1 subnets
O E2    172.16.5.207 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
     172.21.0.0/30 is subnetted, 1 subnets
O E2    172.21.48.196 [110/1] via 10.10.233.133, 00:00:00, Serial0/1/0
     172.20.0.0/30 is subnetted, 2 subnets
O E2    172.20.30.192 [110/1] via 10.10.233.133, 00:00:00, Serial0/1/0
O E2    172.20.210.140 [110/1] via 10.10.233.133, 00:00:00, Serial0/1/0
     172.23.0.0/30 is subnetted, 1 subnets
O E2    172.23.16.44 [110/1] via 10.10.233.133, 00:00:00, Serial0/1/0
     67.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O E2    67.17.96.36/30 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
O E2    67.17.96.40/30 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
O E2    67.17.22.4/32 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
O E2    67.17.109.124/30 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
O E2    67.17.109.120/30 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
O E2    67.16.204.51/32 [110/0] via 10.10.248.25, 00:00:00, Serial0/0/0
     162.97.0.0/32 is subnetted, 1 subnets
O E2    162.97.239.33 [110/0] via 10.10.248.25, 00:00:01, Serial0/0/0
     8.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2    8.19.66.80/28 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    8.19.66.64/29 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    8.19.66.96/28 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 126 subnets, 17 masks
O       10.10.233.172/30 [110/202] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.0.0.0/10 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.233.160/30 [110/196] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.18.64/26 [110/281] via 10.10.248.25, 00:00:01, Serial0/0/0
O IA    10.10.233.184/30 [110/66] via 10.10.233.133, 00:00:01, Serial0/1/0
O       10.10.81.0/24 [110/281] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.100.0/24 [110/84] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.233.140/30 [110/317] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.9.101.0/24 [110/187] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.248.144/29 [110/196] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.110.0/24 [110/84] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.111.0/24 [110/84] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.248.148/30 [110/131] via 10.10.248.25, 00:00:01, Serial0/0/0
C       10.10.233.132/30 is directly connected, Serial0/1/0
O       10.10.255.143/32 [110/266] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.233.152/30 [110/317] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.255.133/32 [110/281] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.255.132/32 [110/282] via 10.10.248.25, 00:00:01, Serial0/0/0
O IA    10.10.255.131/32 [110/131] via 10.10.233.133, 00:00:01, Serial0/1/0
O       10.10.255.130/32 [110/187] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.74.0.0/15 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.64.10.0/24 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.73.0.0/16 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.6.0/24 [110/281] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.7.0/24 [110/140] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.76.0.0/14 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.36.32/27 [110/84] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.4.0/24 [110/266] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.8.0/24 [110/262] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.9.0/24 [110/76] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.64.1.0/24 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O IA    10.10.14.0/24 [110/131] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.70.0.0/16 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O E2    10.9.0.0/16 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
C       10.10.12.0/24 is directly connected, FastEthernet0/0
O E2    10.68.0.0/15 [110/20] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.18.0/26 [110/282] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.16.0/24 [110/356] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.22.0/24 [110/326] via 10.10.248.25, 00:00:01, Serial0/0/0
O       10.10.23.0/24 [110/325] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.20.0/24 [110/262] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.21.0/24 [110/253] via 10.10.248.25, 00:00:02, Serial0/0/0
O E2    10.10.26.0/24 [110/20] via 10.10.248.25, 00:00:02, Serial0/0/0
O E2    10.80.0.0/12 [110/20] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.24.0/23 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O E2    10.64.21.0/24 [110/20] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.35.0/27 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.32.0/24 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.33.0/25 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.38.0/24 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.39.0/28 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.36.0/27 [110/84] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.233.204/30 [110/345] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.43.0/24 [110/266] via 10.10.248.25, 00:00:02, Serial0/0/0
O E2    10.96.0.0/11 [110/20] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.233.192/30 [110/745] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.44.0/24 [110/147] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.50.0/23 [110/132] via 10.10.248.25, 00:00:02, Serial0/0/0
O       10.10.54.0/24 [110/147] via 10.10.248.25, 00:00:02, Serial0/0/0
O IA    10.10.55.0/24 [110/131] via 10.10.233.133, 00:00:02, Serial0/1/0
O E2    10.10.39.16/28 [110/20] via 10.10.248.25, 00:00:02, Serial0/0/0
C       10.10.52.0/24 is directly connected, FastEthernet0/0.52
O       10.10.53.0/24 [110/266] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.233.210/32 [110/66] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.59.0/24 [110/132] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.233.208/30 [110/66] via 10.10.233.133, 00:00:03, Serial0/1/0
O IA    10.10.60.0/25 [110/261] via 10.10.233.133, 00:00:03, Serial0/1/0
O IA    10.10.255.60/32 [110/261] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.248.56/30 [110/131] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.60/30 [110/137] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.31.146.0/24 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.128.0.0/9 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.255.55/32 [110/131] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.248.48/30 [110/315] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.240.56/29 [110/84] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.50/32 [110/132] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.40/30 [110/252] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.34.188.0/24 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.34.189.0/24 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.44/30 [110/316] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.36/30 [110/252] via 10.10.248.25, 00:00:03, Serial0/0/0
C       10.10.248.24/30 is directly connected, Serial0/0/0
O       10.10.233.8/30 [110/340] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.10.230.0/24 [110/50] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.248.16/30 [110/66] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.233.0/30 [110/66] via 10.10.233.133, 00:00:03, Serial0/1/0
O E2    10.10.233.0/24 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.233.4/30 [110/66] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.248.8/30 [110/130] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.240.0/20 [110/82] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.34.188.35/32 [110/20] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.255.4/32 [110/84] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.0/30 [110/98] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.10.255.1/32 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.3/32 [110/83] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.248.4/30 [110/280] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.34.188.42/32 [110/20] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.255.2/32 [110/84] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.124/32 [110/132] via 10.10.248.25, 00:00:03, Serial0/0/0
O IA    10.10.255.126/32 [110/131] via 10.10.233.133, 00:00:03, Serial0/1/0
O       10.10.255.121/32 [110/356] via 10.10.248.25, 00:00:03, Serial0/0/0
O E2    10.10.134.0/27 [110/20] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.133.0/29 [110/84] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.116/32 [110/281] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.119/32 [110/253] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.115/32 [110/316] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.114/32 [110/317] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.233.100/30 [110/148] via 10.10.248.25, 00:00:03, Serial0/0/0
O       10.10.255.109/32 [110/253] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.18.128/26 [110/281] via 10.10.248.25, 00:00:04, Serial0/0/0
O IA    10.10.255.108/32 [110/131] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.255.111/32 [110/266] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.104/30 [110/280] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.255.110/32 [110/253] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.233.120/30 [110/141] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.255.107/32 [110/67] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.255.106/32 [110/131] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.255.101/32 [110/138] via 10.10.248.25, 00:00:04, Serial0/0/0
C       10.10.255.103/32 is directly connected, Loopback500
O       10.10.233.112/30 [110/317] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.100/30 [110/186] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.88/30 [110/265] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.80/30 [110/355] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.72/30 [110/252] via 10.10.248.25, 00:00:04, Serial0/0/0
O       10.10.248.68/30 [110/265] via 10.10.248.25, 00:00:04, Serial0/0/0
O IA    10.10.60.128/25 [110/261] via 10.10.233.133, 00:00:04, Serial0/1/0
     146.82.0.0/32 is subnetted, 1 subnets
O E2    146.82.58.70 [110/0] via 10.10.248.25, 00:00:04, Serial0/0/0
     208.49.159.0/25 is subnetted, 1 subnets
O E2    208.49.159.0 [110/0] via 10.10.248.25, 00:00:04, Serial0/0/0
     192.168.220.0/27 is subnetted, 1 subnets
O E2    192.168.220.0 [110/20] via 10.10.248.25, 00:00:05, Serial0/0/0
     206.132.226.0/32 is subnetted, 1 subnets
O E2    206.132.226.253 [110/0] via 10.10.248.25, 00:00:05, Serial0/0/0
     208.49.116.0/32 is subnetted, 1 subnets
O E2    208.49.116.225 [110/0] via 10.10.248.25, 00:00:05, Serial0/0/0
     208.49.117.0/30 is subnetted, 1 subnets
O E2    208.49.117.192 [110/0] via 10.10.248.25, 00:00:05, Serial0/0/0
O*E2 0.0.0.0/0 [110/1] via 10.10.248.25, 00:00:05, Serial0/0/0

New Member

Route data and voice over separate Wan connections

10.10.248.x/30 used for subnets between each location and one of the carriers, 10.10.233.x/30 subnets used between each location and the other carrier and 10.10.255.x/32 used for the loopback interface on our routers.

Hall of Fame Super Silver

Route data and voice over separate Wan connections

In my experience the way to accomplish routing data via one ISP and voice via another ISP is to use Policy Based Routing. I would suggest and approach something along these lines.

- configure routing so that the connection through the data ISP is preferred and if that connection fails then voice ISP will carry the load. (this takes care of the data requirement and will handle the voice failover)

- configure PBR so that it identifies the voice traffic and sets next hop to use the voice ISP. Use verify availability in the set next hop to verify that this ISP is reachable and if not allow the voice traffic to use normal routing.

HTH

Rick

New Member

Route data and voice over separate Wan connections

So if I setup the PBRs on let's say router A, will that have an effect on the OSPF side, so that let's say router B will see the preferred route to the voice subnet on router A is over the voice WAN?  I ask, because we had experimented with adding static routes on a couple of routers forcing the traffic over the backup data Wan, but it seemed to get lost once it got on the carrier's MPLS network.  I believe this was due to OSPF still showing the primary data WAN as the preferred route to the voice subnet.

Hall of Fame Super Silver

Route data and voice over separate Wan connections

PBR does not have any impact on OSPF and does not change any OSPF metric values. PBR affects forwarding on the router where it is configured and not any other device. So if multiple routers are involved in forwarding this traffic you may need to configure PBR on multiple routers. And if you configure PBR on the remote side to send the voice traffic differently it is likely that you might need to configured PBR on the head end so that it forward the voice response traffic in a similar way.

If configuring PBR on multiple routers is an issue or if forwarding through the backup ISP is an issue then an alternative to consider might be to configure a tunnel that goes through the backup ISP network and to route voice via the tunnel.

HTH

Rick

Super Bronze

Re: Route data and voice over separate Wan connections

You noted you want the "data" path to back-stop the "VoIP" path, and vice versa.  This being the case, if either path begins to cover for the other, you'll really want QoS to insure VoIP has priority over data.  If you do define QoS that provides priority for VoIP, why go to the (extensive) trouble of directing VoIP on one carrier and data on the other?

New Member

Route data and voice over separate Wan connections

We have configured qos policy to give voip priority, however I think we looked at it from a perspective that qos is not a cure all, if the connection is at 100% utilization because of the combination of data and voice traffic you will probably still suffer call quality issues.  Right now we're paying for backup Wan connections that are sitting there not doing much for us most of the time, it would be nice to take advantage of the bandwidth.

Super Bronze

Route data and voice over separate Wan connections

I agree QoS isn't a cure all, but if QoS is properly configured, sharing a link with data and VoIP, even when 100%, shouldn't cause quality issues.  However, you did mention MPLS VPNs - often such service provider supported QoS is "weak".  Regardless, you got a QoS problem if failure of one provider causes issues for VoIP when you need to re-combine VoIP and data traffic.

For a past company, I had a pair of E3s that ran at 100% (continuously) during normal business hours.  They had everything from VoIP to client and server backups running across them.  The former didn't suffer quality issues, and the latter was often why the links were pegged at 100%.

Oh, and if you think the prior worked because the links were multi-megabit, I also had sites with much less bandwidth, such as with fractional T1s/E1s, they too had VoIP and other traffic, but as they only had a few users, not hundreds, they didn't run at 100% continuously - just lots of the time .

1204
Views
0
Helpful
9
Replies