Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

route in datebase, not in routing table

Hi Guys,

I have the following config:

router ospf 201

redistribute static subnets

network 152.159.248.0 0.0.0.255 area 0

network 152.159.3.0 0.0.0.255 area 0

!

no ip classless

ip route 152.159.3.16 255.255.255.255 152.159.3.5

the static route is seen in the db of the neighs, but not the route table ?

I see it being sent out with an ACK from this host,

any thoughts ?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: route in datebase, not in routing table

Jafar,

This static route was taken from your second post:

sh ip route 152.159.3.5

Routing entry for 152.159.3.5/32

Known via "static", distance 1, metric 0 (connected)

Redistributing via ospf 201

Advertised by ospf 201 subnets

Routing Descriptor Blocks:

* directly connected, via Channel1/0

Route metric is 0, traffic share count is 1

Is this from the router where you are not seeing the external route being installed.

You should try removing the forward address from the type 5 lsa by using the tip I gave you in my previous posting (ie. network 152.159.3.6 0.0.0.0 area 0)

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
21 REPLIES

Re: route in datebase, not in routing table

Can you post the output of 'show ip ospf database external 152.159.3.16' from the router that doesn't put the route in the route table.

New Member

Re: route in datebase, not in routing table

OSPF Router with ID (152.159.248.3) (Process ID 201)

Type-5 AS External Link States

LS age: 1411

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 152.159.3.16 (External Network Number )

Advertising Router: 152.159.3.17

LS Seq Number: 8000002B

Checksum: 0x3866

Length: 36

Network Mask: /32

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 152.159.3.5

External Route Tag: 0

.17 is the loopback of the first router,

.5 is the next hop for the first router,

sh ip route 152.159.3.5

Routing entry for 152.159.3.5/32

Known via "static", distance 1, metric 0 (connected)

Redistributing via ospf 201

Advertised by ospf 201 subnets

Routing Descriptor Blocks:

* directly connected, via Channel1/0

Route metric is 0, traffic share count is 1

here is the interface config of the first router too,

interface Channel1/0

description EPP

ip address 152.159.3.6 255.255.255.252

no ip route-cache

no ip mroute-cache

no keepalive

claw 0100 00 152.159.3.5 EPPMVS CIP3 TCPIP TCPIP

csna 0100 02

Thanks in a dvance.

Re: route in datebase, not in routing table

Hi

Any specific reason for giving " no ip classless " . This may make ur router not to give the /32 route to the neighbor .

Try changing it to " ip classless " and check out.

regards

vanesh k

New Member

Re: route in datebase, not in routing table

it is classless on both now,

still in DB, but not in table !

Re: route in datebase, not in routing table

The problem, very likely, is forward address of 152.159.3.5 not reachable from the router that does not put the route in the route table.

Is there a route to 152.159.3.5 and can you ping it? OSPF should advertise that network unless you are filtering or incorrectly routing to that address.

HTH

Sundar

Hall of Fame Super Gold

Re: route in datebase, not in routing table

Jafar

A common reason for a route in the data base not being put into the routing table is that the forward address show in the data base (Forward Address: 152.159.3.5) is not reachable. Can you verify that 152.159.3.5 is reachable from this router.

Another reason that a route in the data base may not be in the routing table as an OSPF route is that some other routing source with a better administrative distance has put the route into the routing table. Can you confirm whether the route is in the routing table at all?

Also we should consider the possibility that a distribute list has been configured and is supressing the route from the routing table. (distribute list with OSPF is especially tricky since the distribute list will affect what is in the routing table but not what is in the OSPF data base, and not affect what is advertised to neighbors.) Can you tell us whether there is any distribute list on the second router?

Also on the question of ip classless or no ip classless, I can think of no reason why no ip classless would affect the propagation of the route. Unless there is some particular reason to configure ip classless I suggest that you are usually better off leaving it as no ip classless (there are good reasons why in modern networks the default is no ip classless).

HTH

Rick

New Member

Re: route in datebase, not in routing table

thanks for the reply,

1--it is reachable,

2--here is the output of show ip route:

sh ip route 152.159.3.16

% Subnet not in table

3-- there are no distribute list on either side.

Thanks

Re: route in datebase, not in routing table

Hi,

Iam not sure abt your network setup.Pls let me know wheter the router where you are not able to see the route has a connected network of " 152.159.3.0 " and under router ospf , a similar network statement like the other router is not given.

regards

vanesh k

New Member

Re: route in datebase, not in routing table

here is the two side config:

this is the router where I do not see the route in the route table:

router ospf 201

log-adjacency-changes

redistribute connected subnets

network 152.159.248.0 0.0.0.255 area 0

!

router igrp 15

redistribute connected

network 152.159.0.0

!

ip classless

this is the side where this static route is:

router ospf 201

redistribute static subnets

network 152.159.248.0 0.0.0.255 area 0

network 152.159.3.0 0.0.0.255 area 0

!

no ip classless

ip route 152.159.3.16 255.255.255.255 152.159.3.5

thanks

New Member

Re: route in datebase, not in routing table

Also, here is the show route for 152.159.3.0 from the neighbour withthe problem:

entry for 152.159.3.0/30

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 201, igrp 15

Advertised by ospf 201 subnets

igrp 15

Routing Descriptor Blocks:

* directly connected, via Channel6/2

Route metric is 0, traffic share count is 1

and,

sh ip ospf database external 152.159.3.0

OSPF Router with ID (152.159.248.3) (Process ID 201)

Type-5 AS External Link States

LS age: 1916

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 152.159.3.0 (External Network Number )

Advertising Router: 152.159.248.3

LS Seq Number: 800015A6

Checksum: 0xB3C5

Length: 36

Network Mask: /30

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 0.0.0.0

External Route Tag: 0

from the router where the static route is configured:

sh ip route 152.159.3.0

Routing entry for 152.159.3.0/30

Known via "ospf 201", distance 110, metric 20, type extern 2, forward metric 1

Redistributing via ospf 201

Last update from 152.159.248.3 on FastEthernet4/1, 17:08:07 ago

Routing Descriptor Blocks:

* 152.159.248.3, from 152.159.248.3, 17:08:07 ago, via FastEthernet4/1

Route metric is 20, traffic share count is 1

and

sh ip ospf database external 152.159.3.0

OSPF Router with ID (152.159.3.17) (Process ID 201)

Type-5 AS External Link States

Routing Bit Set on this LSA

LS age: 2011

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 152.159.3.0 (External Network Number )

Advertising Router: 152.159.248.3

LS Seq Number: 800015A6

Checksum: 0xB3C5

Length: 36

Network Mask: /30

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 0.0.0.0

External Route Tag: 0

Hall of Fame Super Gold

Re: route in datebase, not in routing table

Jafar

On the router where the route is in the data base but not in the routing table would you post the output of show ip route | include 152.159.3

HTH

Rick

New Member

Re: route in datebase, not in routing table

from the neigbor with this problem,

I can ping 152.159.3.5 always.

here is an output of the show ip routes requested:

Neighbor#sh ip route 152.159.3.0

Routing entry for 152.159.3.0/30

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 201, igrp 15

Advertised by ospf 201 subnets

igrp 15

Routing Descriptor Blocks:

* directly connected, via Channel6/2

Route metric is 0, traffic share count is 1

Neighbor#sh ip route 152.159.3.4

Routing entry for 152.159.3.4/30

Known via "ospf 201", distance 110, metric 2, type intra area

Last update from 152.159.248.4 on FastEthernet1/1, 22:08:39 ago

Routing Descriptor Blocks:

* 152.159.248.4, from 152.159.3.17, 22:08:39 ago, via FastEthernet1/1

Route metric is 2, traffic share count is 1

Neighbor#sh ip route 152.159.3.5

Routing entry for 152.159.3.5/32

Known via "ospf 201", distance 110, metric 20, type extern 2, forward metric 1

Last update from 152.159.248.4 on FastEthernet1/1, 17:48:46 ago

Routing Descriptor Blocks:

* 152.159.248.4, from 152.159.3.17, 17:48:46 ago, via FastEthernet1/1

Route metric is 20, traffic share count is 1

New Member

Re: route in datebase, not in routing table

posted already

thanks

Re: route in datebase, not in routing table

The output you have posted doesn't cover 152.159.3.5. From the router having the problem, can you post the output of 'show ip route 152.159.3.4' Were you able to ping 152.159.3.5 from this device?

Cisco Employee

Re: route in datebase, not in routing table

Jafar,

The issue is clearly that the route to the forward address is learnt via a static route. The route to the forward address should always be learnt via OSPF. Otherwise, the external route will never be installed in the RIB as you are now experiencing.

One way to fix the issue is to get rid of the static and let the ospf route to 152.159.3.5 be installed.

The other option is to get rid of the forward address itself by specifying the network statement for the channel1/0 interface as "network 152.159.3.6 0.0.0.0 area 0". This will get rid of the forward address on the type 5 lsa.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: route in datebase, not in routing table

there is no static route for 152.159.3.5, but I changed the static route to point to chanell 1/0.

still no go.

this is running an old code 11.2 !!

Cisco Employee

Re: route in datebase, not in routing table

Jafar,

This static route was taken from your second post:

sh ip route 152.159.3.5

Routing entry for 152.159.3.5/32

Known via "static", distance 1, metric 0 (connected)

Redistributing via ospf 201

Advertised by ospf 201 subnets

Routing Descriptor Blocks:

* directly connected, via Channel1/0

Route metric is 0, traffic share count is 1

Is this from the router where you are not seeing the external route being installed.

You should try removing the forward address from the type 5 lsa by using the tip I gave you in my previous posting (ie. network 152.159.3.6 0.0.0.0 area 0)

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: route in datebase, not in routing table

Thanks,

I added auto summary for that unreachable host on the main router, and it worked !!

I think it is a code issue,

Thanks to everyone.

Cisco Employee

Re: route in datebase, not in routing table

Jafar,

This is not really a code issue. The rule is that the forward address has to be resolved via an ospf route. All levels of code will behave the same.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: route in datebase, not in routing table

Hi

I have just experianced the same problem, on my network i had 5 routers on the same lan running ospf. The router priority was set to 1 on all routers. When the dr was elected it was a checkpoint firewall running ospf, this device was allowing full bi directional communication between all routers running ospf on the lan to itself apart from my new cisco box. My box though another router was the DR as i did not have a good neighbor state with the checkpoint box, i belive it was in the init state. It caused all sorts of issues on my box and the rules had to be ammended on the checkpoint.

New Member

Re: route in datebase, not in routing table

The reason is also because of preference order in OSPF as

network 152.159.3.0 0.0.0.255 area 0

is learned by neighs as Intra area route and host route 152.159.3.16 255.255.255.255 as External type2,so it will only put 152.159.3.0 in the routing table and not 152.159.3.16 learned as LSA-5(part of above less specific subnet)

181
Views
28
Helpful
21
Replies
CreatePlease to create content