Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

route_map and floating static route

Hello ,

I came across and extract part of the configuration as below :

Both RTs may rcv incoming traffic from 137.20.159.0/24 and according to route-map rm1 ,it will forward to 113.116.22.193 via Port-channel6

I saw floating static routes in RT21 and RT22.

The Administrator was saying if the Port-channel6 of 1 RT fails , traffic from 137.20.159.0/24 can be forwarded to another RT.

I have not been able to test it, but i am doubtful if this floating static route works as required. My understanding a route-map is as good as a route statement/table entry , will the router

refer at another destination route which map the next-hop of route-map when it is not available ?

I am not sure if src 137.20.159.0/24 dest 113.116.22.192/28 works , but i believe not for src 137.20.159.0/24 to any other adresses.

Please advice and correct me if i am wrong

thanks

regards

RT21

----

interface Port-channel6

description EtherChannel6

ip address 113.116.22.198 255.255.255.240

interface Vlan13

description N1

ip address 10.208.2.67 255.255.255.240

no ip redirects

ip rip advertise 15

ip policy route-map rm1

ip ospf hello-interval 4

standby 131 ip 10.208.2.69

standby 131 preempt

standby 131 name N1-HSRP

interface Vlan23

description N2

ip address 10.208.2.83 255.255.255.240

no ip redirects

ip rip advertise 15

ip policy route-map rm1

ip ospf hello-interval 4

standby 231 ip 10.208.2.85

standby 231 priority 95

standby 231 preempt

standby 231 name N2-HSRP

!

access-list 154 permit ip 137.20.159.0 0.0.0.255 any

route-map rm1 permit 50

description matcthstc

match ip address 154

set ip next-hop 113.116.22.193

ip route 113.116.22.192 255.255.255.240 10.208.2.84 50

!

RT22

----

interface Port-channel6

description EtherChannel6

ip address 113.116.22.199 255.255.255.240

!

interface Vlan13

description N1

ip address 10.208.2.68 255.255.255.240

no ip redirects

ip rip advertise 15

ip policy route-map rm1

ip ospf hello-interval 4

standby 131 ip 10.208.2.69

standby 131 priority 95

standby 131 preempt

standby 131 name N1-HSRP

interface Vlan23

description N2

ip address 10.208.2.84 255.255.255.240

no ip redirects

ip rip advertise 15

ip policy route-map rm1

ip ospf hello-interval 4

standby 231 ip 10.208.2.85

standby 231 preempt

standby 231 name N2-HSRP

access-list 154 permit ip 137.20.159.0 0.0.0.255 any

route-map rm1 permit 50

description matchsrc

match ip address 154

set ip next-hop 113.116.22.193

!

ip route 113.116.22.192 255.255.255.240 10.208.2.67 50

2 REPLIES
New Member

Re: route_map and floating static route

I think if PortChannel is down:

1. VLAN HSRP will not be changed, it not trace interface state.

2. Router Map will continue send packet to 113.116.22.193, but packet will be drop, because router map not match interface state~!

New Member

Re: route_map and floating static route

Thanks for the response

1)I understand this part on VLAN HSRP

2)For eg. Port-channel6 of RT21 is down. traffic from 137.20.159.0/24 will still be coming in to RT21. The qn is if the floating static route helps to forward these traffic via RT22 ?

278
Views
0
Helpful
2
Replies
CreatePlease login to create content