Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Route map on Tun Gre interface

Hi

I'm trying to set o route map on a GRE tunnel interface.

The router has two eth interfaces.

Trafic is comming on eth1 gre encapsulated and has to go out on the same interface unencapsulated only if it's coming and going to specific ip addresses.

The config is as follows:

ip access-list extended R1

permit ip host xx.xx.xx.xx host yy.yy.yy.yy

route-map R1 permit 10

match ip address R1

set ip default next-hop uu.uu.uu.uu

interface Tunnelzz

ip address aa.aa.aa.aa

tunnel source bb.bb.bb.bb

tunnel destination cc.cc.cc.cc

When I do a <<sh route-map>> the router display 0 matches.

Any help would be very appreciated.

Best regards,

Adrian

3 REPLIES
Purple

Re: Route map on Tun Gre interface

Adrian,

You need to apply it to the tunnel interface as follows:

interface Tunnelzz

ip policy route-map R1

Paresh

PS. Pls do rate posts.

New Member

Re: Route map on Tun Gre interface

Paresh,

It is applied as you said and the result did not changed.

Looks like on the Gre tunnel interface the incomming traffic is not matched by ACL.

I tryed on the GRE int the followin:

access-list 10 permit host 10.31.2.250

access-list 10 permit any

interface Tunnelzz

ip access-group 10 in

----

I am sure that I have trafic comming from 10.31.2.250 on the Tunnelzz but when i do:

sh access-lists

I have 0 matches on first rule and a lot of matches on the second one.

Thanks,

Adrian

New Member

Re: Route map on Tun Gre interface

How about you apply the route-map on the eth1 interface rather than the GRE interface?

Maybe I misunderstood your question.

206
Views
0
Helpful
3
Replies
CreatePlease to create content