Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route-Map ?

Below is the pasted configuration of one router, problem is route map not working. it is not doing source based routing. Packets from specific source are (LAN pool) are taking default route only.

Any idea or i am missing something ?

!

ip cef

!

!

interface Loopback0

no ip address

!

interface Serial0

ip address 61.95.141.122 255.255.255.252

!

interface Serial1

ip address 203.187.240.254 255.255.255.252

!

interface FastEthernet0

ip address 203.101.119.209 255.255.255.240 secondary

ip address 203.187.240.1 255.255.255.240 secondary

ip address 203.101.81.33 255.255.255.248

ip policy route-map Iqara

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 61.95.141.121

ip route 203.187.192.12 255.255.255.255 203.187.240.253

ip route 203.187.192.15 255.255.255.255 203.187.240.253

no ip http server

!

!

access-list 110 permit ip host 203.187.240.2 any

access-list 110 permit ip 203.187.240.0 0.0.0.15 any

access-list 191 permit icmp any any echo

access-list 191 permit icmp any any echo-reply

route-map Iqara permit 20

match ip address 110

set ip next-hop 203.187.240.253

!

7 REPLIES
Bronze

Re: Route-Map ?

Hello,

What happens when you issue a show ip access-list 110

Do you see the counters incrementing for the access list when traffic passes over the ethernet interface?

Thanks

Michael

New Member

Re: Route-Map ?

yes, counters increase. But not on that rate on which packets are flowing i.e. if i try 100 times,access list shows 20 only.

Silver

Re: Route-Map ?

Can you please provide the "sh ip route" ?

New Member

Re: Route-Map ?

try to debug ip packet 110, past the output .

Silver

Re: Route-Map ?

New Member

Re: Route-Map ?

Below is the sh ip route output.

Gateway of last resort is 61.95.141.121 to network 0.0.0.0

203.101.81.0/29 is subnetted, 1 subnets

C 203.101.81.32 is directly connected, FastEthernet0

203.101.119.0/28 is subnetted, 1 subnets

C 203.101.119.208 is directly connected, FastEthernet0

203.187.240.0/24 is variably subnetted, 2 subnets, 2 masks

C 203.187.240.252/30 is directly connected, Serial1

C 203.187.240.0/28 is directly connected, FastEthernet0

203.187.192.0/32 is subnetted, 2 subnets

S 203.187.192.12 [1/0] via 203.187.240.253

S 203.187.192.15 [1/0] via 203.187.240.253

61.0.0.0/30 is subnetted, 1 subnets

C 61.95.141.120 is directly connected, Serial0

S* 0.0.0.0/0 [1/0] via 61.95.141.121

Purple

Re: Route-Map ?

It might be worthing doing a 'debug ip policy' to see what exactly is happening.

Paresh

153
Views
0
Helpful
7
Replies