Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Route Map

hi;

I am having three 2mbps link connected to my HO to Datacentre,running eigrp,

now I want to dedicate one of the 2 mbps link only for some Ip from HO to access some server in datacentre and vice versa. and if other ip access those server will go thro other two links.

kindly help me how can i use route map or how can i achieve the same...

Thanks in advance.....

11 REPLIES

Re: Route Map

nilesh...

you can do it using route maps like this...

1. permit the IP address you require using the accesslist.

2. configure the route map statment with permit keyword.

3. then match the ip address of the accesslist.

4. set the next hop as your require exitinterface to the matched packet...

your configuration like this

access-list 3 permit a.b.c.d 0.0.0.255

route-map HO permit 10

match ip address 3

set ip next-hop IP address of the exit interface.

you can do it for others also in same way...

hope this will help you

rate this post if it helps

regards

Devang

New Member

Re: Route Map

Thanks devang for ur reply.

but here you gave ip access list 3 where you gave complete subnet as permit but I have only few Ip which i want to allow not complete subnet ...

thanks.

Re: Route Map

then you can go for

access-list 3 permit a.b.c.d 0.0.0.0

this accesslist will match the exact IP address...

rate this post if it helps

regards

Devang

New Member

Re: Route Map

devang;

If i want to match destination server also then how can i get it done.means if traffic generated from 10.10.10.10. for 20.20.20.20 will get routed to one of the next hope.

thanks..

//nilesh

Re: Route Map

what i understand from your explanation... you want to route traffice destain for the 20.20.20.20 should follow the your desire path... if i am right then you can do it using the static route...

ip route 20.20.20.0 255.0.0.0 IP address of the next-hope(or you can give the IP address of Exit interface or you can also give the exit interface name like FE 0)

rate this post if it helps

regards

Devang

Hall of Fame Super Gold

Re: Route Map

Nilesh

You should be able to accomplish the objective by using Policy Based Routing which uses a route map as Devang has indicated. I believe you would want to do it in this way:

- take one of the interfaces out of EIGRP so that normal traffic will not use it.

- configure an access list that will identify the traffic:

access-list 150 permit ip host host

- configure a route map to manipulate the traffic

route-map test-map permit 10

match ip address 150

set ip next-hop

- assign the route map and policy based routing on the interface on which traffic will arrive

interface

ip policy route-map test-map

You would need similar configuration on the router on both ends of the connection.

HTH

Rick

New Member

Re: Route Map

thanks rich;

these will help me much.

how can i take out one interface from eigrp.

thnks.

//nilesh

Hall of Fame Super Gold

Re: Route Map

Nilesh

The EIGRP network statement allows you to specify a mask. This is an optional feature and depending on how the interfaces are addressed is probably how you would remove one interface from EIGRP.

Assuming that your three interfaces have addresses like this:

interface serial 0/0

ip address 192.168.1.1 255.255.255.252

interface serial 0/1

ip address 192.168.1.5 255.255.255.252

interface serial 1/0

ip address 192.168.1.9 255.255.255.252

you may have eigrp configured with a network statement

network 192.168.1.0

and this includes the three interfaces. What you want is this

network 192.168.1.5 0.0.0.3

network 192.168.1.9 0.0.0.3

this will include the second and third interface but not the first interface.

You would need to adapt this to whatever addressing is used on your interfaces.

HTH

Rick

New Member

Re: Route Map

yes you got half right, means traffic for 20.20.20.20 only if it is from 10.10.10.10 then only it will flow from desire path

thnks

//nilesh

Hall of Fame Super Gold

Re: Route Map

Nilesh

for what you want it is needed to use an extended access list (lists numbered from 100 to 199) which can specify both source address and destination address.

HTH

Rick

New Member

Re: Route Map

Hi

I post here since my problem is strictly related.

I've done all the steps you described: access-list, route-map applied the route map on the interface.

The problem is that the trafic is commin over and GRE tunnel an when I do a <> it idicates 0 matches regardless the fact that there is traffic on the link.

All the configs done are on a 3640.

Thanks in advance,

Adrian

142
Views
15
Helpful
11
Replies
CreatePlease to create content