Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Route Reflector

Hi All,

If I understand correctly iBGP must be fully meshed as iBGP will not forward routing information due to BGP split horizon rules. Therefore we can use route reflectors to forward or "reflect" routes to other iBGP clients.

I try to set this up:

R1 and R4 are Clients connected to R2 which is the Route reflector. But R1 and R4 do not seem to get routes from R2.

Any help appreciated with my config.

Router 2:

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 1.2.1.1 remote-as 100

neighbor 1.2.1.1 route-reflector-client

neighbor 1.4.1.4 remote-as 100

neighbor 1.4.1.4 route-reflector-client

no auto-summary

Router 1:

router bgp 100

no synchronization

bgp log-neighbor-changes

network 4.0.0.0

network 5.0.0.0

network 6.0.0.0

aggregate-address 4.0.0.0 252.0.0.0 as-set

neighbor 1.2.1.2 remote-as 100

neighbor 1.3.1.3 remote-as 300

no auto-summary

R4:

router bgp 100

no synchronization

bgp log-neighbor-changes

network 13.0.0.0

neighbor 1.4.1.2 remote-as 100

no auto-summary

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: Route Reflector

Hi

The problem is the next-hop in your BGP routing table is not reachable ie. from R4

sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C 1.4.1.0 is directly connected, Serial1/0.1

C 13.0.0.0/8 is directly connected, Loopback1

From the BGP routing table on R4

* i4.0.0.0 1.2.1.1 0 100 0 i

* i4.0.0.0/6 1.2.1.1 0 100 0 i

* i5.0.0.0 1.2.1.1 0 100 0 i

* i6.0.0.0 1.2.1.1 0 100 0 i

All these routes have a next-hop of 1.2.1.1 but there is not route in your routing table for 1.2.1.1 so these routes cannot be installed in the routing table.

Are you running an IGP in your routers eg EIGRP/OSPF ? You need to make sure that the routers know how to reach the next hop received in the BGP advertisement.

Does this make sense

Jon

Re: Route Reflector

Hi,

As Jon has stated, you need static routing or IGP to make sure that the BGP routes next-hops are reachable from all the routers.

HTH,

Mohammed Mahmoud.

13 REPLIES

Re: Route Reflector

Hi,

Can you please state the IPs used for peering (which is which).

Can you please send also "show ip bgp summary".

HTH ,please do rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: Route Reflector

R2:

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial1/0.1 point-to-point

ip address 1.2.1.2 255.255.255.0

frame-relay interface-dlci 201

!

interface Serial1/0.2 point-to-point

ip address 2.2.1.2 255.255.255.0

frame-relay interface-dlci 203

!

interface Serial1/0.3 point-to-point

ip address 1.4.1.2 255.255.255.0

frame-relay interface-dlci 204

!

R2#show ip bgp summary

BGP router identifier 2.2.1.2, local AS number 100

BGP table version is 16, main routing table version 16

5 network entries using 585 bytes of memory

5 path entries using 260 bytes of memory

3/2 BGP path/bestpath attribute entries using 372 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1217 total bytes of memory

BGP activity 5/0 prefixes, 10/5 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.2.1.1 4 100 99 101 16 0 0 01:11:52 4

1.4.1.4 4 100 94 104 16 0 0 01:15:29 1

R4:

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial1/0.1 point-to-point

ip address 1.4.1.4 255.255.255.0

frame-relay interface-dlci 402

!

R4#show ip bgp summary

BGP router identifier 1.4.1.4, local AS number 100

BGP table version is 2, main routing table version 2

5 network entries using 585 bytes of memory

5 path entries using 260 bytes of memory

4/1 BGP path/bestpath attribute entries using 496 bytes of memory

1 BGP rrinfo entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1365 total bytes of memory

BGP activity 5/0 prefixes, 9/4 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.4.1.2 4 100 104 96 2 0 0 01:16:25 4

R1:

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial1/0.1 point-to-point

ip address 1.2.1.1 255.255.255.0

frame-relay interface-dlci 102

!

interface Serial1/0.2 point-to-point

ip address 1.3.1.1 255.255.255.0

frame-relay interface-dlci 103

!

R1#show ip bgp summary

BGP router identifier 6.1.1.1, local AS number 100

BGP table version is 5, main routing table version 5

5 network entries using 585 bytes of memory

5 path entries using 260 bytes of memory

4/2 BGP path/bestpath attribute entries using 496 bytes of memory

1 BGP rrinfo entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1365 total bytes of memory

BGP activity 5/0 prefixes, 6/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.2.1.2 4 100 103 101 5 0 0 01:13:46 1

1.3.1.3 4 300 90 96 5 0 0 01:25:06 0

Re: Route Reflector

Hi,

From your output the routes are exchanged normally and there is no problems, R2 receives 4 route, R1 receives 1 route and R4 receives 4 routes, accordingly the RR is working fine, check if you are doing any filtering.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: Route Reflector

Sorry I am new to BGP.

How did you determine that R2 receives 4 routes for example?

I am not doing any filtering with ACL's or the like.

Im using Dynamips cisco emulator, but it seemed to work find for everything else. Could it be because they are loopbacks? But you said they are being received ok.

R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets

C 1.4.1.0 is directly connected, Serial1/0.1

C 13.0.0.0/8 is directly connected, Loopback1

BTW how do I rate a post?

Hall of Fame Super Blue

Re: Route Reflector

Hi

You can rate a post by clicking on the windown bottom right of the messages where it says "Rate this post". Please do rate helpful posts as it helps other find the solution to their questions more quickly and Mohammed is very helpful in this forum.

As to your problem. The routers are receiving routes but they are not being put into the IP routing table. You can tell this from the line

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.4.1.2 4 100 104 96 2 0 0 01:16:25 4

Look at the last entry on the line - PfxRcd ie prefix received.

So they may well be in the BGP table but not in the IP table - these are 2 different tables.

Can you post the output of a "sh ip bgp" on each of your routers.

Jon

Re: Route Reflector

Hi Jon,

Thank you very much :) as you said before we are here to help people and exchange our experiences, and i am glade to support this forum beside people like your self.

BR,

Mohammed Mahmoud.

Re: Route Reflector

Hi,

From the show ip bgp summary the State/PfxRcd field expresses the number of routes received.

The routes may be received in the BGP table but not inserted into the routing table as they are 2 different tables, the bgp table can be viewed via "show ip bgp", please post its output.

I hope that i've been informative.

To rate the helpful replies, use the below scroll box on the right.

HTH,

Mohammed Mahmoud.

New Member

Re: Route Reflector

Thanks guys for your help!!!!

Please explain if you know how the BGP table gets into the route table? Ill try and read the book again.

R1#sh ip bgp

BGP table version is 5, local router ID is 6.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 4.0.0.0 0.0.0.0 0 32768 i

*> 4.0.0.0/6 0.0.0.0 100 32768 i

*> 5.0.0.0 0.0.0.0 0 32768 i

*> 6.0.0.0 0.0.0.0 0 32768 i

* i13.0.0.0 1.4.1.4 0 100 0 i

R2#show ip bgp

BGP table version is 16, local router ID is 2.2.1.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*>i4.0.0.0 1.2.1.1 0 100 0 i

*>i4.0.0.0/6 1.2.1.1 0 100 0 i

*>i5.0.0.0 1.2.1.1 0 100 0 i

*>i6.0.0.0 1.2.1.1 0 100 0 i

*>i13.0.0.0 1.4.1.4 0 100 0 i

R4#show ip bgp

BGP table version is 2, local router ID is 1.4.1.4

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i4.0.0.0 1.2.1.1 0 100 0 i

* i4.0.0.0/6 1.2.1.1 0 100 0 i

* i5.0.0.0 1.2.1.1 0 100 0 i

* i6.0.0.0 1.2.1.1 0 100 0 i

*> 13.0.0.0 0.0.0.0 0 32768 i

Hall of Fame Super Blue

Re: Route Reflector

Hi

The problem is the next-hop in your BGP routing table is not reachable ie. from R4

sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C 1.4.1.0 is directly connected, Serial1/0.1

C 13.0.0.0/8 is directly connected, Loopback1

From the BGP routing table on R4

* i4.0.0.0 1.2.1.1 0 100 0 i

* i4.0.0.0/6 1.2.1.1 0 100 0 i

* i5.0.0.0 1.2.1.1 0 100 0 i

* i6.0.0.0 1.2.1.1 0 100 0 i

All these routes have a next-hop of 1.2.1.1 but there is not route in your routing table for 1.2.1.1 so these routes cannot be installed in the routing table.

Are you running an IGP in your routers eg EIGRP/OSPF ? You need to make sure that the routers know how to reach the next hop received in the BGP advertisement.

Does this make sense

Jon

Re: Route Reflector

Hi,

You are welcomed, your output explains the problem, the routes having only * are in the BGP table but will never be inserted into the router table as they are not marked as best "* = valid, > = best", this could be due to many reasons, most probably the next-hop might be not reachable, please post the full configuration and show ip route.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Re: Route Reflector

Hi,

As Jon has stated, you need static routing or IGP to make sure that the BGP routes next-hops are reachable from all the routers.

HTH,

Mohammed Mahmoud.

New Member

Re: Route Reflector

Hi Guys,

Thanks so much for your help, your explanation makes sense, and sh ip bgp, will be a very handy output in the future. I put a static route in and it updates fine!

I have re-read the book "CCNP BSCI exam certification guide" and I guess that next-hop-self will only apply iBGP trying to get to eBGP?

I think the book maybe misses a bit of detail in relation to how the show commands can be of use and this problem that may occur, but many thanks to you guys it makes sense.

BTW, I have had a very long day study, but I don't see any rate this post anywhere. Maybe I have a different view of the discussion board to you guys.

Thanks again.

Re: Route Reflector

Hi,

You are very welcomed :) and please don't hesitate for further questions.

P.S The rating is done using the below on the right scroll box having "Rate this post" on it, then press submit, the rating is from 1 (not helpful) to 5 (extermely helpful), you choose the rating that each post should deserve.

HTH,

Mohammed Mahmoud.

257
Views
0
Helpful
13
Replies
CreatePlease to create content