Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

route

hello

iam having router with serial interface configured with public ip, and i have LAN with host configured with private ip address, so i want this host to be accessable form the internet, ihave configured static route in the router

Ip nat inside source static 192.168.1.22 255.255.255.0 ***.***.***.*** (our Public IP )

but it's not work

can any body please advice

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: route

Whichever one you want to. You can use either.

For simplicities sake use the free public address.

Jon

9 REPLIES

Re: route

You need to have the following

Ip nat inside source static 192.168.1.22

ip route 0.0.0.0 0.0.0.0

interface

ip nat inside

interafce

ip nat outside

Narayan

Community Member

Re: route

it should be

Ip nat outside source static public_ip inside_ip

interface Ethernet1

ip address *********

ip nat inside

interface Serial1

ip address *********

ip nat outside

Community Member

Re: route

now tell me which one is correct ;)

Hall of Fame Super Blue

Re: route

Narayan's solution is correct - it is an "ip nat inside ..." statement that is needed.

Jon

Community Member

Re: route

hello

yes Narayan is seem to be right, but how to determine next-hop-address ?!!!!

the other solution provided ,seem to be and it's really will stop the access to the Router from the host.

Hall of Fame Super Blue

Re: route

The next-hop ip address should be the IP address on the other end of your serial link. So you have a public IP on your end - do you know what the IP on the other end is.

Alternatively you could just point the default-route out of your serial interface eg.

ip route 0.0.0.0 0.0.0.0 serial0

where serial0 is the serial interface on your router. It would be more efficient though if you could use the next-hop IP address if you can.

Jon

Community Member

Re: route

hello

i have public ip address asigned to serial ineterface along with other FREE PUBLIC ip address from ISP , which one we have to use

in the public ip address fields

ip nat inside source static 192.168.1.1 *******

help please

Alaa

Hall of Fame Super Blue

Re: route

Whichever one you want to. You can use either.

For simplicities sake use the free public address.

Jon

Community Member

Re: route

hello

this my second case solved in this dissc, previous one solved by Giuseppe

so thanks to all

152
Views
5
Helpful
9
Replies
CreatePlease to create content