Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router BGP load sharing between direct E1 lease line and IPBGP

Dear Colleagues

I have CPE connected with E1 interface 2Mbps lease line, and we run eBGP accross

which is redundant by ISP internet connecting GRE Tunnel.

all connectivities are UP and running,

I have atttached configuration log and diagram for description

The priority BGP route is always with E1 interface,

My requirement is to make GRE tunnel as first priority or available both route for BGP destination

Can you please guide how to do that?

Router 1#

interface Serial0/0/0:0

ip address 216.200.72.21 255.255.255.252

!

interface Tunnel0

description GRE tunnel to Aicent GRX

ip address 64.125.140.173 255.255.255.252

ip mtu 1500

tunnel source 185.16.71.251

tunnel destination 79.132.225.178

crypto map macvpnmap

!

interface FastEthernet0/1.2

description GRX_IPVPN_SW_6509_1/39

encapsulation dot1Q 555

ip address 185.16.71.251 255.255.255.248

ip access-group ACL_IN in

no snmp trap link-status

crypto map macvpnmap

!

router bgp 64906

synchronization

bgp log-neighbor-changes

network 64.125.140.172 mask 255.255.255.252

network 125.19.25.0 mask 255.255.255.192

network 216.200.72.20 mask 255.255.255.252

neighbor 64.125.140.174 remote-as 19440

neighbor 64.125.140.174 soft-reconfiguration inbound

neighbor 216.200.72.22 remote-as 19440

neighbor 216.200.72.22 description To-GRX-Aicent

neighbor 216.200.72.22 update-source Serial0/0/0:0

neighbor 216.200.72.22 version 4

neighbor 216.200.72.22 soft-reconfiguration inbound

no auto-summary

Router1#sh ip bgp summary

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

64.125.140.174  4 19440   99371  122943  1176630    0    0 3w2d         4457

216.200.72.22   4 19440 2160847 1564058  1176630    0    0 02:07:08     4457

Router1#sh ip route bgp

     187.191.0.0/16 is variably subnetted, 2 subnets, 2 masks

B       187.191.5.128/25 [20/0] via 216.200.72.22, 02:07:54

B       187.191.17.224/28 [20/0] via 216.200.72.22, 02:07:54

     193.56.242.0/28 is subnetted, 1 subnets

B       193.56.242.128 [20/0] via 216.200.72.22, 02:07:54

Everyone's tags (5)
8 REPLIES
Cisco Employee

Router BGP load sharing between direct E1 lease line and IPBGP

Hi Abhishek,

If you already see both paths in the "show ip bgp" output, it should be as easy as adding "maximum-paths 2" to your bgp configuration. This should provide per session load sharing.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Router BGP load sharing between direct E1 lease line and IPBGP

Sep 26, 2013 4:55 PM                             (in response to Harold Ritter)

! ***Match all routes via prefix list***

!

ip prefix-list PRIORITY seq 5 permit 0.0.0.0/0 le 32

!

! ***Increase weight with route-map***

!

route-map PREFER-IT

match ip address prefix-list PRIORITY

set weight 1000

!

! ***Apply route-map to neighbor inbound***

!

neighbor 64.125.140.174 route-map PREFER-IT in

!

end

Apply this config and then soft clear the neighbor 65.125.140.174

It  will increase the weight of the routes learnt from the BGP peer across  GRE and hence your router will prefer the GRE tunnel as primary link.

New Member

Router BGP load sharing between direct E1 lease line and IPBGP

Hi Vishesh

I have done this, and my IP GRE route has started picking some traffic, but not all,

so I would say roughly 70% of the traffic is still going via Serial 0/0/0:0

and rest 30% is via GRE tunnel.

I have clear the GRE cache

I am expecting Serial 0/0/0:0 will be back up route,

Do you need more logs,

I am keeping this configuration for longer time

*  192.68.138.128/29

                    216.200.72.22                          0 19440 35030 64792 i

*                   64.125.140.174                      1000 19440 19440 19440 35030 64792 i

*  192.68.138.128/25

                    216.200.72.22                          0 19440 35030 64792 i

*                   64.125.140.174                      1000 19440 19440 19440 35030 64792 i

*  192.68.138.136/29

                    216.200.72.22                          0 19440 35030 64792 i

*                   64.125.140.174                      1000 19440 19440 19440 35030 64792 i

*  192.68.138.144/30

thanks

Router BGP load sharing between direct E1 lease line and IPBGP

Did you soft clear the neighbor?

Please attach a .txt file with the output of

show ip bgp summary

show ip bgp

show ip route

New Member

Re: Router BGP load sharing between direct E1 lease line and IPB

hi

pl find the logs, thanks for suggestion

Router BGP load sharing between direct E1 lease line and IPBGP

Route preference changes in BGP takes effect only after clearing the BGP neighborship. Mostly soft clear does the job; however sometimes we may need to hard reset the neighbor as well.

It is working as the routes learned from the BGP peer 64.125.140.174 are preffered because of the higher weight and installed in routing table.

*   217.164.95.8/29  216.200.72.22                         0      19440 8959 64673 i

*>                           64.125.140.174                      1000  19440 19440 19440 8959 64673 i

B       217.164.95.8/29 [20/0] via 64.125.140.174, 00:02:22

GOOD JOB !!!

New Member

Re: Router BGP load sharing between direct E1 lease line and IPB

Hello Vishesh

I have re-established neighbour relationship, by hard reset the interface itself,

but still traffic is going via that route

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

64.125.140.174  4 19440  119819  150152     4539    0    0 00:10:49     4494

216.200.72.22   4 19440 2201042 1602590     4539    0    0 00:03:18     4494

Airtel_GRX#

sh ip bgp and sh ip route are attached

please advice

thanks for all your assistance

Router BGP load sharing between direct E1 lease line and IPBGP

Routing table says that next-hop is 64.125.140.174 which is across the tunnel. But you say traffic goes out 216.200.72.22; Is there any PBR that is routing the traffic out Serial0/0/0:0?

Please check the output of -

show ip cef 64.125.140.174

show ip cef exact-route 64.125.140.173  64.125.140.174

show ip cef exact-route source-IP destination-IP     <<<< To check how traffic will be switched by the router coming from source-IP and going to destination-IP

Also please post the complete show run. Also please tell me how are you checking that the traffic is going out the serial interface and not tunnel.

461
Views
4
Helpful
8
Replies
CreatePlease to create content