Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Router bgp network /16 not advised

Hi all, I have the following configuration:

....

interface GigabitEthernet1/0

description ita_internal

ip address 10.39.1.1 255.255.255.0

negotiation auto

no keepalive

no cdp enable

....

interface GigabitEthernet2/0

description esp_iop

ip address 10.39.255.1 255.255.255.252

negotiation auto

no keepalive

no cdp enable

service-policy input Police

service-policy output ShapeOutgoing

....


router bgp 57.1

no synchronization

bgp log-neighbor-changes

bgp dampening

network 10.39.0.0

network 10.39.0.0 mask 255.255.0.0

neighbor 10.39.255.2 remote-as 52.1

neighbor 10.39.255.2 ebgp-multihop 2

neighbor 10.39.255.2 next-hop-self

neighbor 10.39.255.2 advertisement-interval 2

neighbor 10.39.255.2 soft-reconfiguration inbound

....

My neighbor is up, but my problem is that my network 10.39.0.0 is not advised to my neighbor, on "sh ip bgp 10.39.0.0" I receive:

% Network not in table

If I put "network 10.39.1.0 mask 255.255.255.0" this is advised, but I need 10.39.0.0 with mask /16; what's wrong with this configuration ?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Router bgp network /16 not advised

Hi Marco,

The network statement requires a route with the exact same mask in the routing table in order for the route to get originated in BGP. In general, it is recommended to have a static route pointing to null0 to originate the aggregated route.

ip route 10.39.0.0 255.255.0.0 null0

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
9 REPLIES
Cisco Employee

Router bgp network /16 not advised

Hi Marco,

The network statement requires a route with the exact same mask in the routing table in order for the route to get originated in BGP. In general, it is recommended to have a static route pointing to null0 to originate the aggregated route.

ip route 10.39.0.0 255.255.0.0 null0

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

I came to read about black

I came to read about black hole configuration that will drop/discard all packet destined to configured subent.So I confused a little bit that In this scenarion will it discard the packet which is destined to 10.39.0.0?
 

Hall of Fame Super Blue

The example in this thread is

The example in this thread is not to drop traffic but to allow BGP to advertise the summary route.

The assumption is that the router advertising the summary route also has the more specific routes that are part of the summary route.

So neighboring routers receive an advertisement for the summary route and send any traffic destined for networks within that summary route to the advertising router. This router then has the more specific network entries in it's routing table and because a more specific route is always used the packet is forwarded to the correct next hop.

If there is no more specific route though then yes, the packet would be dropped so you do need to be careful when using the above method to advertise summary routes.

Jon

New Member

Router bgp network /16 not advised

I too had same issue. After adding the route to Null0, it was showing in routing table. It should work. try that.

New Member

Router bgp network /16 not advised

Network command requies exact masked route to be learned from IGP.. as mentioned by Harold, you can enter a static with /16 mask pointing to "null"

New Member

Router bgp network /16 not advised

Hi Marco,

As suggested by othets you need a route for the 10.39.0.0 in the routing table of the local router as a connected interface ,learnt through other routing protocols or static. As per you router config you only have 10.39.1.0 configured on Gig 0/0 interface. If you add a static route for subnet 10.39.0.0/16 pointing to null0 and advertise it in BGP all traffic for this /16 subnet will be directed to this router unless other routers in your network are originating a better or a more specific route to a subset of this /16 subnet. But please note that since the static route is pointing to null0 interface all traffic (other that 10.39.1.0 which is actually available on this router)  that comes to this router will be dropped. If this is just a test lab where you are testing BGP this is fine. If this is a production setup where you have 10.39.0.0/16 used in your network you must actually point your static route on your router to towards the interface through which these networks are reachable so that when traffic arrives to this router ( because of the BGP advertisement) this router can direct the traffic towards these subnets.

HTH

Regards

Umesh Shetty

Cisco Employee

Router bgp network /16 not advised

Umesh,

Generally, the more specific routes are learned via the IGP.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Router bgp network /16 not advised

Hi Harold,

Yes thats generally the case, I just wanted to make sure if thats how it is here as well. If its not this may cause a traffic black hole.

Regards

Umesh

New Member

Thank you all, as you

Thank you all, as you suggested, it was a static route problem.

Regards.

274
Views
0
Helpful
9
Replies
CreatePlease to create content