Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router Cisco 837 Interface

Hi, I've searched for a router that supports a connection through en ADSL. so I've choosed the 837 model. (If any other propositions, they are wellcome) How many interfaces has the 837 model. I wont to configure the router that it connects to Internet via the ADSL, and on the other side that I have 2 LAN or a LAN and DMZ. So it has a public IP, IP1-100.100.10.1, IP2-192.168.1.1. So i can forward som ports from the publis IP to the IP1. In this case my IP1 is the DMZ zone, IP2 the LAN. Is it possible to do this with this model? I've seen that it has four port manageable switch, but i didn't find the in the specification can it have 2 interfaces to cofigure them separately like:

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

interface Ethernet1

ip address 100.100.10.200 255.255.255.0

ip nat inside

!

Here is a picture of what i want do do, in case i was not clean... Sorry for my bad Englis too...

Thanks a lot!

myanakiev@dia-gr.com

13 REPLIES
Blue

Re: Router Cisco 837 Interface

dont think this is possible since there is only 1 routed ethernet interface on the device. the other ethernet interfaces are switched only.

see this link for more 837 config info:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_book09186a008011a32f.html

New Member

Re: Router Cisco 837 Interface

I would suggest going with a higher line 870 series router. With the 870's, you can create multiple VLAN's and routed VLAN interfaces. With an 870 series, you'll be able to do what is indicated in the diagram. You cannot do this with an 837.

http://www.cisco.com/en/US/products/hw/routers/ps380/products_data_sheet0900aecd8028a976.html

New Member

Re: Router Cisco 837 Interface

Hi, Thanks a lot of you two...

Ok, I'll see the propositions you've made me.

But why in the 837 data sheet in table 1, features it is written:

Demilitarized Zone Port (DMZ) : One of the switch ports could be convertsed in to a DMZ port to place publicly accessible servers or to segregate users on the LAN.

Data sheet:

http://www.cisco.com/application/pdf/en/us/guest/products/ps4874/c1650/ccmigration_09186a008010e5c5.pdf

Thanks again!

Momchil

New Member

Re: Router Cisco 837 Interface

The 837's switch is, um, partially managed. You can set up a DMZ port by configuring special interface ethernet2, which separates switch port 1 out into a routable DMZ interface (ethernet0 is the aggregate switch interface.) However, there are some limitations on throughput which I can't remember the details of; you may want to search cisco.com for "837 dmz".

Regards,

Jonathan

New Member

Re: Router Cisco 837 Interface

Thanks a lot for the explication about the 837. T think the best solution for me is the 877 which is also the newer version of 837.

Regards Momchil

New Member

Re: Router Cisco 837 Interface

I saw into the Q&A that the Cisco 870 series are fixed-configuration routers? What does it means?

New Member

Re: Router Cisco 837 Interface

It means that there are no interchangeable interfaces, or modular interfaces. Whatever model of 800 series that you buy will come only with the interfaces that you buy it with, and you cannot add/remove.

New Member

Re: Router Cisco 837 Interface

Thank for your help about the cisco's 800, it was helpful for me!

It was really not hard to understand, but...

Regards Momchil

Re: Router Cisco 837 Interface

Hi,

We have loads of 877 ADSL Routers and my friend I must tell you that the configuration thought by you couldn't be achieved by the 800 Series at all.

I would request you to consider the Cisco's latest series of 1800 or somewhat older series of 1700 Routers.

Regards,

Wilson Samuel

New Member

Re: Router Cisco 837 Interface

Hi,

Thanks for your post again. But i have some new questions... Why did you told me that the configuration thought by me is not possible? I want to have a connection with ADSL and two separate LANs, and to forward some ports to one of the LANs. The thing i want ot do is something like this, this is also part of owr current config of the cisco 1720 :

interface ATM0

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode ansi-dmt

no fair-queue

hold-queue 224 in

!

interface ATM0.1 point-to-point

pvc 2/32

encapsulation aal5mux ppp dialer

pppoe-client dial-pool-number 1

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

full-duplex

!

interface FastEthernet0

ip address 100.200.x.x.255.255.0

ip nat inside

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname LOGIN

ppp chap password PASS

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static tcp 192.168.1.3 8080 SOMEIP 8080 extendable

ip nat inside source static tcp 192.168.1.2 80 SOMEIP 80 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

ip pim bidir-enable

!

!

access-list 1 permit 100.200.20.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 2 permit 100.200.20.0 0.0.0.255

no cdp run

OK, the 1720 has a wan card for the adsl, one integrated 10/100 port and one wic 10M card. So it has 2 interfaces. The problem is thata the 1720 is obsolate and we can not connect with the second LAN to 100M...

With the 877 I saw that we can configure the cisco with vlan, so i can connect one of the netwoks to one of the ports to the switch and the aother to another. So i can do it with VLAN, Even i saw but i'm not sure that we can configure the 4 interfaces ports of the swicth separately, like:

interface FastEthernet0

ip address ...

interface FastEthernet1

ip address ...

interface FastEthernet2

ip address ...

interface FastEthernet3

ip address ...

and not using vlans... You've consided me the series of 1800, but they offers me more VPNS, more switch ports, better performance, etc. But only the 1841 is not fixed configuration, support extention cards, has two wan ports... So i did not understand why you considered me the 1800 series, what it will helps me? So pleace explain me much more about what you think.

Regards,

Momchil

New Member

Re: Router Cisco 837 Interface

I have an 837 and you can do exactly what you are talking about. You will have 3 routed interfaces, 2 physical and one virtual. Interface E1 is tied to ports f1,f2 and f3 on the 4-port switch and port f4 is tied to interface E2.

New Member

Re: Router Cisco 837 Interface

Thanks Again, So I can do it on the 877 too. Can you give me a portion of your configuration file, this can be useful for me.

Regards, Momchil

New Member

Re: Router Cisco 837 Interface

interface Null0

no ip unreachables

!

interface Ethernet0

description inside-interface

ip address ************* 255.255.255.0

ip access-group 100 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

hold-queue 100 out

!

interface Ethernet2

description dmz1-interface

Ip address **************** 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

ip route-cache flow

hold-queue 100 out

!

interface ATM0

description dsl interface async

no ip address

ip mtu 1492

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

bridge-group 1

bridge-group 1 spanning-disabled

no routing dynamic

pvc 0/35

!

!

interface FastEthernet1

speed 100

full-duplex

!

interface FastEthernet2

shutdown

speed 100

full-duplex

!

interface FastEthernet3

shutdown

speed 100

full-duplex

!

interface FastEthernet4

shutdown

speed 100

full-duplex

!

interface BVI1

description outside-interface

ip address dhcp

ip access-group 2010 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip inspect FW-RULE-1 out

ip ips INTRUSION-RULE-IPS_ips_rule in

ip virtual-reassembly

ip route-cache flow

1413
Views
0
Helpful
13
Replies