Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router crash/freeze after link failure (with multicast)

Hi all,

I'm working on a network design with several offices and dual WAN connection. Now I'm testing it in a lab, but one router (RTR04) keeps freezing after a link failure (only with multicast enabled). You can see the lab topoplogy in the atachment. There are two connection between the sites, one managed layer 2 vpn (primairy) and DMVPN over an other connection as backup. OSPF runs as routingprotocol between the routers with static routes to RTR03.

When I enable multicast (spare-mode with RTR03 as RP) and kill the l2 connection between RTR01 en 04 then RTR04 freezes. Console does not display anything and does not respond, one ping failure is displayed on screen before frees (interface leds keep blinking/burning even after I unplug the cable). When i configure a static mroute from RTR04 to RTR01 the router does not freeze.

On all routers RTR03 is configured as RP and the interfaces are configured with ip sparse-mode (for dmvpn on the tunnel interface). On RTR04 I can see 01 and 02 as pim neighbour.

I have also tried with sparse-dense mode, but samre result. When the DMVPN interface is down (RTR04 to 02) the routers does not crash when I kill the connection to RTR01.

RTR01

ip multicast-routing
!
interface Loopback1
 ip address x.x.x.x 255.255.255.255
!
interface GigabitEthernet0/0
 description ** e-VPN **
 ip address x.x.x.x 255.255.255.0
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf hello-interval 1
 ip ospf priority 100
 ip ospf cost 60
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description to RTR02
 ip address x.x.x.x 255.255.255.252
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf hello-interval 1
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description to RTR03
 ip address x.x.x.x 255.255.255.252
 ip pim sparse-mode
 duplex auto
 speed auto
!
ip pim rp-address x.x.x.x

+ OSPF config and static routes to RTR03

 

RTR02

ip multicast-routing
!
interface Loopback1
 ip address x.x.x.x 255.255.255.255
!
interface Tunnel0
 description ** DMVPN **
 bandwidth 50000
 ip address x.x.x.x 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication xxx
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp holdtime 60
 ip nhrp registration timeout 20
 ip tcp adjust-mss 1360
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf network broadcast
 ip ospf hello-interval 4
 ip ospf priority 100
 ip ospf cost 80
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel key xxx
!
interface GigabitEthernet0/0
 description ** DMVPN **
 ip address x.x.x.x 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description to RTR01
 ip address x.x.x.x 255.255.255.252
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf hello-interval 1
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description to RTR03
 ip address x.x.x.x 255.255.255.252
 ip pim sparse-mode
 ip ospf hello-interval 1
 duplex auto
 speed auto
!
ip pim rp-address x.x.x.x

+ OSPF config and static routes to RTR03

 

RTR04

ip multicast-routing
!
interface Loopback1
 ip address x.x.x.x 255.255.255.255
!
interface Tunnel0
 bandwidth 1000
 ip address x.x.x.x 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication xxx
 ip nhrp map x.x.x.x x.x.x.x
 ip nhrp network-id 100
 ip nhrp holdtime 60
 ip nhrp nhs x.x.x.x
 ip nhrp registration timeout 20
 ip tcp adjust-mss 1360
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf network broadcast
 ip ospf hello-interval 4
 ip ospf priority 0
 ip ospf cost 180
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
 tunnel key xxx
!
interface GigabitEthernet0/0
 description ** e-VPN **
 ip address x.x.x.x 255.255.255.0
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 7 xxx
 ip ospf hello-interval 1
 ip ospf priority 0
 ip ospf cost 140
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description ** DMVPN **
 ip address x.x.x.x 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan22
 description ** DATA VLAN **
 ip address x.x.x.x 255.255.255.0
 ip helper-address x.x.x.x
 ip pim sparse-mode
 no autostate
!
interface Vlan122
 description ** VOICE VLAN **
 ip address x.x.x.x 255.255.255.0
 ip helper-address x.x.x.x
 ip pim sparse-mode
 no autostate
!
ip pim rp-address x.x.x.x

 

  • WAN Routing and Switching
Everyone's tags (1)
76
Views
0
Helpful
0
Replies