Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Router error after memory upgrade

Hi guys,

I have a 3660 router for which the flash memory was upgraded. It was upgraded from 2x16 MB to 2x32 MB. But after the upgrade, I am getting the following error while uploading IOS image through xmodem. The message is:

" erasing flash at 0x30000000sector erase failed at location 0x30000000, status 0x20202020 "

I have tried changing the positions of the 2 flash modules, also tried using only one module at a time, but in vain.

Please help me out.

Thanks in Advance.

Sridhar.

2 REPLIES

Re: Router error after memory upgrade

Hi

Have you tried formating the flash before uploading the ios ?

Is it possible for you to check up by formating the same and upload the ios code onto it ?

regds

Community Member

Re: Router error after memory upgrade

Hi Prem,

I got it resolved. I used xmodem to directly boot from DRAM and then erased the flash. The flash showed very strange behavior as I could load 12.1 image (4MB) image onto the flash with checksum verification OK. But when I tried uploading 12.3 image (27MB) image onto flash, initially it gave me error of "not enough memory in flash" though there was a lot of it left. In the second attempt, it got uploaded, but verification of checksum failed. I did all these attempts after erasing the flash completly and moreover the flash memory was newly installed.

I then uploaded duplicate 12.1 (4MB) images by renaming the same and then uploaded the 12.3 image and to my surprise, the image uploaded successfully.

I still can't figure out why all this happened. I got the problem resolved but still do not have the explanation as to why all this happened.

Thanks for you concern.

Regards,

Sridhar.

111
Views
0
Helpful
2
Replies
CreatePlease to create content