Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Router Rip and no shutdown commands not working on 2621xm

Hi All,

I'm facing a really strange issue. I have an old 2621xm router in CCIE lab at home. Only a week ago I started having issue on 2 of them. The problem is on one of them when I go under interface configuration and I type "no shut" nothing happens. Interface stays in administratively down status and when I check running config "shutdown" is still under interface.

On the other one the same problem but only with "router rip" command. I configure my rip routing but then when I check running config there is no rip section and also RIP is not running under "show ip protocols rip".

These routers are connected to 2511 AccesServer. So I thought the issue might be communication from AccessServer to these devices. I connected a console cable straight to them and still the same problem. Everything else is working on these devices.

Has anyone had the same issue before? Any help will be appreciated.

10 REPLIES
VIP Purple

Router Rip and no shutdown commands not working on 2621xm

Hi Nashvi,

Can you make the interface as default interface and put the configurations one by one and check.

The shutdown command stays in the running config of the interface thats why.

To make interface default,

conf t

default interface gi.....

no shut

exit.

Or can you use this command show post? if yes then please show the output.

Hope this helps

Regards

please rate if it helps.

New Member

Router Rip and no shutdown commands not working on 2621xm

Dear Sandeep,

Thanks for the reply. I tried it before but I ran it again to show the output. I even tried re-imaging the device.

R6(config)#default int FastEthernet0/0

Building configuration...

Interface FastEthernet0/0 set to default configuration

R6(config)#do sho runn int FastEthernet0/0

Building configuration...

Current configuration : 83 bytes

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

R6(config)#interface fastEthernet 0/0

R6(config-if)#no sh

R6(config-if)#end

R6#show ip int brief

Interface                 IP-Address     OK? Method Status               Protocol

FastEthernet0/0           unassigned     YES TFTP   administratively down down

VIP Purple

Re: Router Rip and no shutdown commands not working on 2621xm

Hi Nashvi,

Can you connect a device to that port and then try.

Can you try this.

clear interface f1/0 and  then try a no shut"

if still now working then might be this is a hardware issue.

Regards

New Member

Router Rip and no shutdown commands not working on 2621xm

Hi Sandeep,

There is already a device connected to it and it's still down.

Ok that's fine this might be hardware issue but what about the other router that I'm saying I can go to router rip mode with no error and I can set everything with no error again but when I check running config it's not there. This can't be hardware issue!!! Am I right?

VIP Purple

Router Rip and no shutdown commands not working on 2621xm

Yes ,,,, if its the same router , then 100% its a hardware issue.

You have to change your hardware and then try these commands on other hardware.

Regards

please rate if it helps

New Member

Router Rip and no shutdown commands not working on 2621xm

no it's another router but the same model 2621xm

VIP Purple

Router Rip and no shutdown commands not working on 2621xm

Hi Nashvi,

Usually this router supports RIP configration but there is some problöem in your flash or hardware.

If you can do this then please try.

Step:Try to update the image of the router and then try.

or

Step:Change your hardware and test with new one.

Regards

please rate if it helps.

New Member

Router Rip and no shutdown commands not working on 2621xm

As I mentioned in my other post I already updated the image. I will replace the flash tomorrow and will let you know,if by hardware you mean just the flash. Because if you mean the whole router then that's not a solution

New Member

Router Rip and no shutdown commands not working on 2621xm

Hi Sandeep,

I replaced the flash with another known good one. But still the same problem. Also flash doesn't show any erase or write error.

R6#show flash: err

System flash directory:

File  Length   Name/status

  1   29539928  c2600-adventerprisek9-mz.124-3.bin

[29539992 bytes used, 20267364 available, 49807356 total]

49152K bytes of processor board System flash (Read/Write)

   Chip    Bank    Code      Size      Name                erase  write

    1      1       8917      8192KB    INTEL 28F640J3      0      0

    2      1       8917      8192KB    INTEL 28F640J3      0      0

    1      2       8918      16384KB    INTEL 28F128J3      0      0

    2      2       8918      16384KB    INTEL 28F128J3      0      0

New Member

Router Rip and no shutdown commands not working on 2621xm

I found the problem with RIP. RIP configuration won't show in any show command unless we configure at least one interface under the configuration.

But the problem with shutdown interface still exist.

Thanks all.

1945
Views
0
Helpful
10
Replies
CreatePlease to create content