Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Router Sub-interface Problem

Am implementing a WLCM Based Wireless LAN to run in parallel with the existing Wired LAN.

I Require 2 VLANs, one each for WIRED and WLAN

Have Sub-interfaced the Router Ethernet Interface into two. However, doing this (Sub interfacing) results in the LAN being very SLOW (Having HIGH LATENCY).

What can be the problem?

How can i go about solving this problem?

Below is an extract from the Router configuration,(AFFECTED ROUTERS 2811 and 3725):

ip dhcp excluded-address 192.168.117.239 192.168.117.254

!

ip dhcp pool LWAP-POOL

network 192.168.117.128 255.255.255.128

default-router 192.168.117.254

option 60 ascii "Cisco AP c1250"

option 43 hex f104.c0a8.7501

!

ip dhcp pool WLAN-Clients

network 10.10.119.0 255.255.255.0

default-router 10.10.119.1

dns-server 192.168.119.10 172.16.1.52

interface FastEthernet0/0

no ip address

ip access-group 112 in

duplex auto

speed auto

!

interface FastEthernet0/0.117

description LWAP subint

encapsulation dot1Q 117

ip address 192.168.117.254 255.255.255.128

shutdown

!

interface FastEthernet0/0.119

description CONNECTION TO THIKA_ARCADE LAN Subint

encapsulation dot1Q 119

ip address 192.168.119.1 255.255.255.0

ip helper-address 192.168.119.10

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Integrated-Service-Engine1/0

ip address 192.168.117.126 255.255.255.128

no keepalive

!

interface Integrated-Service-Engine1/0.4

description Interface to WLAN Clients

encapsulation dot1Q 4

ip address 10.10.119.1 255.255.255.0

Your Assistance will be highly appreciated!

6 REPLIES
Community Member

Re: Router Sub-interface Problem

Hey there, any one who can advice? Am still encountering this problem.

Walter

Re: Router Sub-interface Problem

Nothing looks apparently wrong with your config, but knowing little of your topology is a bit of a hindrance.

What kind of switch does the router connect to? (L2 or L3)

What kind of APs are you using?

What kind of controller are you using?

What type of latency are you seeing? If you do a traceroute, are you seeing loops somewhere?

HTH,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: Router Sub-interface Problem

Hi John,

AP's are LAP-1250. Controller is probably them NM-WLC modules.

Community Member

Re: Router Sub-interface Problem

But even before inserting the NM Card, just sub-interfacing the router interface, increases the latency to the remote site to 2000ms and above.

Hall of Fame Super Gold

Re: Router Sub-interface Problem

Walter,

interface Integrated-Service-Engine1/0

ip address 192.168.117.126 255.255.255.128 < ---- Is this correct?

Community Member

Re: Router Sub-interface Problem

Hi,

May be this will help, as at the Router end the Speed and duplex is auto / auto.

Can you also check the Speed and Duplex setting on the Switch side as well

Can you try Hardcoding at Switch and Router interfaces to Speed 100 duplex full.

once and check the performance.

sh int Fast 0/X

and sh int Gig 1/0/X

222
Views
0
Helpful
6
Replies
CreatePlease to create content