Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Router to Router DDR problem

Dear All,

I have two routers router1 and router2, I connect both of them using modem on async interface. my problem is, most time it will not work; even after reset modem of both side. May be some time it will work, but after some time it will automatically disconnect. When users using this line, it may be working only three or four min then disconnect. I mean no stable at all.

Router1 running configurations

hostname router1

username router2 password 0 cisco

no aaa new-model

ip subnet-zero

ip cef

chat-script default ABORT ERROR BUSY "NO ANSWER" "" "ATDT\T" TIMEOUT 60 CONNECT \C

interface serial/7

physical-layer async

description connected to router2

no ip address

encapsulation ppp

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

interface dialer1

description connected to router2

ip address 172.16.22.1 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer map snapshot 1 name xxx broadcast

dialer map ip 172.16.22.2 name router2 modem-script default boroadcast 041234567

dialer hold-queue 10

snapshot server 15 dialer

no cdp enable

ppp authentication chap

!

router rip

network 172.16.0.0

!

ip classless

ip route 172.16.12.0 255.255.255.0 172.16.22.2

!

dialer-list 1 protocol ip permit

router2 running configurations

username xxx password xxx

mmi polling-interval 60

no mmi auto-configure

no mmi PVC

mmi snamp-timeout 180

no aaa new-model

ip subnet-zero

no ip domain lookup

ip cef

chat-script default ABORT ERROR ABORT BUSY ABORT "NO ANSWER" "" "ATDT\T" TIMEOUT 60 CONNECT \C

!

interface f0

desc connect to router1

ip address 172.16.12.1 255.255.255.0

speed auto

!

Interface s0

physical-layer async

description connected to router1

no ip address

encapsulation ppp

dialer in-band

dialer rotary-group1

dialer group1

async mode dedicated

!

Interface dialer1

description connected to router1

ip address 172.16.22.2 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer map snapshot 1 name router1

modem-script default broadcast 026345678

dialer map ip 172.16.22.1 name router1 modem-script default broadcst 026345678

dialer hold-queue 10

dialer-group 1

snapshot client 15 360 suppress-state change-update dialer

no cdp enable

ppp authentication chap

how can I make my connection stable; please help me

4 REPLIES
New Member

Re: Router to Router DDR problem

hello Mohd,

can you add to router 2

dialer-list 1 protocol ip permit

and to router 1

interface dialer1

dialer group1

I am suspecting that connection disconnect because of idle-timeout expire.

Can you send us a "sh interface dialer1" output with interval of 30 sec ?

please also use "debug dialer" and send output when line disconnect.

Regards,

cisand

New Member

Re: Router to Router DDR problem

hi cisand

I am sorry to left some commands in router2; this also included in router2

router ospf1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area1

dialer-list 1 protocol ip permit

cdp timer 10

line1

timeout login response 300

modem inout

modem autoconfigure type usr_sportster

stop bit 1

speed 115200

flow control hardware

I am ready to send you dialer output and debug output; but you know some time modem hesitates to dialing; even after I reset modem of both sides no progress. After I try more time; one time it may be connect; it will stay only a few minutes then disconnect. when I get connection; PING response time will be low; it increases and disconnecting. That is the problem I am facing.

New Member

Re: Router to Router DDR problem

I have a similar issue. I have a 1750 dialing into a 3640. The 1750 dials in and connects. I can ping the 170.1.1.16 from the 1750 and my laptop. I can ping internal hosts without a problem from the 1750. I have a laptop attached to the router behind a cisco hub. I can ping the 1750 from the laptop but no further. Please help.

Hall of Fame Super Silver

Re: Router to Router DDR problem

Steve

There are a couple of things in your post that I am not clear about. I note that the Ethernet 0 configures async 5 as backup interface. So what does it take to get the router to dial. I see an interface dialer 1 but nothing that relates to this. I see a floating static default route using async 5, but I do not see any other source of routing information.

I suspect that the problem may be that you have a route for how to get traffic out, but that the remote destinations do not have a working route to get traffic back to you over the dialer.

As a side note: your problem seems to be different from the problem in the original post. You probably would have done better to have started a new thread than to append your problem to a previous thread.

HTH

Rick

597
Views
0
Helpful
4
Replies
CreatePlease to create content