Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Router to Switch communication

I'm having a brain fart here.

I have a Router which is connected to a switch.

The router has Ethernet0 and Ethernet1, both of which are connected to a switch.

E0 and E1 are configured as routed ports

!

interface Ethernet0

description Internet public vlan 510

ip address 60.254.111.121 255.255.255.192

no ip directed-broadcast

ip nat outside

media-type 10BaseT

!

interface Ethernet1

description Wireless_Network

ip address 172.16.1.15 255.255.248.0

no ip directed-broadcast

ip nat inside

media-type 10BaseT

!

The swtich these two ports are connected to has the following configuration.

interface GigabitEthernet2/17
description Wireless router internal
switchport access vlan 199
switchport mode access
switchport port-security maximum 12
switchport port-security aging time 10
switchport port-security violation restrict
switchport port-security aging type inactivity
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
end


interface GigabitEthernet2/18
description Wireless router External
switchport access vlan 510
switchport mode access
switchport port-security maximum 12
switchport port-security aging time 10
switchport port-security violation restrict
switchport port-security aging type inactivity
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
end

E0 is connected to Gi2/17

E1 is connected to Gi2/18

How does the communication work going from L3 Router to a L2 switch.

3 REPLIES
Hall of Fame Super Blue

Re: Router to Switch communication

John

Not entirely sure i understand exactly what you mean.

A client in vlan 510 that wants to send traffic to the internet will send traffic to it's default-gateway which should be the eth1 router interface. The router then routes the packet to the outside interface and then sends the packet on to the same switch but in vlan 199.

Presumably the next-hop from your router to the ISP is also attached to the same L2 switch ?

As far as the L2 switch is concerned they are 2 totally separate networks (vlans) that can only communicate via the router.

Note though it's not necessarily a good idea to have the outside and inside vlans on the same L2 switch but it does depend on the rest of your topology.

Jon

Re: Router to Switch communication

Well this is basically just for wireless users. So Wireless Internal basically means a totally seperate network from our

LAN. The users on our wireless network cannot ping any addresses, and or have any connectivity to the inside unless

they use VPN. I've been trying to fix all the issues on this network since I've got here. Most of the configurations I have

been finding are messed up it's not even funny. I have already seen a bunch of ACLs with permit statements then a permit any any at the end..... Gotta love those...

Router to Switch communication

it looks like you've got a small error in the description of router interface or you've really configured  the wrong VLANs on the interfaces.

212
Views
0
Helpful
3
Replies
CreatePlease to create content