Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing between 3G interfaces

Hi all

Amongst other things, I'm trying to get two Cisco 1941 routers with HWIC-1T and HWIC-3G-HSPA interfaces to use the 3G interfaces if the frame is down (as it is right now).

In the lab, I was not able to get these to use the 3G interfaces as a backup (i.e. backup interface cell 0/1/0) and I've not been able to workout the correct incantation for static routing either.

kununurra#show ip int br d1

Interface                  IP-Address      OK? Method Status                Protocol

Dialer1                    172.31.2.94     YES IPCP   up                    up

kununurra#traceroute 172.31.2.94

Type escape sequence to abort.

Tracing the route to 172.31.2.94

VRF info: (vrf in name/id, vrf out name/id)

  1 202.12.199.198 288 msec 208 msec 200 msec

  2 172.31.2.94 412 msec *  480 msec

kununurra#

wyndham#show ip int br d1

Interface                  IP-Address      OK? Method Status                Protocol

Dialer1                    172.31.2.95     YES IPCP   up                    up

wyndham#traceroute 172.31.2.95

Type escape sequence to abort.

Tracing the route to 172.31.2.95

VRF info: (vrf in name/id, vrf out name/id)

  1 202.12.199.198 644 msec 636 msec 448 msec

  2 172.31.2.95 768 msec 916 msec 836 msec

wyndham#

Cellular 0/1/0 uses Dialer1

kununurra#show run | i route

ip source-route

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Dialer1 254

ip route 172.31.2.0 255.255.255.0 Dialer1

ip route 192.168.3.0 255.255.255.0 Serial0/0/0

ip route 192.168.3.0 255.255.255.0 Dialer1 254

kununurra#

wyndham#show run | i route

ip source-route

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Dialer1 254

ip route 172.31.2.0 255.255.255.0 Dialer1

ip route 192.168.2.0 255.255.255.0 Serial0/0/0

ip route 192.168.2.0 255.255.255.0 Dialer1 254

wyndham#

Given that when tracing to the IP address on the routers own Dialer interface, the first hop is 202.12.199.198 on both routers, how do I configure the routing?  As I'm not sure I'm being clear, normally devices on 192.168.2.x talk to 192.168.3.x via their routers serial interfaces.  When the serial (read fram relay) link is down, I'd like them to be able to talk over 3G.

Please note that I will still need to be able to access the router directly via the 3G interface as a failback/last resort.

TIA

CC

Everyone's tags (3)
4 REPLIES
Hall of Fame Super Silver

Re: Routing between 3G interfaces

CC

My first advice is to not try to use backup interface. There are other solutions that are much better.

I am not sure what is the issue with your incantation of static routing using the 3G. The floating static route which you have configured is a much better solution than backup interface. And given that we do not know much about how this router is configured it is hard to say for sure but it looks to me like these static routes and floating static routes should work. I am guessing that the 202.12.199.198 is an address of the provider gear that is handling your 3G connection. Can you ping some other destination in the Internet (and I would start by pinging IP addresses rather than names to avoid potential problems with DNS.

HTH

Rick

[edit] when I did a project which used 3G I just did dialer inband on the cellular interface and that worked pretty well. I would think that using a dialer interface should also work well.

New Member

Re: Routing between 3G interfaces

Hi Rick

wyndham#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         192.168.3.1     YES NVRAM  up                    up

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

Serial0/0/0                192.168.57.2    YES manual down                  down

Cellular0/1/0              unassigned      YES unset  up                    up

Cellular0/1/1              unassigned      YES unset  down                  down

Dialer1                    172.31.2.95     YES IPCP   up                    up

wyndham#ping 172.31.2.94

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.31.2.94, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 768/823/916 ms

wyndham#

This is in a private Telstra cloud so only our devices can talk to each other, I can't ping stuff on the net but these two routers can ping each other, and I can access them from the office, 2000+km away.

Here is a trimmed down show run:

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

ip address 192.168.57.2 255.255.255.0

encapsulation frame-relay

clock rate 2000000

frame-relay interface-dlci 16 switched

frame-relay lmi-type ansi

!

interface Cellular0/1/0

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

dialer-group 1

async mode interactive

!

interface Cellular0/1/1

no ip address

encapsulation ppp

!

interface Dialer1

ip address negotiated

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string gsm

dialer persistent

dialer-group 1

ppp chap hostname username

ppp chap password password

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Dialer1 254

ip route 172.31.2.0 255.255.255.0 Dialer1

ip route 192.168.2.0 255.255.255.0 Serial0/0/0

ip route 192.168.2.0 255.255.255.0 Dialer1 254

!

dialer-list 1 protocol ip list 1

The other router is basically the same, just with appropriate IP address changes.

Thanks

CC

New Member

Routing between 3G interfaces

Yay!  I've got it working.

I setup a GRE tunnel with the dialer interface being the source on the other router's dialer IP being the destination.  Now I can traceroute between the 192.168.2.0 and 192.168.3.0 networks! 

CC

Hall of Fame Super Silver

Routing between 3G interfaces

CC

I am glad that you got it working. Congratulations on finding a solution. Thanks for posting back and updating the status so that we know that it is solved.

HTH

Rick

852
Views
0
Helpful
4
Replies
CreatePlease login to create content