Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing between a router and a L3 switch

Hi I have an issue where I have two sites that we are trying to connect via an ethernet port. In site 2 I am using the gig0/0 port on a 1941 router and configured the port as such:

interface gig0/0

ip address 192.168.18.2 255.255.255.252

ip route 10.0.4.0 255.255.255.0 192.168.18.1

site 2, I am using a 3750 switch because I don't have any gig ports available on their router and is configured as such:

  interface FastEthernet4/0/1

no switchport

ip address 192.168.18.1 255.255.255.252

ip route 172.20.0.0 255.255.0.0 192.168.18.2

Although both ports show up as up and I can ping their interfaces locally, I cannot ping the far side interfaces nor their networks.

I've tried changed the gateway to the local interface but that didn't work either. 

The carrier claims I need to have it on a vlan and suggested this config on site 1:

Interface gig0/0.955

encapsulation dot1q 955

ip address 192.168.18.2 255.255.252

And there is the problem.  I cannot configure a sub-interface on the L3 switch and cannot add the vlan like they recommend.

Any suggestions from anyone on how to connect the two sites?

Thanks

  • WAN Routing and Switching
Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Routing between a router and a L3 switch

Pete

The actual port may need to be configured as a trunk because of the router end. If so then -

1) create vlan 995

2) configure port as trunk but only allow vlan 995 on it

3) create SVI and migrate IP

Jon

Hall of Fame Super Blue

Re: Routing between a router and a L3 switch

Pete

Yes sorry, i often use the term SVI.

It is as you have described ie. "interface vlan " on a L3 switch and then assign an IP.

Don't forget to do a "no shut" after you have configured it as you usually have to.

The static route doesn't change.

Jon

7 REPLIES
Hall of Fame Super Blue

Routing between a router and a L3 switch

Pete

On the L3 switch -

1) create vlan 955

2) allocate the port that connects to the router into vlan 955 ie. change to a switchport and put it into that vlan

3) create an SVI for vlan 995 and migrate the address from the L3 port to the SVI

Jon

Hall of Fame Super Blue

Routing between a router and a L3 switch

Pete

The actual port may need to be configured as a trunk because of the router end. If so then -

1) create vlan 995

2) configure port as trunk but only allow vlan 995 on it

3) create SVI and migrate IP

Jon

New Member

Routing between a router and a L3 switch

Thanks Jon, got a question on step 3. Not sure on how to create a SVI and migrate the IP.

Is this what you are talking about?

  Interface vlan 955

  ip address 192.168.18.1 255.255.255.252

Then on the switchport

interface fastethernet 4/0/1

switchport trunk allowed vlan 955

switchport mode trunk

And then keep the static route the same?

Hall of Fame Super Blue

Re: Routing between a router and a L3 switch

Pete

Yes sorry, i often use the term SVI.

It is as you have described ie. "interface vlan " on a L3 switch and then assign an IP.

Don't forget to do a "no shut" after you have configured it as you usually have to.

The static route doesn't change.

Jon

Re: Routing between a router and a L3 switch

Jon,

I don't mea to hijack this thread, but if you take let's say a 3750 switch OOB, and as long as the following three are true will the SVI for VLAN 1 automatically be up?

- VLAN has been created on the switch

- VLAN is active on a access or trunk port

- Port that is active for this VLAN is not blocked by spanning tree

Or do you need to do 'no shut' as well?

Hall of Fame Super Blue

Routing between a router and a L3 switch

John

For vlan 1 specifically, on the switches i have used, you should not need to do a "no shut" on that SVI as long as you haven't administratively shut it down previously.

All other SVIs you create you need to do a "no shut".

Also you shouldn't need to create vlan 1 in the vlan database as it is there by default and actually again on the switches i have worked with you can't actually get rid of it even if you want to.

Finally from memory, as i don't have a switch to hand, STP blocking should not affect whether the port is up or not ie. it is still up but not forwarding any traffic and that should be enough to bring up the vlan interface.

Jon

Hall of Fame Super Blue

Re: Routing between a router and a L3 switch

John

Just did a quick search about the last part ie. STP.

I found a couple of references saying the port must be in forwarding state so perhaps my memory isn't as good as i thought it was.

I thought it was enough for the port to be up/up but apparently not.

Apologies for any misleading info but pretty sure the rest still stands.

We never stop learning.

Jon

225
Views
5
Helpful
7
Replies
This widget could not be displayed.