cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1010
Views
0
Helpful
3
Replies

Routing between two 1921 routers through MPLS and Internet

Damien Duchenne
Level 1
Level 1

Hi all,

 

I'm configuring a setup in which one two 1921 routers are connected together by two differents paths: one through Internet, the other one through an MPLS.

Each router has its own LAN connected on it and the aim of this setup is that the communication between the two LAN of each router is possible via the MPLS and if this one fails, via Internet.

To do this, I've created two tunnel interfaces, one through Internet and the other one through the MPLS. I've activated the EIGRP with a unique AS for both routers and with the share of the routes through both tunnels, but it doesn't work due to recursive routing problem. Therefore, I've created two different AS, one for the routing through the MPLS and the other one for the routing through Internet. It seems to work up to now and seems to give a priority to the AS 1, which is great for me. But is it really normal that there is a priority like this? If not, how can I configure a priority for each tunnel interface ? Is this setup OK ?

 

For information, here is the current configuration :

 

ROUTER A

interface Tunnel0
 description GRE Through MPLS
 ip address 10.0.2.1 255.255.255.248
 tunnel source 10.0.0.2
 tunnel destination 10.0.0.34
!
interface Tunnel1
 description GRE Through Internet
 ip address 10.0.3.1 255.255.255.248
 tunnel source X.X.X.X
 tunnel destination Y.Y.Y.Y
!
interface GigabitEthernet0/0
 description MPLS
 ip address 10.0.0.2 255.255.255.240
 duplex full
 speed 100
!
interface GigabitEthernet0/1
 description Internet
 ip address X.X.X.X 255.255.255.240
 duplex auto
 speed auto
!
router eigrp 1
 network 10.0.1.32 0.0.0.15
 network 10.0.2.0 0.0.0.7
 passive-interface default
 no passive-interface Tunnel0
!
!
router eigrp 2
 network 10.0.1.32 0.0.0.15
 network 10.0.3.0 0.0.0.7
 passive-interface default
 no passive-interface Tunnel1


ROUTER B

interface Tunnel0
 description MPLS
 ip address 10.0.2.2 255.255.255.248
 tunnel source 10.0.0.34
 tunnel destination 10.0.0.2
!
interface Tunnel1
 ip address 10.0.3.2 255.255.255.248
 tunnel source Y.Y.Y.Y
 tunnel destination X.X.X.X
!
interface GigabitEthernet0/0
 description MPLS
 ip address 10.0.0.34 255.255.255.240
 duplex full
 speed 100
!
interface GigabitEthernet0/1
 description Internet
 ip address Y.Y.Y.Y 255.255.255.240
 duplex auto
 speed auto
!
router eigrp 1
 network 10.0.1.32 0.0.0.15
 network 10.0.2.0 0.0.0.7
 passive-interface default
 no passive-interface Tunnel0
!
!
router eigrp 2
 network 10.0.1.32 0.0.0.15
 network 10.0.3.0 0.0.0.7
 passive-interface default
 no passive-interface Tunnel1
!

 

Thank you for your help.

 

Best regards,

Damien

1 Accepted Solution

Accepted Solutions

Nagendra Kumar Nainar
Cisco Employee
Cisco Employee

Damien,

Per my understanding, when there are 2 instances of EIGRP learning same prefix, I think it will choose the one with lowest AS. But it is more like local matter.

You can use admin distance to influence the same. You can configure "distance" command under respective EIGRP instance to influence the RIB entry.

 

-Nagendra

View solution in original post

3 Replies 3

Nagendra Kumar Nainar
Cisco Employee
Cisco Employee

Damien,

Per my understanding, when there are 2 instances of EIGRP learning same prefix, I think it will choose the one with lowest AS. But it is more like local matter.

You can use admin distance to influence the same. You can configure "distance" command under respective EIGRP instance to influence the RIB entry.

 

-Nagendra

Hi Nagendra,

Thank you for your reply.

I'll continue the configuration in this direction so and I'll use the distance metric to be sure that the priority is well interpreted by the routing protocol.

Thank you very much.

 

Best regards,

Damien

Hi Damien

I see this is already answered but I think this might help you.

You can also do it using an offset list which will only cause routing over the internet to happen in the event the mpls is down, and will allow the routing to return to normal when the mpls comes back up.
Key points:

1. Just remember that routing between endpoints needs to be functioning prior to the creation of the tunnel, ie avoid the temptation and don't start your tunnel config until your able to ping the endpoints
2. When you do create the tunnel it should have its own routing instance separate from the routing used in point 1 above. In my example in eigrp 1 you should only include the LAN networks and the tunnel ip network NOT the tunnel source or destinations as that will cause the recursion problem.
3. I used static routes for the paths between tunnel sources and destinations but you could use a separate instance of a dynamic protocol.

You might also want to have a look at the discussion on https://learningnetwork.cisco.com/thread/43367 which is essentially the same problem.

Anyway here's my configs - Hope it helps (:

Site A
!
interface Loopback0
 description SiteA LAN
 ip address 192.168.0.1 255.255.255.0
!
interface Tunnel0
 description GRE through MPLS
 ip address 10.0.1.1 255.255.255.0
 tunnel source 172.16.0.1
 tunnel destination 172.18.0.1
!
interface Tunnel1
 description GRE through Tinternet
 ip address 10.0.2.1 255.255.255.0
 tunnel source 101.101.101.1
 tunnel destination 202.202.202.1
!
interface FastEthernet0/0
 description MPLS Path
 ip address 172.16.0.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description internet path
 ip address 101.101.101.1 255.255.255.0
 speed 100
 full-duplex
!
router eigrp 1
 passive-interface default
 no passive-interface Tunnel0
 no passive-interface Tunnel1
 offset-list SECONDARY in 40000 Tunnel1
 offset-list SECONDARY out 40000 Tunnel1
 network 10.0.1.0 0.0.0.255
 network 10.0.2.0 0.0.0.255
 network 192.168.0.0
 no auto-summary
!
ip route 172.18.0.1 255.255.255.255 172.16.0.2
ip route 202.202.202.1 255.255.255.255 101.101.101.2
!
!
ip access-list standard SECONDARY
!
!

R2.MPLS-Path
!
interface FastEthernet0/0
 description link to SiteA
 ip address 172.16.0.2 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description Link to SiteB
 ip address 172.18.0.2 255.255.255.0
 speed 100
 full-duplex
!

R3.Internet-Path
!
interface FastEthernet0/0
 description Link to siteA
  ip address 101.101.101.2 255.255.255.240
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description link to siteB
 ip address 202.202.202.2 255.255.255.240
 speed 100
 full-duplex
!


Site B
!
interface Loopback0
 description SiteB LAN
 ip address 192.168.1.1 255.255.255.0
!
interface Tunnel0
 description MPLS path
 ip address 10.0.1.2 255.255.255.0
 tunnel source 172.18.0.1
 tunnel destination 172.16.0.1
!
interface Tunnel1
 description Internet path
 ip address 10.0.2.2 255.255.255.0
 tunnel source 202.202.202.1
 tunnel destination 101.101.101.1
!
interface FastEthernet0/0
 description MPLS path
 ip address 172.18.0.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description Internet path
 ip address 202.202.202.1 255.255.255.240
 speed 100
 full-duplex
!
router eigrp 1
 passive-interface default
 no passive-interface Tunnel0
 no passive-interface Tunnel1
 network 10.0.1.0 0.0.0.255
 network 10.0.2.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 101.101.101.1 255.255.255.255 202.202.202.2
ip route 172.16.0.1 255.255.255.255 172.18.0.2
!
!

!!end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco