Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing error

Hello friends ,

I connect two LANs together with two Cisco 2600 with PARADYNE 7975 M/SDSL.

I can telnet each of them trough another router.

But computers that each side can't ping another side.

LAN1 IP address is : 172.20.0.0 255.255.0.0

LAN2 IP address is : 172.17.0.0 255.255.0.0

---------- Router1 -------------------

interface FastEthernet0/0

ip address 172.20.2.3 255.255.0.0

duplex auto

speed auto

interface Serial0/1

ip address 172.18.2.5 255.255.255.0

encapsulation ppp

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 172.17.0.0 255.255.0.0 Serial0/1

ip route 172.18.0.0 255.255.255.0 Serial0/1

ip route 172.20.0.0 255.255.0.0 FastEthernet0/0

no ip pim bidir-enable

---------- Router2 -------------------

interface FastEthernet0/0

ip address 172.17.2.1 255.255.0.0

duplex auto

speed auto

interface Serial0/1

ip address 172.18.2.6 255.255.255.0

encapsulation ppp

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/1

ip route 172.17.0.0 255.255.0.0 FastEthernet0/0

ip route 172.18.0.0 255.255.255.0 Serial0/1

ip route 172.20.0.0 255.255.0.0 Serial0/1

Thanks for your helping.

6 REPLIES

Re: Routing error

Does not look like there is anythin wrong with the basic config. Do the computers on each LAN have a default gateway pointing to the router IP address at each site?

HTH>

Silver

Re: Routing error

remove these routes they are not necessary:

from router1

ip route 172.18.0.0 255.255.255.0 Serial0/1

ip route 172.20.0.0 255.255.0.0 FastEthernet0/0

from router2

ip route 172.17.0.0 255.255.0.0 FastEthernet0/0

ip route 172.18.0.0 255.255.255.0 Serial0/1

ip route 172.20.0.0 255.255.0.0 Serial0/1

make sure you don't have "no ip routing" in the config file.

can you display the output of : show ip interfaces brief

New Member

Re: Routing error

Hello ohass,

Thank for your help ,

"ip route 172.20.0.0 255.255.0.0 Serial0/1 ", from router2 is necessary. right ?

here is output of :show ip interfaces brief

Router1

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.20.2.3 YES NVRAM up up

Serial0/0 unassigned YES NVRAM administratively down down

Serial0/1 172.18.2.5 YES manual up up

Router2

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.17.2.1 YES manual up up

Serial0/0 unassigned YES NVRAM administratively down down

FastEthernet0/1 unassigned YES NVRAM administratively down down

Serial0/1 172.18.2.6 YES manual up up

Thanks for helping

Re: Routing error

You really should avoid using interfaces as the destinations of routes, unless you are also including an IP address.

This causes the router to ARP for the next address every time it sends a packet out that interface.

Try replacing the routing statements with IP addresses instead of interfaces, and see if it helps your problem.

hth,

nick

Silver

Re: Routing error

yes it is necessary but since you have a default route (0.0.0.0) this will replace the static route. any way: any one will be enough.

now:

1-from rtr1 (console) try to ping wan of rtr2.

2-plz disp;ay the output of show ip route

New Member

Re: Routing error

Hi, did you configure gateway address on your end machines ?

293
Views
0
Helpful
6
Replies