Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gold

routing following source address

I have following simple scenario

I need static routing on router with destination 10.17.16.1.0 but network A behind router should goes to this destination via gateway A and network B should goes to this destination via gateway B... Can you give me an exaple of some route maps config???

Thx

1 ACCEPTED SOLUTION

Accepted Solutions

Re: routing following source address

Hi M.SIR,

I think this should work

route-map Test permit 10

match ip address 100

set ip next-hop

!

route-map Test permit 20

match ip address 200

set ip next-hop

!

access-list 100 permit ip

access-list 200 permit ip

Router(config)interface fa0/1

Router(config-if)# ip policy route-map Test

Regards,

Ankur

3 REPLIES

Re: routing following source address

Hi M.SIR,

I think this should work

route-map Test permit 10

match ip address 100

set ip next-hop

!

route-map Test permit 20

match ip address 200

set ip next-hop

!

access-list 100 permit ip

access-list 200 permit ip

Router(config)interface fa0/1

Router(config-if)# ip policy route-map Test

Regards,

Ankur

New Member

Re: routing following source address

That's the topology.

-10.17.16.0-

| |

| |

RTA--RTC--RTB

|

LAN (192.168.1.0)

(192.168.2.0)

Router C

interface s0/0

description to RTA

ip address 2.2.2.1 255.255.255.252

interface s0/1

description to RTB

ip address 3.3.3.1 255.255.255.252

interface eth0/2

ip address 192.168.1.0 255.255.255.0

ip address 192.168.2.0 255.255.255.0 secondary

ip policy route-map routing

route-map routing permit 5

description from 192.168.1.0 to 10.17.16.0 via RTA

match-ip address 100

set ip next-hop 2.2.2.2

route-map routing permit 5

description from 192.168.2.0 to 10.17.16.0 via RTB

match-ip address 101

set ip next-hop 3.3.3.2

access-list 100 permit ip 192.168.1.0 0.0.0.255 10.17.16.0 0.0.0.255

access-list 101 permit ip 192.168.2.0 0.0.0.255 10.17.16.0 0.0.0.255

Router A

ip route 192.168.1.0 255.255.255.0 2.2.2.1

ip route 192.168.2.0 255.255.255.0 2.2.2.1

Router B

ip route 192.168.1.0 255.255.255.0 2.2.2.1

ip route 192.168.2.0 255.255.255.0 2.2.2.1

Host in network 10.17.16.0 may have a static route to 192.168.1.0 and 192.168.2.0

Best regards

Please rate this post .

New Member

Re: routing following source address

The topology doesn't appear well,

RTA--RTC--RTB

RTC

|

LAN (192.168.1.0)

(192.168.2.0)

10.17.16.0

|

RTB

10.17.16.0

|

RTA

there is mistake on RTB configuration , modify it as :

Router B

ip route 192.168.1.0 255.255.255.0 3.3.3.1

ip route 192.168.2.0 255.255.255.0 3.3.3.1

Best regards.

98
Views
0
Helpful
3
Replies
CreatePlease to create content