Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Routing Help - 3640

I am trying to setup my home lab, but not having much luck.  Here is what I have going on...

Cabel Modem ----> Cisco/Linksys Router(192.168.5.1)------->Cisco 3640 (192.168.2.1)

What I want to do is have my internet connection split in to so when I mess with the 3640 I don't interupt the internet connection for the computers outside the lab network.  I has to be something simple, but I can't figure it out.

Here is my running config from the 3640:

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.2.1

!

ip dhcp pool Home

   import all

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

!

ip dhcp pool 192.168.2.100-192.168.2.254

!

ip audit notify log

ip audit po max-events 100

!

call rsvp-sync

!

!

!

!

!

partition flash 2 16 16

!

!

!

!

interface FastEthernet0/0  <---connection from the 192.168.5.0 network

ip address dhcp

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.0

no ip http server

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

I tried the static route of:

Router(dhcp-config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1

But got this as a result: %Invalid next hop address (it's this router)

2 REPLIES

Re: Routing Help - 3640

Hi Jonathan,

Try 192.168.5.1 instead:

ip route 0.0.0.0 0.0.0.0 192.168.5.1

Sent from Cisco Technical Support iPhone App

Routing Help - 3640

Hi jonathan,

John is right.

Also since you are using dhcp on the switch to get the ip address from your linksys router(dont know why you do that rather than simply confuguring a /30). you also need to have a return route from the linksys router to the 192.168.2.0 subnet.

so on the linksys router have a static route

ip route 192.168.2.0 255.255.255.0 < exit-interface> . The interface is what connects to the 3640 fa0/0 port

HTH

Kishore

260
Views
0
Helpful
2
Replies
CreatePlease to create content