Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing Policies Redundant?

Hello,

I want to implement a routing policy that forces all traffic with a certain destination port down one specific link of two wan links. However, should that one link go down, I would want traffic to roll over the other wan link. Is this possible with routing policies?

Thank you,

Tate

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Routing Policies Redundant?

Hi,

You will need to configure your router as follows in order to get Citrix traffic to go over one link but fail over to the second link if the first goes down.

! track link one

track 123 rtr 1 reachability

! track link two

track 124 rtr 2 reachability

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

ip policy route-map PolMap

!

interface Ethernet0/1

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/2

ip address 192.168.2.1 255.255.255.0

!

ip access-list extended CitrixTraffic

permit tcp any any eq 1494

! add any other lines as necessary

!

route-map PolMap permit 10

match ip address CitrixTraffic

set ip next-hop verify-availability 192.168.1.254 10 track 123

set ip next-hop verify-availability 192.168.2.254 20 track 124

!

rtr 1

type echo protocol ipIcmpEcho 192.168.1.254

rtr schedule 1 life forever start-time now

!

rtr 2

type echo protocol ipIcmpEcho 192.168.2.254

rtr schedule 2 life forever start-time now

!

Pls do remember to rate posts.

Paresh

5 REPLIES

Re: Routing Policies Redundant?

You can do this with PBR using multiple tracking options feature.

The link below should guide you through the process.

http://www.cisco.com/en/US/tech/tk364/technologies_configuration_example09186a0080211f5c.shtml

Pls. rate all helpful posts.

HTH,

Sundar

New Member

Re: Routing Policies Redundant?

Thanks for the reply,

I already know how to do the object tracking with a routing policy, but I want to create a routing policy that sends all traffic of one type (citrix) down the first link, and then have it roll over to the second link if link one goes down. So would I have one policy for tracking, and one policy for my citrix traffic?

thanks,

Purple

Re: Routing Policies Redundant?

Hi,

You will need to configure your router as follows in order to get Citrix traffic to go over one link but fail over to the second link if the first goes down.

! track link one

track 123 rtr 1 reachability

! track link two

track 124 rtr 2 reachability

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

ip policy route-map PolMap

!

interface Ethernet0/1

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/2

ip address 192.168.2.1 255.255.255.0

!

ip access-list extended CitrixTraffic

permit tcp any any eq 1494

! add any other lines as necessary

!

route-map PolMap permit 10

match ip address CitrixTraffic

set ip next-hop verify-availability 192.168.1.254 10 track 123

set ip next-hop verify-availability 192.168.2.254 20 track 124

!

rtr 1

type echo protocol ipIcmpEcho 192.168.1.254

rtr schedule 1 life forever start-time now

!

rtr 2

type echo protocol ipIcmpEcho 192.168.2.254

rtr schedule 2 life forever start-time now

!

Pls do remember to rate posts.

Paresh

New Member

Re: Routing Policies Redundant?

Thanks!,

I actually thought of a different way to implement what I wanted to do, and this way I can verify that it works with a traceroute. I attached my network diagram. Since my citrix server is .34, I thought I could make traffic from .34 always go down the WAN but also fail over. Does this config look OK per the network diagram?

ip sla monitor 1

type echo protocol ipIcmpEcho 10.10.10.3

timeout 1000

threshold 2

frequency 2

ip sla monitor schedule 1 life forever start-time now

ip sla monitor 2

type echo protocol ipIcmpEcho 10.10.33.1

timeout 1000

threshold 2

frequency 2

!

!

track 10 rtr 1 reachability

!

track 33 rtr 2 reachability

!

interface FastEthernet0/1

ip address 192.168.200.6 255.255.254.0

ip policy route-map PolMap

duplex auto

speed auto

!

ip route 192.168.33.0 255.255.255.0 10.10.10.3 track 10

ip route 192.168.33.0 255.255.255.0 10.10.33.1 track 33

!

access-list 150 permit ip host 192.168.200.34 any

!

route-map PolMap permit 10

match ip address 150

set ip next-hop verify-availability 10.10.10.3 10 track 10

set ip next-hop verify-availability 10.10.33.1 20 track 33

I am using existing track objects for this, is that OK? I also already have redundant routes in for the destination network, do I need to change any ip route statements?

thank you very much.

New Member

Re: Routing Policies Redundant?

Thanks so much guys!

It seems to work fine.

103
Views
0
Helpful
5
Replies