Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

mig
New Member

Routing Problem with DDR over Async-Interface

Hi!

My configuration consists of two 1711 with WIC-1AM running IOS 12.3(7)XR4. I configured dialer-watch, this works fine. But my problem is no routing-packets (no hello packets) are sent across the dial-Up link. I have tested it with EIGRP and OSPF. The network of the interface is still in the routing-process and no passive-interface is configured. I see the hello-packets with "debug ip ospf hello" or "debug eigrp packets" send to the async-interface so long until the dial-up interface cames up. Then no more hello-packet is sent. Why is this so?

Can you help me?

Here the config of the dialing router:

Current configuration : 1649 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

!

username Router2 password ***

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

!

!

ip cef

ip ids po max-events 100

no ftp-server write-enable

!

chat-script mike ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT \c

!

!

!

!

!

!

!

interface Loopback0

ip address 172.16.255.5 255.255.255.255

!

interface FastEthernet0

ip address 172.16.255.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

shutdown

!

interface Vlan1

no ip address

!

interface Async1

ip address 172.16.255.9 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 30

dialer map ip 172.16.50.0 name Router2 modem-script mike broadcast 13

dialer watch-group 1

dialer-group 1

async mode interactive

ppp authentication chap

!

router ospf 2704

log-adjacency-changes

network 172.16.255.0 0.0.0.3 area 0

network 172.16.255.8 0.0.0.3 area 0

!

ip classless

no ip http server

no ip http secure-server

!

!

!

access-list 101 deny ospf any any

access-list 101 permit ip any any

dialer watch-list 1 ip 172.16.50.0 255.255.255.0

dialer-list 1 protocol ip list 101

!

!

control-plane

!

!

line con 0

line 1

modem InOut

transport input all

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

end

11 REPLIES
New Member

Re: Routing Problem with DDR over Async-Interface

Porque no intentas con rutas estaticas para no generar trafico de enrutamiento.

You can try static routes

mig
New Member

Re: Routing Problem with DDR over Async-Interface

Yes, another possibility is to try it with a floating-static route. But with a floating-static route the dial-up connection is only used on interesting traffic. My requirement is to dial the backup as soon as the primary-link fails.

The dialer-watch with a static-route brings the problem that the static route is always better than the route learned from a routing-protocol, so the dial-up link never goes down (except the idle-timer runs out).

Re: Routing Problem with DDR over Async-Interface

Hi,

I think that you can do this using a floating static route using an administratice distance higher than that of the routing protocol you are using, and so if the route through your routing protocol is lost the floating static route is used.

regards.

mig
New Member

Re: Routing Problem with DDR over Async-Interface

Hi,

Yes with a floating static route my configuration works fine.

But i don´t know why no routing hellos were sent as soon as the asyc-interface comes up??

regards

mig

mig
New Member

Re: Routing Problem with DDR over Async-Interface

Hi,

As soon as the async-interface cames up, the output of "show ip ospf interface" contains that the interface is a passive-interface (no hellos) :(

But I haven´t configured it as passive-interface.

Why is this so?

I hope someone can help me!

Thanks,

mig

Async1 is up, line protocol is up

Internet Address 172.16.255.9/30, Area 0

Process ID 2704, Router ID 172.16.255.5, Network Type POINT_TO_POINT, Cost: 869

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

No Hellos (Passive interface)

Supports Link-local Signaling (LLS)

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

Re: Routing Problem with DDR over Async-Interface

Hi,

Really i can't find anything wrong in your config :(

try typing "no passive-interface Async1" under the ospf process.

mig
New Member

Re: Routing Problem with DDR over Async-Interface

I have already tried this, with no affect.

The symptom is that the entry "(no hellos) passive-interface" in the output "show ip ospf interface" is shown only when the async-interface cames up. If the interface is down, this entry is not in the output. :((

Re: Routing Problem with DDR over Async-Interface

mig
New Member

Re: Routing Problem with DDR over Async-Interface

Thanks, I´ve found this link already.

But in my example, the neighbor don´t stuck in the exstart/exchange process. My problem is concerning the hello-packets. In my example the dialer-interface is definitely point-to-point.

Re: Routing Problem with DDR over Async-Interface

Kindly see this link too --> try using dialer interface

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481b.shtml

New Member

Re: Routing Problem with DDR over Async-Interface

this thread is a bit old, but this may be the answer:

under the async interface:

async default routing

196
Views
0
Helpful
11
Replies
CreatePlease login to create content