Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

routing problems

hello every one. I have bought 2 cisco 2500 routers, I connected them together with dte/dce cable, encapsulation on both serial are hdlc, clock rate on dce end both set to 64000, routing protocol used is rip, every time i enter sh ip route, cannot see other serial cable on routing table.

DTE router is running on is 11.2 os, while dce router is running on 11.0 os i think this might be the problem could someone confirm this to me, funny enough when i do a sh int on either router it is shown as line up, protocol up on.

Now if the problem is incompatible os, this obviously means i need to up grade one of the routers to 11.2, slight problem. As i am working from a single pc that is not connected to a network, I cannot seem to generate an ip address for my windows xp computer, everytime i enter ipconfig on dos, it just comes out as media state..........media disconnected. I have downloaded a tftp server on to my pc, but still cannot generate an ip address for my pc, which means i cannot up grade my router, nor can i telnet/ping my routers from pc, but i can access them through hyperterminal/serial roll cable.

Could someone please tell me how i can ping my router from my pc, this is the config for my dce router

Current configuration:

!

version 11.0

!e

service udp-small-serverstching on the same interf

service tcp-small-servers

!

hostname moyo network

!2

ICMP redirects are always sen

enable password redfox

networ

!1

!.

interface Serial0CMP unreachables

description my first serial int conf

ip address 192.168.10.1 255.255.255.0255.255.255 via Serial1 (192.168.90.1)

interface TokenRing0

no ip address

ring-speed 4

!

interface TokenRing1

no ip address

shutdown

!

router igrp 10

network 192.168.10.0

network 192.168.20.0

!

!

line con 0

line aux 0

password moyo

login

transport input all

line vty 0 4

password moyo

login

!

end

for my dte router the sh run

version 11.22.168.90.0,

no service password-encryptionic 1.80.1),

service udp-small-servers

service tcp-small-servers255.255.255.255 via Seria

!

hostname moyo_dte Serial1 (192.168

!0

!

!

interface Serial0

description #dte 0 to 2nd router#

network 192.168.80.

ip address 192.168.80.1 255.255.255.0ng is d

no ip mroute-cache

!I

interface Serial1te to 255.255.255

description #dte 1 to 2nd router# line protocol is up metric 1, 0 c

ip address 192.168.90.1 255.255.255.0

interface TokenRing0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

router rip

network 192.168.80.0

network 192.168.90.0

!

ip classless

!

!

line con 0

line aux 0

password moyo

login

transport input all

line vty 0 4

password moyo

login

!

end

could some please advise me been racking my brains

3 REPLIES
Hall of Fame Super Silver

Re: routing problems

Moyo

There appears to be some other output mixed in with the config output on the dce router. This confuses things and I may not have an accurate understanding of your router. But I think that I do see several issues.

- I do not see a clock rate command on the serial interface of the dce router. The clock rate is needed on the dce if the router are connected directly back to back. But you say that the routers show the serial interface as up and up, so maybe it is there and I do not see it.

_ on the dce router I see only one serial interface. Most of these 2500 routers have two serial interfaces. Does the dce router have another serial and if so how is it configured?

- the dce router seems to have this address on the serial interface:

ip address 192.168.10.1

and the dte router has these two addresses:

192.168.80.1

192.168.90.1

If serial interfaces are connected directly back to back then the IP addresses configured need to be in the same subnet.

I believe that the mismatched addresses are the reason that you are not seeing the routing table content that you are expecting.

- I see that you appear to be running the igrp routing protocol on the dce router and running rip on the dte router. This will also prevent the routers from exchanging routing information. Either configure both routers with igrp or configure both routers with rip.

- It also looks like both of the 2500 routers have Token Ring interfaces and not Ethernet interfaces. Unless you have a Token Ring interface card on your PC you will not be able to establish a LAN connection from your PC to either of the routers.

If you correct the IP addresses on the serial I believe that the routers will be able to communicate with each other. I do not think that there is an easy answer for the Token Ring issue.

HTH

Rick

New Member

Re: routing problems

one is setup for igrp and one is setup for rip. they should both be setup for the same routing protocol...

New Member

Re: routing problems

right i see your point, there is 2 questions i want to ask, how can i create an ip address for my standalone pc, so i can transfer the flash file to my pc, every time i enter ipconfig on my pc it just gives me the ip address of my modem thats connected to the internet and some thing called media disconnected. I have tried to ping the ip address of the modem from my router but to no avail, i have even tried to ping the serial ports on my router but to no avail.

My second question is my first router is running cisco ios 11.0, the second one is running cisco 11.2 would i still be able to see my routing table via rip, even though the ios of both routers arer not compatible

97
Views
0
Helpful
3
Replies
CreatePlease login to create content