Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing question (OSPF)

i have 3 AS -my 65334 and ISP's.

I received 2 routes- 10.20.24.0/24(AS3216) and 10.20.48.0/24 ( AS2854).

Inside AS i use OSPF.

Here parts of configs-

---------------

Router R1-

----------------------------

router ospf 1

log-adjacency-changes

network 1.1.1.0 0.0.0.255 area 0

network 172.22.22.0 0.0.0.7 area 0

redistribute bgp 65334 subnets

router bgp 65334

no synchronization

bgp log-neighbor-changes

network 172.22.23.1 mask 255.255.255.255

timers bgp 5 20

redistribute ospf 1 match internal external 1 external 2

neighbor 172.30.0.66 remote-as 3216

neighbor 172.30.0.66 soft-reconfiguration inbound

no auto-summary

===========================

R1#sh ip route 10.20.48.0

Routing entry for 10.20.48.0/24

Known via "ospf 1", distance 110, metric 1

Tag 2854, type extern 2, forward metric 2

Redistributing via bgp 65334

Advertised by bgp 65334 match internal external 1 & 2

Last update from 1.1.1.1 on GigabitEthernet0/1, 00:17:12 ago

Routing Descriptor Blocks:

* 1.1.1.1, from 172.22.23.2, 00:17:12 ago, via GigabitEthernet0/1

Route metric is 1, traffic share count is 1

Route tag 2854

==========================

Router R2-

------------------

router ospf 1

log-adjacency-changes

redistribute bgp 65334 subnets

network 2.2.2.0 0.0.0.255 area 0

network 172.22.22.0 0.0.0.7 area 0

!

router bgp 65334

no synchronization

bgp log-neighbor-changes

network 172.22.23.2 mask 255.255.255.255

timers bgp 5 20

redistribute static

redistribute ospf 1 match internal external 1 external 2

neighbor 172.16.200.194 remote-as 2854

neighbor 172.16.200.194 soft-reconfiguration inbound

no auto-summary

===============

R2#sh ip route 10.20.24.0

Routing entry for 10.20.24.0/24

Known via "ospf 1", distance 110, metric 1

Tag 3216, type extern 2, forward metric 2

Redistributing via bgp 65334

Advertised by bgp 65334 match internal external 1 & 2

Last update from 2.2.2.1 on FastEthernet0/0, 00:16:21 ago

Routing Descriptor Blocks:

* 2.2.2.1, from 172.22.23.1, 00:16:21 ago, via FastEthernet0/0

Route metric is 1, traffic share count is 1

Route tag 3216

-----------------

From router R1 network 10.20.48.0/24 is reachable via 1.1.1.1. But i've direct

connection between R1 and R2.

Same with router R2 and network 10.20.24.0/24.

How to use direct link between R1 and R2?

R1#sh ip ospf ne

Neighbor ID Pri State Dead Time Address Interface

192.168.16.1 1 FULL/DR 00:00:35 1.1.1.1 GigabitEthernet0/1

172.22.23.2 1 FULL/DR 00:00:34 172.22.22.2 FastEthernet1/1

R2#sh ip ospf ne

Neighbor ID Pri State Dead Time Address Interface

172.22.23.1 1 FULL/BDR 00:00:31 172.22.22.1 FastEthernet2/1

192.168.16.1 1 FULL/DR 00:00:34 2.2.2.1 FastEthernet0/0

3 REPLIES
Cisco Employee

Re: Routing question (OSPF)

Mike,

Make sure that the ospf cost of going over the direct link between r1 and r2 is lower than the cost of going via the third router. It looks like it is not currently the case.

Hops this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Routing question (OSPF)

HAROLD, Thank you for reply!

Here info about costs-

R1

===

R1##sh ip ospf int

GigabitEthernet0/1 is up, line protocol is up

Internet Address 1.1.1.201/24, Area 0

Process ID 1, Router ID 172.22.23.1, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DROTHER, Priority 1

Designated Router (ID) 192.168.16.1, Interface address 1.1.1.1

Backup Designated router (ID) 10.20.46.4, Interface address 1.1.1.2

----------

FastEthernet1/1 is up, line protocol is up

Internet Address 172.22.22.1/29, Area 0

Process ID 1, Router ID 172.22.23.1, Network Type BROADCAST, Cost: 10

Transmit Delay is 1 sec, State BDR, Priority 1

Designated Router (ID) 172.22.23.2, Interface address 172.22.22.2

Backup Designated router (ID) 172.22.23.1, Interface address 172.22.22.1

--------------

R2

====

R2#sh ip ospf int

FastEthernet2/1 is up, line protocol is up

Internet Address 172.22.22.2/29, Area 0

Process ID 1, Router ID 172.22.23.2, Network Type BROADCAST, Cost: 10

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.22.23.2, Interface address 172.22.22.2

Backup Designated router (ID) 172.22.23.1, Interface address 172.22.22.1

--------

FastEthernet0/0 is up, line protocol is up

Internet Address 2.2.2.201/24, Area 0

Process ID 1, Router ID 172.22.23.2, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State BDR, Priority 1

Designated Router (ID) 192.168.16.1, Interface address 2.2.2.1

=====

Yes, as you supposed the link between R1 and R2 have greatest cost ( 10 instead 1 for another interface).

I can manualy decrease cost for link R1-R2 and increase cost for others interfaces.

But! AS3216 and 2854 have a lot others routes which come to R1 and R2 and redistribute inside my AS5334. I want to use link R1-R2 only for communications networks in AS3216 and 2854 between each others and for backup purpose( in case of MEN failure).

Do you think changing cost can affected only for communications networks in AS3216 and 2854 between each others ( they will use link R1-R2 instead for example R1-MEN-Router-MEN-R2)?

Cisco Employee

Re: Routing question (OSPF)

You could use MPLS TE to make sure traffic between AS3216 and 2854 go across the direct r1 to r2 link.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
100
Views
0
Helpful
3
Replies