Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Routing specific network via BGP

Hi,

I need assistant on routing BGP. We have one router with a few network being advertise out to both primary and backup link via BGP.

Is there a way to route the following:

Network A, B, C out to ISP 1 via BGP

Network D, E, F out to ISP 2 via BGP

This process has to be real-time traffic. Basically both links are active at the same time and there is no more failover. Specific networks will only use the dedicated links we push them out to. Traffic should be symetric on return route.

Any suggestion would be highly highly appreciated.

Our config below.

interface FastEthernet4/0

description LINK TO BACKUP - 40MBPS

bandwidth 40960

ip address Y.Y.Y.Y 255.255.255.252

ip flow ingress

load-interval 30

shutdown

duplex full

speed 100

no cdp enable

!

interface FastEthernet4/1

bandwidth 30720

no ip address

ip flow ingress

load-interval 30

duplex full

speed 100

no cdp enable

!

interface FastEthernet4/1.1

description LINK TO PRIMARY - 30MBPS

bandwidth 30720

encapsulation dot1Q 1001

ip address X.X.X.X 255.255.255.252

ip flow ingress

ip nbar protocol-discovery

service-policy output QoS-DIA-Parent-OUT

!

router bgp 1234

bgp log-neighbor-changes

neighbor Y.Y.Y.Y remote-as 5678

neighbor X.X.X.X remote-as 91011

!

address-family ipv4

neighbor Y.Y.Y.Y activate

neighbor Y.Y.Y.Y weight 3000

neighbor Y.Y.Y.Y prefix-list BLOCKINBOUNDBGP in

neighbor Y.Y.Y.Y prefix-list BLOCKOUTBOUNDBGP out

neighbor X.X.X.X activate

neighbor X.X.X.X weight 2000

neighbor X.X.X.X soft-reconfiguration inbound

neighbor X.X.X.X prefix-list BLOCKINBOUNDBGP in

neighbor X.X.X.X prefix-list BLOCKOUTBOUNDBGP out

no auto-summary

no synchronization

network A mask 255.255.255.0

network B mask 255.255.255.0

network C mask 255.255.255.0

network D mask 255.255.255.0

network E mask 255.255.255.0

network F mask 255.255.255.0

exit-address-family

!

ip classless

ip route A 255.255.255.0 Null0 250 name Route_to_advertise_BGP

ip route B 255.255.255.0 Null0 250 name Route_to_advertise_BGP

ip route C 255.255.255.0 Null0 250 name Route_to_advertise_BGP

ip route D 255.255.255.0 Null0 250 name Route_to_advertise_BGP

ip route E 255.255.255.0 Null0 250 name Route_to_advertise_BGP

ip route F 255.255.255.0 Null0 250 name Route_to_advertise_BGP

!

!

!

ip prefix-list BLOCKINBOUNDBGP seq 10 permit 0.0.0.0/0

!

ip prefix-list BLOCKOUTBOUNDBGP seq 10 permit A/24

ip prefix-list BLOCKOUTBOUNDBGP seq 15 permit B/24

ip prefix-list BLOCKOUTBOUNDBGP seq 20 permit C/24

ip prefix-list BLOCKOUTBOUNDBGP seq 25 permit D/24

ip prefix-list BLOCKOUTBOUNDBGP seq 30 permit E/24

ip prefix-list BLOCKOUTBOUNDBGP seq 35 permit F/24

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Routing specific network via BGP

ip prefix-list BLOCKOUTBOUNDBGP seq 25 permit D/24

ip prefix-list BLOCKOUTBOUNDBGP seq 30 permit E/24

ip prefix-list BLOCKOUTBOUNDBGP seq 35 permit F/24

Hi,

As per my understanding your purpode is to route Network A B and C through ISP1

and E F and G through IPS 2 and both ISPs are connected at the same router.

You can use weight metric for infulencing the traffic.

Ceate prifix list

ip prefix-list BLCOKOUTBOUND seq 10 permit A/24

ip prefix-list BLOCKOUTBOUND seq 15 permit B/24

ip prefix-list BLOCKOUTBOUND seq 20 permit C/24

and

ip prefix-list BLOCKOUTBOUNDBGP seq 25 permit D/24

ip prefix-list BLOCKOUTBOUNDBGP seq 30 permit E/24

ip prefix-list BLOCKOUTBOUNDBGP seq 35 permit F/24

Create routemap

Routemap NET_ABC

match ip address prifix-list BLCOKOUTBOUND

set weight 50

match ip address prifix-list BLCOKOUTBOUNDBGP

set weight 150

Router bgp 1234

neighbor Y.Y.Y.Y routemap NET_ABC out

Hope this can help you to get the desired output

Thanks

Shashi

1 REPLY
New Member

Routing specific network via BGP

ip prefix-list BLOCKOUTBOUNDBGP seq 25 permit D/24

ip prefix-list BLOCKOUTBOUNDBGP seq 30 permit E/24

ip prefix-list BLOCKOUTBOUNDBGP seq 35 permit F/24

Hi,

As per my understanding your purpode is to route Network A B and C through ISP1

and E F and G through IPS 2 and both ISPs are connected at the same router.

You can use weight metric for infulencing the traffic.

Ceate prifix list

ip prefix-list BLCOKOUTBOUND seq 10 permit A/24

ip prefix-list BLOCKOUTBOUND seq 15 permit B/24

ip prefix-list BLOCKOUTBOUND seq 20 permit C/24

and

ip prefix-list BLOCKOUTBOUNDBGP seq 25 permit D/24

ip prefix-list BLOCKOUTBOUNDBGP seq 30 permit E/24

ip prefix-list BLOCKOUTBOUNDBGP seq 35 permit F/24

Create routemap

Routemap NET_ABC

match ip address prifix-list BLCOKOUTBOUND

set weight 50

match ip address prifix-list BLCOKOUTBOUNDBGP

set weight 150

Router bgp 1234

neighbor Y.Y.Y.Y routemap NET_ABC out

Hope this can help you to get the desired output

Thanks

Shashi

139
Views
0
Helpful
1
Replies
CreatePlease to create content