Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing Subnet?

Hi,

We've got a Cisco 828 with an extra block of public addresses. Extra block (lets say 82...) gets routed to 1 other address (lets say 222...), by our ISP.

Now we want to get some 'internal' machines using those 82...-addresses. But we don't exactly see how to route or how to modify our 828 in a correct way to handle incoming 82...-requests.

Lan-access (NAT) is not a problem...

Any snippet of code would be really handy.

Thanks,

Fré

1 REPLY
Silver

Re: Routing Subnet?

If you don't need the "internal" machines to have these new public addresses directly, but can settle for NAT'ing, then it's relatively easy:

interface ATM0

ip address 222.222.222.2 255.255.255.252

ip nat outside

no ip unreachables

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

ip nat inside

!

! The following route should be you public NAT network

ip route 82.82.82.0 255.255.255.0 Null0

ip nat inside source static 10.10.10.10 82.82.82.10

ip nat inside source static 10.10.10.11 82.82.82.11

!

This is given that the ISP routes the 82... network to your interface address on the ATM-link..

But if you want the "internal" machines to have the public addresses configured, you could put a secondary address on your internal LAN-if:

NOTE: THIS IS NOT A RECOMMENDED SOLUTION!!

interface ATM0

ip address 222.222.222.2 255.255.255.252

ip nat outside

no ip unreachables

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

ip address 82.82.82.1 255.255.255.0 secondary

ip nat inside

!

Now you can have both internal addresses and public addresses on the LAN.. but... THIS IS NOT A RECOMMENDED SOLUTION!!!

284
Views
0
Helpful
1
Replies