Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing two building together help

Hi,

I am in the process to route two buildings together. Both building have the same network setup.

2 Core Switches 4506-E Chassis having glbp for layer 3 redundency on about 20 vlan in each building with default intervlan routing in place.

Below is a simple sketch of how these are connected. Blue lines are still not connected...

photo.JPG

What I need is to setup routing onto the blue fibre links so that networks from building 1 can reach networks on building to and vias versa. I would also need to implement some sort of redundency since I have to fibre links between the 2 building.

Any help and examples would be greatly appriciated.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Routing two building together help

Hi Jesmond,

did you issue the

no switchport

command before attempting to install ip? Below there is the guide for your machine...

Alessio

      

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/15.1/XE_330SG/configuration/guide/l3_int.html#wp1029778

      

Jokes aside, pls mark this thread as answered

Take Care

Alessio

9 REPLIES

Re: Routing two building together help

Hi Jesmond,

it's my opinion you should treat the links between the 4500s like a logical core and enabling OSPF/EIGRP on those links. A Layer 3 native routing solution has also another benefit, you can limit the broadcast domain from crossing the core links. every information which needs to pass from a building to another will be IP encapsulated and sent out.

And it would be loop-free.

Being Intervlan-routing in process you need just to advertise /30 link for each "blue fibre" you will be connecting making sure that the "no passive-interface link_interface" . Possibly you have trunks between your 4500s that allow intervlan routing. everything should be up normally.

Take Care

Alessio

New Member

Re: Routing two building together help

Hi Alessio,

Thanks for the information. Since I never worked with routing, this is all new for me.

Do you have any examples of how to configure the EIGRP on this setup?

Regards,

Jesmond

Routing two building together help

Ok,

let's assume that we have B1=building1 and B2=building2

and that the link over the blue fibre from B1 to B2 is 10.1.2.0/30

and the other link 10.2.1.0/30

the .1 ip addresses will belong to building 1 and the .2 will belong to building 2

Router 4500_B1_A

conf t

int g0/1         

description Blue fibre pointing to Building 2 on 4500B2_B

ip address 10.1.2.1 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.1.2.0 0.0.0.3

Router 4500_B1_B

conf t

int g0/1        

description Blue fibre pointing to Building 2 on 4500B2_A

ip address 10.2.1.1 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.2.1.0 0.0.0.3

Router 4500_B2_A

conf t

int g0/2       

description Blue fibre pointing to Building 1 on 4500B1_A

ip address 10.2.1.2 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.2.1.0 0.0.0.3

Router 4500_B2_B

int g0/2       

description Blue fibre pointing to Building 1 on 4500B1_B

ip address 10.1.2.2 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.1.2.0 0.0.0.3

If i did not cross the IP this should be a good start point. keep in mind that this config is only for the blu fibre (as you defined), that means only the point to point link inter-building. it is important to understand how your inter-vlan routing is set. From what i have understood, once you change to my config example the correct AS number (EIGRP) you should be very close to your final config even if without optimisation!!!

essentially my config is to add/merge to your current EIGRP configuration

Take Care

Alessio

New Member

Re: Routing two building together help

Hi Alessio,

I was trying to start working on you configuration example and I notices that you have connected as below:

B1_A to B2_B

and

B1_B to B2_A

Am I correct? If yes I have to connect the 2 blue fibres differently from as they are on the picture.

Waiting for your kind reply.

Thanks

Jesmond

Re: Routing two building together help

It was just crossing the switches

  • Router 4500_B1_A

conf t

int g0/1

description Blue fibre pointing to Building 2 on 4500B2_A

ip address 10.1.2.1 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.1.2.0 0.0.0.3

Router 4500_B1_B

conf t

int g0/1

description Blue fibre pointing to Building 2 on 4500B2_B

ip address 10.2.1.1 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.2.1.0 0.0.0.3

Router 4500_B2_A

int g0/2

description Blue fibre pointing to Building 1 on 4500B1_A

ip address 10.1.2.2 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.1.2.0 0.0.0.3

Router 4500_B2_B

conf t

int g0/2

description Blue fibre pointing to Building 1 on 4500B1_B

ip address 10.2.1.2 255.255.255.252

no sh

!

exit

!

router eigrp 100

no auto

network 10.2.1.0 0.0.0.3

!

!

Check again of course but this should be the one you want

Rate if you like this post

Alessio

New Member

Re: Routing two building together help

Hi Alessio,

Thanks for the update!

Will test this config and let you know with any output!

Thanks Again.

Jesmond

New Member

Re: Routing two building together help

Hi Alessio,

For some reason, I have no option to add an IP address on my tenG interface on my supervisory engine. (WS-X45-SUP7L-E) IP Base Image. Do you know why?

Jesmond

Re: Routing two building together help

Hi Jesmond,

did you issue the

no switchport

command before attempting to install ip? Below there is the guide for your machine...

Alessio

      

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/15.1/XE_330SG/configuration/guide/l3_int.html#wp1029778

      

Jokes aside, pls mark this thread as answered

Take Care

Alessio

New Member

Re: Routing two building together help

Hi Alesio,

I forgot to issue that command at first, than I rembered and is issued the command and everything is ok.

Thanks!!!

Jesmond

519
Views
5
Helpful
9
Replies
CreatePlease login to create content