Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

routing using RIP V2

Hi ,

I am having a doubt of how to configure RIPv2 for the following network scenarios.

We are in the process of upgrading our Internet connection from frame relay to 20Meg pipe. With respect to that we are placing 3750 Cisco catalyst switch at ISP collocation rack were ISP provide an Ethernet connection to my Switch. From there optical fibre cable terminal to my premises. Each end comprise of a router provided by Telecom Company. Which comprise of PIP solutions also to connect inter office network.

Let me take collocation end router provided by telecom company as Router A ( ip 10.3.255.66/27) it is terminated to a Cisco 3750 switch . The Cisco 3750 switch is has the ISP Ethernet interface terminated which provides internet connection to my office premises.

At my office premises I have other end of Router A , terminated to router B ( ip 10.2.255.1/29) and other end terminated to Cisco 3750 switch , one of the interface is connected to my PIX Firewall which has WAN IP address for example 203.5.221.221 and the rest of the WAN IP address are behind my firewall i.e DMZ network.

I want to route 203.0.0.0 ( public IP address) to the internet community. It has to route via Router B and Router A before reaching Internet cloud, I need a solution of how to configure route for this public ip address by passing through two routers and a catalyst switch 3750 before reaching internet world. Please help me with good solution since I have to complete this task by 15 Feb 2006.

Thanks in advance

siva

1 ACCEPTED SOLUTION

Accepted Solutions

Re: routing using RIP V2

Hello,

in case you would like to stick with RIPv2 (feasable imho) the common part of the config should look like this:

router rip

version 2

no auto-summary

network 10.0.0.0

(this network statement should identify the interfaces where RIP should be used - it does NOT define the announced networks)

You still need a point at which you insert the information on the 203/8 network (or default route?)

The default route or 203/8 route can be setup as a static route

ip route 203.0.0.0 255.0.0.0 10.1.2.3 ethernet0

(or ip route 0.0.0.0 0.0.0.0 10.1.2.3 ethernet0)

assuming your next hop is 10.1.2.3 reachable through Ethernet0. You need to adjust this to your environment. On this router you should redistribute the static into RIP:

router rip

version 2

network 10.0.0.0

no auto-summary

redistribute static

passive-interface ethernet0

The passive-interface command makes sure, that you do not send RIP updates to your ISP.

Hope this helps! Please rate all posts.

Regards, Martin

2 REPLIES

Re: routing using RIP V2

The most common practice for this situations is to use a static route. You could redistribute it via RIP if needed using the command:

redistribute static

Regards,

Leo

Re: routing using RIP V2

Hello,

in case you would like to stick with RIPv2 (feasable imho) the common part of the config should look like this:

router rip

version 2

no auto-summary

network 10.0.0.0

(this network statement should identify the interfaces where RIP should be used - it does NOT define the announced networks)

You still need a point at which you insert the information on the 203/8 network (or default route?)

The default route or 203/8 route can be setup as a static route

ip route 203.0.0.0 255.0.0.0 10.1.2.3 ethernet0

(or ip route 0.0.0.0 0.0.0.0 10.1.2.3 ethernet0)

assuming your next hop is 10.1.2.3 reachable through Ethernet0. You need to adjust this to your environment. On this router you should redistribute the static into RIP:

router rip

version 2

network 10.0.0.0

no auto-summary

redistribute static

passive-interface ethernet0

The passive-interface command makes sure, that you do not send RIP updates to your ISP.

Hope this helps! Please rate all posts.

Regards, Martin

277
Views
0
Helpful
2
Replies