Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing with 3640 and 3745 via WIC-2T

I have two routers I am trying to connect via the WIC-2T port.  I can ping from router to router, but not from my PC (192.168.2.122) to the 3745 (10.0.1.3)...help please...

3640:

Current configuration : 1846 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.1 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

ip address 10.0.1.4 255.255.255.0

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip route 192.168.2.0 255.255.255.0 10.0.1.3

ip route 192.168.3.0 255.255.255.0 10.0.1.2

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

3745:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.3 255.255.255.0

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

ip route 192.168.3.0 255.255.255.0 10.0.1.4

!

ip http server

ip http authentication local

ip nat inside source list 15 interface FastEthernet0/0 overload

!

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Routing with 3640 and 3745 via WIC-2T

On each router you need to change the statement for networks you are advertising in eigrp

On 3640

router eigrp 1

no auto-summary

network 10.0.1.4

network 10.0.1.8

network 192.168.2.0

On 3745

router eigrp 1

no auto-summary

network 10.0.1.4

network 192.168.1.0

On 2610

router eigrp 1

no auto-summary

network 10.0.1.8

network 192.168.3.0  - I don't see 2610 config posted, change this network to what is configured.

This should work. On PCs change default gateway to point to router interfaces and give them an address in same subnet

Example PC connected to 3640

ip address 192.168.2.10

Subnet mask 255.255.255.0

Default gateway 192.168.2.1

Eugen

15 REPLIES
Hall of Fame Super Silver

Routing with 3640 and 3745 via WIC-2T

Jonathan

This is a fairly simple issue to diagnose and solve. The source IP is  192.168.2.122 but the 3745 has no route for that network. That network is remote, you are not running a dynamic routing protocol, and there is no static route for 192.168.2.0. It would be easy to verify this diagnosis by doing show ip route on the 3745.

The solution would be either to run a dynamic routing protocol between the routers or to configure a static route on the 3745 for 192.168.2.0.

HTH

Rick

New Member

Routing with 3640 and 3745 via WIC-2T

Thanks, do you have a suggestion on which protocol would be better?  RIP or RIPv2 should be the easiest to configure, but would EIGRP be better?  Also can you help me with a quick config just to get them talking to each other?

What I want to connect the three routers via the serial connection, and be able to talk to all the 192.168.X.X networks.

3640: FE 0/0 ----> DHCP set by ISP

         FE 0/1 ----> 192.168.2.1

         SE 0/0 ---->10.0.1.1

         SE 0/1 ----> 10.0.1.4

3745:  FE 0/0 ----> No IP (Not yet configured)

          FE 0/1 ----> 192.168.1.1

          SE 0/0 ----> 10.0.1.3

2600: E 0/0   ---->192.168.3.1

         SE 0/0 ----> 10.0.1.2

Hall of Fame Super Silver

Routing with 3640 and 3745 via WIC-2T

Jonathan

Your first post talked about two routers. Now you are talking about three routers. So let's straighten that out first. If there are three routers and two serial lines it is quite possible to connect them which will effectively create a hub router with two spoke routers.

There are several options of how to use serial connections and it looks like you have chosen the most simple of the options, each serial link to use HDLC encapsulation and to create a point to point connection. To make that work you would need a separate IP subnet on each of the serial links. What you show in the post above is all the serial IP addresses grouped together (1, 2, 3, 4) and that does not work. What you need is one subnet for the first serial (perhaps 10.0.1.0/30) and another subnet for the other serial (perhaps 10.0.1.4/30). That could be very easy to do and would work well.

There are several choices for dynamic routing protocol, and in fact for a very small network such as this it is feasible to do all of the routing with static routes. If you were interested in trying static routes then each router would need static routes for the LAN network of the other two routers and a static route for any serial link that was not connected. (so 3 static routes on the 3745 and the 2600 and 2 static routes on the 3640).

The reasons for wanting dynamic routing protocols usually include 1) want to scale to larger size and 2) if there is a failure somewhere in the network want to dynamically find an alternate route 3) want to choose the best path to destinations when there are alternate paths to consider. But none of these factors come into play with the network that you describe here.

But assuming that you want to use dynamic routing I would suggest that EIGRP is almost as easy to configure as RIP and presents several advantages over RIP.  (EIGRP uses less bandwidth than RIP and converges more quickly are the two advantages that I would start with)

If you want to use EIGRP then the configs might look something like this

3640

router eigrp 1

network 192.168.2.0

network 10.0.0.0

3745

router eigrp 1

network 192.168.1.0

network 10.0.0.0

2600

router eigrp 1

network 192.168.3.0

network 10.0.0.0

HTH

Rick

New Member

Routing with 3640 and 3745 via WIC-2T

So on the serial interface my IP address should be something like:

2600 - SE0/0------->10.0.4.1

3640 - SE0/0------> 10.0.3.1

          SE0/1------> 10.0.2.1

3745- SE0/0-------> 10.0.1.1

Then apply the EIGRP config above and I should be squared away?

If so, I will do that tonight when I return home, and report back....

Thanks for your help....

Hall of Fame Super Silver

Routing with 3640 and 3745 via WIC-2T

Jonathan

What you suggest here is quite different from what I was describing. What you suggest here could work, if you use /23 subnet masking. It would be quite ineffecient in terms of use of IP addresses but it could work.

I would suggest that you draw out the topology of the network with the two serial links connecting the three routers. And then think about what subnets you would use on the serial lnks to make the connections. Perhaps to make it easier I might suggest to use /24 subnets on the serial interfaces. So you might have subnet 10.0.1.0/24 on one serial and have 10.0.2.0/24 on the other serial.

HTH

Rick

New Member

Routing with 3640 and 3745 via WIC-2T

So would this work better for the serial IP assignments?

10.0.1.4/30

10.0.1.6/30

10.0.1.8/30

New Member

Routing with 3640 and 3745 via WIC-2T

I have tried everything I can think of to get this to work, and still no luck....I can ping serial interfaces from the router CLI, but not from the CMD promt on my PC.  I can't ping any 192.168.0.0 network....  Please help

Here are my runing configs....

3640:

Current configuration : 1828 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.0 255.255.192.0

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

ip address 10.0.1.1 255.255.192.0

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

3745:

Current configuration : 1475 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.4 255.255.192.0

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

auto-summary

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip nat inside source list 15 interface FastEthernet0/0 overload

!

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

Bronze

Routing with 3640 and 3745 via WIC-2T

You may need to brush up on subnetting. When you use a /30 bit mask your subnets go up in 4.

Example: 10.0.1.4/30 first subnet

               10.0.1.8/30 second subnet

               10.0.1.12/30 third subnet......and on and on.

Eugen

New Member

Routing with 3640 and 3745 via WIC-2T

My bad....I tried doing 10.0.1.4/30 and 10.0.1.4 255.255.255.252 but the router says it is a bad /30 subnet mask...I figured that would be because of the class A address...  That is why I went with a 10.0.1.X 255.248.0.0 for the serial WICs.  I still can't ping any of the 192.168.XXX.XXX addresses, it just times out on me. 

From my PC (192.168.2.122) I tired to ping 10.0.1.0 and it timed out....

From the 3745 (10.0.1.4) I tried to ping 192.168.2.1 (3640 Router) and it was unsuccessful.

I did a debug on the router and ther serial interfaces are "talking" but I can't access/ping any of the 192.168.XXX.XXX networks...

Would static routes need to be placed in order to access the 192.168.XXX.XXX networks, is so could you please help me out with that?

Any advice?  Below are my running configs:

3640:

Current configuration : 1828 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.0 255.255.192.0

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

ip address 10.0.1.1 255.255.192.0

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

3745:

Current configuration : 1475 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.4 255.255.192.0

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

auto-summary

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip nat inside source list 15 interface FastEthernet0/0 overload

!

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

Bronze

Routing with 3640 and 3745 via WIC-2T

Maybe this will help you

New Member

Routing with 3640 and 3745 via WIC-2T

Alright, made the changes as shown in the picture above (3725 from above is my 2610)...I can ping each router from each other, but I can't ping from the PC (192.168.2.122) to the 3745 or the 2610.

Any idea?

Hall of Fame Super Silver

Re: Routing with 3640 and 3745 via WIC-2T

Jonathan

If the PC can not ping the other routers my first suggestion would be to check the default gateway of the PC.

Also I notice in the configs that you posted that under router EIGRP you consistently are using network 192.160.0.0. But you should be using 192.168.1.0 or 192.168.2.0 to match the network on that router.

HTH

Rick

Sent from Cisco Technical Support iPhone App

Bronze

Routing with 3640 and 3745 via WIC-2T

On each router you need to change the statement for networks you are advertising in eigrp

On 3640

router eigrp 1

no auto-summary

network 10.0.1.4

network 10.0.1.8

network 192.168.2.0

On 3745

router eigrp 1

no auto-summary

network 10.0.1.4

network 192.168.1.0

On 2610

router eigrp 1

no auto-summary

network 10.0.1.8

network 192.168.3.0  - I don't see 2610 config posted, change this network to what is configured.

This should work. On PCs change default gateway to point to router interfaces and give them an address in same subnet

Example PC connected to 3640

ip address 192.168.2.10

Subnet mask 255.255.255.0

Default gateway 192.168.2.1

Eugen

New Member

Routing with 3640 and 3745 via WIC-2T

Thank you so much for the help, it finally works.....

Bronze

Routing with 3640 and 3745 via WIC-2T

Thats good...

Glad to help

Eugen

620
Views
0
Helpful
15
Replies
CreatePlease to create content