Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing with 4507R

I currently have an AT&T Opt-e-man connection which is connected to my main router. There are 3 vlans which go over it to 3 separate remote sites. We are upgrading the speed of the connection and moving it to fiber. So, since my router doesn't support fiber (only a 3745), I'm going to bring it into my 4507R with a Sup II+ modules. My questions is how to transfer the sub-interface configuration that is on the router, over to the switch? Routing is already enabled since we have other VLANs.

Would something like this work on the 4507R? Port G1/1 will be connected to the providers access switch via 1000base-SX fiber.

interface Vlan30

description Location1

ip address 10.1.0.1 255.255.255.252

interface Vlan31

description Location2

ip address 10.2.0.1 255.255.255.252

interface Vlan32

description Location3

ip address 10.3.0.1 255.255.255.252

interface g1/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 30,31,32

switchport mode trunk

7 REPLIES
Hall of Fame Super Silver

Re: Routing with 4507R

Joe

What you have got here looks good to me.

HTH

Rick

New Member

Re: Routing with 4507R

Thanks, I'll give that a shot.

New Member

Re: Routing with 4507R

I have just one question. Are these vlans created just for the interfaces because the Mask is 255.255.255.252 and this mask will only allow 2 hosts on each vlan

Re: Routing with 4507R

My guess is that he is using the /30's for his WAN transits as they are all trunked.

There must be other VLAN's for LAN's that have not been included.

New Member

Re: Routing with 4507R

only the gi1/1 is a trunk port and the vlans are allowed over these trunk ports

Hall of Fame Super Gold

Re: Routing with 4507R

I don't know if this is relevant but the 3700 supports the NM-1GE (using GBIC). It requires 12.2(11)YT IOS.

New Member

Re: Routing with 4507R

These VLANs are for our WAN segments only, hence the /30 mask. Also, these VLANs are what AT&T uses to separate traffic going out the opt-e-man connection to the different remote sites. The remote sites have their own subnets. Currently our router has a trunk port coming from AT&T's switch with sub-interfaces for each VLAN. I just need to translate that into what would be needed on the switch since it doesn't support sub-interfaces.

I looked into the gigabit interface for the router itself. But we didn't go that route due to several reasons: 1) it would cost several thousand dollars to add a fiber interface to the router. It only costs a few hundred for a GBIC for the switch. 2) My vendor didn't really recommend pushing that much traffic through the router. Granted on a normal day we don't tax the links at all, but backups can really take their toll. 3) We are running out of room on the router for another module.

Thanks everyone.

268
Views
3
Helpful
7
Replies