Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RP candidate and BSR candidate at the same router. Rp mapping fail

I have MVPN service in MPLS network.

I recently connected new  source of multicast  into my CORE router which I also do an RP-candidate for groups of this source.

In my network I also have two other RPs with others groups on others routers .

The CORE router also is BSR candidate and it successfully mapped this two RPs, but it mapping for own RP does not work.

If i move BSR candidate on another router, which is not RP then all three RPs are mapped successfully.

IS it possible to have RP and BSR candidate in the same router?

IMHO in a global RP configuration all work fine. This issue observed only in vrf configuration.

ip pim vrf IPTV rp-candidate Port-channel1.329 group-list 99 interval 15

ip pim vrf IPTV bsr-candidate Port-channel1.328 0

Interface Po1.328 — receivers of multicast from RP[1-3] on the  CORE router

Interface Po1.329 — source of multicast for RP on core router.

2 REPLIES
New Member

RP candidate and BSR candidate at the same router. Rp mapping fa

candidate bsr and RP will work in the same box,

New Member

RP candidate and BSR candidate at the same router. Rp mapping fa

But in fact they does not work.

Some more config on CORE router

ip multicast-routing

ip multicast-routing vrf IPTV

mls ip multicast replication-mode ingress

mls rate-limit multicast ipv4 fib-miss 1000 100

ip pim rp-candidate Loopback0 interval 15

no ip pim v1-rp-reachability

ip pim vrf IPTV rp-candidate Port-channel1.329 group-list 99 interval 15

ip pim bsr-candidate Loopback0 0 3

ip pim vrf IPTV bsr-candidate Port-channel1.328 0

interface Port-channel1.328

description ---# VLAN to METRO:iptv [S0]

encapsulation dot1Q 328

ip vrf forwarding IPTV

ip address 10.61.240.9 255.255.255.248

ip pim neighbor-filter 97

ip pim dr-priority 2

ip pim query-interval 15

ip pim sparse-mode

ip igmp last-member-query-interval 100

interface Port-channel1.329

description ---# VLAN to IPTV:uplink [S2]

encapsulation dot1Q 329

ip vrf forwarding IPTV

ip address 192.168.253.54 255.255.255.252

ip access-group iptv:uplink in

ip access-group 100 out

no ip proxy-arp

ip pim neighbor-filter 97

ip pim query-interval 120

ip pim bsr-border

ip pim dense-mode

ip igmp unidirectional-link

access-list 97 deny   10.61.240.0 0.0.3.255

access-list 97 deny   192.168.253.52 0.0.0.3

access-list 99 permit 239.32.4.0 0.0.0.255

access-list 99 deny   any

access-list 100 deny   ip any 224.0.0.0 15.255.255.255

ip access-list extended iptv:uplink

permit ip host xx.xx.xx.248 239.32.4.0 0.0.0.255 // where xx.xx.xx.248 is a public address of source

deny   ip any 224.0.0.0 15.255.255.255

permit ip any any

ip route vrf IPTV xx.xx.xx.248 255.255.255.255 192.168.253.53

router ospf as-num

mpls traffic-eng multicast-intact

IF the BSR is a remote router all looks magnificently

#sh ip pim vrf IPTV bsr-router

PIMv2 Bootstrap information

  BSR address: 10.61.240.33 (?)

  Uptime:      09:11:28, BSR Priority: 1, Hash mask length: 0

  Expires:     00:01:43

This system is a candidate BSR

  Candidate BSR address: 10.61.240.9, priority: 0, hash mask length: 0

  Candidate RP: 192.168.253.54(Port-channel1.329),

#sh ip pim vrf IPTV rp mapping

PIM Group-to-RP Mappings

This system is a candidate RP (v2)

Group(s) 239.1.0.0/24

  RP 10.61.243.14 (?), v2

    Info source: 10.61.240.33 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 12:25:21, expires: 00:01:48

Group(s) 239.1.1.0/24

  RP 10.61.241.1 (?), v2

    Info source: 10.61.240.33 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 12:25:28, expires: 00:01:51

Group(s) 239.1.2.0/24

  RP 10.61.241.1 (?), v2

    Info source: 10.61.240.33 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 12:25:28, expires: 00:01:48

Group(s) 239.32.4.0/24

  RP  192.168.253.54 (?), v2

    Info source: 10.61.240.33 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 12:25:28, expires: 00:01:48

IF i do this system as BSR then RP mapping for 192.168.253.54 disappear

sh ip pim vrf IPTV bsr-router

PIMv2 Bootstrap information

This system is the Bootstrap Router (BSR)

  BSR address: 10.61.240.9 (?)

  Uptime:      00:00:03, BSR Priority: 2, Hash mask length: 0

  Next bootstrap message in 00:00:56

  Candidate RP: 192.168.253.54(Port-channel1.329),

#sh ip pim vrf IPTV rp mapping

PIM Group-to-RP Mappings

This system is a candidate RP (v2)

This system is the Bootstrap Router (v2)

Group(s) 239.1.0.0/24

  RP 10.61.243.14 (?), v2

    Info source: 10.61.243.14 (?), via bootstrap, priority 0, holdtime 37

         Uptime: 12:35:55, expires: 00:00:23

Group(s) 239.1.1.0/24

  RP 10.61.241.1 (?), v2

    Info source: 10.61.241.1 (?), via bootstrap, priority 0, holdtime 37

         Uptime: 12:36:02, expires: 00:00:22

Group(s) 239.1.2.0/24

  RP 10.61.241.1 (?), v2

    Info source: 10.61.241.1 (?), via bootstrap, priority 0, holdtime 37

         Uptime: 12:36:02, expires: 00:00:22

391
Views
0
Helpful
2
Replies
CreatePlease login to create content