Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

RSTP convergence problem

Hi all,

I'm currently having issues regarding RSTP on a simple switch network, scenario is as follows. I have 2 switches directly connected to each other over a trunk link (dot1q). These 2 interfaces have the following identical config.

interface GigabitEthernet0/15

switchport trunk allowed vlan 1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100.

For some reason the 2 switch aren't exchanging STP BPDUs, this has been confirmed in a debug spanning-tree bpdu receive. Configuration on both switches is default apart from spanning-tree mode rstp. Also note that VLAN 1 is the native VLAN for that trunk, I thought that a STP instance would run for VLAN 1.

Show spanning-tree shows that each switch thinks it is the root for VLAN 1 which makes sense considering they are not talking to each other. Any ideas why this is happening?

9 REPLIES

Re: RSTP convergence problem

Hi Matthew,

I just can guess.

There are some high-end multilayer switches like 6500 for which the ports are layer3 ports by default.

In this case you have to apply the "switchport" command without options on the interface to put it into layer2 mode.

My other idea is: may it be that the port is in the down state? Then use "no shutdown".

At the moment I have no more ideas.

Please write me if this solved your problem.

Cheers:

Istvan

New Member

Re: RSTP convergence problem

Hi Istvan,

Thanks for your reply. First of all the switch is only a layer 2 device. I can also confirm that the interface status is up. CDP can see the neighboring switch across the interface in question.

Regards,

Re: RSTP convergence problem

Hi Matthew,

Can you post the full running-configs of both switches here?

Please copy and paste, and do not use attachments.

Many thanks:

Istvan

New Member

Re: RSTP convergence problem

Here is the running config for each switch. Please note that Gi 1/16(mgmt2) is unplugged on each switch. Hence there is only a single active connection between the 2 switches. Output has been truncated due to exceeding the forum character limit.

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname SW1

!

enable secret 5 --blank--

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

vtp mode transparent

!

!

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 110

name blade-center

!

interface Port-channel1

description EtherChannel

switchport access vlan 110

switchport mode access

!

interface GigabitEthernet0/15

description mgmt1

switchport trunk allowed vlan 1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/16

description mgmt2

switchport trunk allowed vlan 1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/17

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/18

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/19

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/20

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface Vlan1

ip address 172.16.113.5 255.255.255.0

no ip route-cache

management

!

ip default-gateway 172.16.113.100

ip http server

ip http authentication local

snmp-server community **

snmp-server community **

snmp-server community **

snmp-server community **

!

line con 0

line vty 0 4

password 7

login

line vty 5 15

login

!

ntp clock-period 17180224

!

end

---------------------------------------------------

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname SW2

!

enable secret 5 --blank--

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

vtp mode transparent

!

!

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 110

name blade-center

!

interface Port-channel1

switchport access vlan 110

switchport mode access

!

!

interface GigabitEthernet0/15

description mgmt1

switchport trunk allowed vlan 1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/16

description mgmt2

switchport trunk allowed vlan 1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/17

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/18

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/19

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface GigabitEthernet0/20

switchport access vlan 110

switchport mode access

channel-group 1 mode on

!

interface Vlan1

ip address 172.16.113.6 255.255.255.0

no ip route-cache

management

!

ip default-gateway 172.16.113.100

ip http server

ip http authentication local

snmp-server community **

snmp-server community **

snmp-server community **

snmp-server community **

!

line con 0

line vty 0 4

password 7

login

line vty 5 15

login

!

ntp clock-period 17180182

!

end

Re: RSTP convergence problem

on the GigabitEthernet0/15 interfaces that the switches are connected, let spanning-tree work out the path cost so i suggest you remove "spanning-tree cost 100" because your interfaces are gig not 10mb so i dont under why your cost is 100. the cost gor a gig is 4.

also enter the command "sh spanning-tree vlan 1" on both switches so i can see the switches config for vlan 1 instance.

Franco

Re: RSTP convergence problem

if you have only a single trunk link between your switches, you dont need to worry about STP. STP is only useful if you are redunant links between your switches.

Re: RSTP convergence problem

Hi Matthew,

I don't see problems with your running-configs.

However, you are mentioning, that Gig0/16 (mgmt2) has been unplugged.

Could you please verify now, if the CDP neighbor relationship is still alive through the Gig0/15 ports?

I have a supposition that you may use a straight-through cable between the Gig0/15 ports, not crossover cable.

Or there may be some other cable or connector problem.

Thanks:

Istvan

Re: RSTP convergence problem

Hi,

1st point:make sure there is a connectivity between the 2 switches before going further.

2nd point: what is this? spanning-tree cost 100 ? for which vlan you are changing the cost in G0/15?

The 3rd point, there is no need to configure cost here, since this is the only interface connected to the root-bridge, it will always be elected as a root port.

HTH

Mohamed

New Member

Re: RSTP convergence problem

Hi All,

Thanks for everyone's replies.

Sorry about the delay in replying to your postings. I can confirm that CDP is operating over Gi 0/15 and I can see the neighboring switch. There is no actual problem with this setup but I did want to know why no BPDU were received across this link.

Cheers,

Matt

317
Views
0
Helpful
9
Replies
CreatePlease to create content