Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

RV042 - protocol binding does not work


I am trying to direct nearly all traffic to WAN1, which is my high-throughput Broadstripe cable connection. I would like the traffic from certain online games to use only WAN2, which is my low-latency Speakeasy DSL.

After a few days of messing around with this I am convinced the RV042's protocol binding does not work. I do not wish to use SmartLink mode because that directs all traffic to just one WAN with the other as a backup, and that's not what I need here. I need to make use of both, just one of them is heavily used while the other is only rarely used for select ports.

So far my results have been that no matter which ports I bind to which WAN, I will experience latency in my game (which should be WAN2) if I perform downloads (which should traveling over WAN1). Furthermore, I just had an experience which solidifies my thinking that the protocol binding is not functional. I have set the RV042 to send all traffic from port 80 and 8080 through WAN1 (Broadstripe). Just now I began experiencing "Resolving host" problems when trying to access webpages. In the past I've had this issue with my Speakeasy DSL where the modem claims to be online but there's no service - and it will always just say "Resolving host" in my browser at these times. In light of this I turned off the Load Balancing of the RV042 and enabled SmartLink, telling it to use WAN1 for all traffic. At this point my Internet worked, webpages loaded, downloads worked, etc. So then I turned the SmartLink setting to use WAN2 (the Speakeasy DSL I suspected was failing at the moment). At this point no Internet worked. I then turned it back to Load Balancing, and once again I could not load any webpages. I restarted the Speakeasy modem and after about 10 minutes I could browse webpages again. This clearly implies that my browser's traffic, which the RV042 should be sending through WAN1 per the protocol bindings I've established, was trying to use WAN2.

The issue here isn't that my Speakeasy DSL went down, it's that the browser traffic was not able to access the Internet while the Speakeasy was down even though the RV042 should be directing all browser traffic to the Broadstripe WAN to begin with.

Can anyone help me with this? Do I need a different router to accomplish what I want to do? I really had hoped I could just send nearly ALL traffic through Broadstripe and select game ports to Speakeasy using this Cisco RV042 router, but instead it's just been a hassle trying to configure something that in the end appears not to be doing what it should anyway.

Thank you in advance for any help!

Everyone's tags (3)
Community Member

Re: RV042 - protocol binding does not work

I'll amend this by saying it must work in at least some capacity. The reason I say this is when I change the RV042's protocol binding for port 80 (HTTP) to WAN2, I can visit and it will come back as my Speakeasy DSL IP. The protocol binding must be working if it does this. I'm not understanding why it won't route my torroents, HTTP, NNTP, and other traffic ONLY through WAN1 (Broadstripe cable) though when I set it up to do so. It's as if it ignores the rules when it wants to do its own load balancing.

Community Member

Re: RV042 - protocol binding does not work

It does work after all, just not as I expect. I will create a new topic to refine my question.

CreatePlease to create content