Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Same PPPOE session ID for different sessions

Hi All,

We have a setup with a central router and a remote router. We want to establish 2 PPOE session to the same remote site.

We have created 2 dialer interfaces and each interface dialer is attached to 2 different Lan interfaces.

We can not establish the 2 sessions simultaniously, because we see with the "sh ppoe session" the same session ID for each session.

Uniq ID PPPoE RemMAC         Port              VT VA         State

            SID      LocMAC                               VA-st          Type

N/A     1           mac x            G0/0               Di1 Vi2         UP    

                        mac y                                                     UP            

N/A     1            mac x           Gi0/1              Di2 Vi3          UP    

                         max z                                                    DOWN      

Can anyone help me with this issue?

Thank you,

José

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Same PPPOE session ID for different sessions

Hello Jose,

I am somewhat concerned about seeing the pppoe enable group global in your configuration. They make your router behave like a PPPoE concentrator itself. I suggest removing them, just to be sure they do not interfere with the proper operation of your PPPoE client configuration.

I advise caution here: as soon as you enter the no pppoe enable command on your Gi0/0 and Gi0/1, the pppoe-client configuration will be removed as well, surprisingly enough. Therefore, after you remove the pppoe enable group global commands, you will need to put the pppoe-client dial-pool-number X command back. Be aware that this will lead to a loss of connectivity until the PPPoE client reestablishes its session with the remote site.

Best regards,

Peter

4 REPLIES
New Member

Same PPPOE session ID for different sessions

can you post the both config (Server and client pppoe)

New Member

Same PPPOE session ID for different sessions

Hello adnane,

I don't have the config f the server but see below the config of the pppoe client.

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname test

!

boot-start-marker

boot system flash c1900-universalk9-mz.SPA.151-4.M4.bin

boot-end-marker

!

!

logging buffered 50000

enable secret 5

!

no aaa new-model

clock timezone gmt 1 0

clock summer-time gmt recurring

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip vrf Internet

rd 65001:1000

route-target export 65001:1000

route-target import 65001:1000

!

ip dhcp excluded-address 192.168.3.1

ip dhcp excluded-address 192.168.3.254

ip dhcp excluded-address 192.168.3.11 192.168.3.16

ip dhcp excluded-address 192.168.1.3

ip dhcp excluded-address 192.168.1.14

ip dhcp excluded-address 192.168.1.13

!

ip dhcp pool Shell

import all

network 192.168.3.0 255.255.255.0

lease 5

!

ip dhcp pool Internet

import all

vrf Internet

network 192.168.1.0 255.255.255.240

domain-name test.be

dns-server 195.130.130.11 195.130.131.11

default-router 192.168.1.14

lease 5

!

!

no ip domain lookup

multilink bundle-name authenticated

!

isdn switch-type basic-net3

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1921/K9 sn FCZ1610900U

license boot module c1900 technology-package securityk9

license boot module c1900 technology-package datak9

!

!

username codenet password 7

!

redundancy

!

!

ip tftp source-interface Loopback2

!

policy-map SHAPE_VDSL_VPN

class class-default

  shape average 1000000

policy-map SHAPE_VDSL_Internet

class class-default

  shape average 512000

!

!

!

interface Loopback1

ip vrf forwarding Internet

ip address 10.10.19.66 255.255.255.240

ip nat inside

ip virtual-reassembly in

!

interface Loopback2

ip address 84.199.222.158 255.255.255.255

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 2

!

interface BRI0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer idle-timeout 300

dialer string 1661032932940

dialer load-threshold 10 outbound

dialer-group 10

isdn switch-type basic-net3

isdn point-to-point-setup

ppp pap sent-username

BU_CEBRUSHS01@VPRN_2035

password 7 00081F550C6818555F265C1F0A492B

!

interface FastEthernet0/1/0

switchport access vlan 10

no ip address

no cdp enable

!

interface FastEthernet0/1/1

switchport access vlan 20

no ip address

no cdp enable

!

interface FastEthernet0/1/2

no ip address

!

interface FastEthernet0/1/3

no ip address

!

interface Vlan1

no ip address

history BPS all

!

interface Vlan10

description ### VLAN IVPN ###

ip address 192.168.3.254 255.255.255.0

ip access-group 100 out

ip nat inside

ip virtual-reassembly in

!

interface Vlan20

description ### VLAN Internet ###

ip vrf forwarding Internet

ip address 192.168.1.14 255.255.255.240

ip access-group 101 out

ip nat inside

ip virtual-reassembly in

!

interface Dialer1

bandwidth 100000

ip address negotiated

ip mtu 1492

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1452

load-interval 30

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp ipcp route default

no cdp enable

service-policy output SHAPE_VDSL_VPN

!

interface Dialer2

bandwidth 100000

ip vrf forwarding Internet

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 2

dialer-group 2

ppp authentication chap callin

ppp ipcp route default

no cdp enable

service-policy output SHAPE_VDSL_Internet

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 50 interface Loopback1 vrf Internet overload

ip nat inside source static 192.168.1.3 10.10.19.65 vrf Internet

ip nat inside source static 192.168.1.13 10.10.19.67 vrf Internet

ip nat inside source static 192.168.3.11 10.74.9.193

ip nat inside source static 192.168.3.12 10.74.9.194

ip nat inside source static 192.168.3.13 10.74.9.195

ip nat inside source static 192.168.3.14 10.74.9.196

ip nat inside source static 192.168.3.15 10.74.9.197

ip nat inside source static 192.168.3.16 10.74.9.198

ip nat inside source static 192.168.3.1 10.74.9.202

ip route 0.0.0.0 0.0.0.0 BRI0/0/0 254

ip route 10.74.9.192 255.255.255.240 Vlan10

!

!

logging source-interface Loopback99

logging 195.130.131.217

logging 195.130.148.25

access-list 1 permit 195.130.131.216 0.0.0.7

access-list 1 deny   any log

access-list 40 permit 10.74.128.0 0.0.7.255

access-list 40 permit 195.130.131.216 0.0.0.7

access-list 40 permit 192.168.248.0 0.0.7.255

access-list 40 permit 192.168.243.0 0.0.0.255

access-list 40 deny   any

access-list 50 permit 192.168.1.0 0.0.0.15

access-list 100 permit tcp any host 192.168.3.1 established

access-list 100 permit tcp any host 192.168.3.1 eq 65000

access-list 100 permit udp any host 192.168.3.1 eq 65000

access-list 100 permit tcp any host 192.168.3.1 eq 3389

access-list 100 permit udp any host 192.168.3.1 eq 3389

access-list 100 permit tcp any 192.168.3.0 0.0.0.255 eq 2150

access-list 100 permit udp any 192.168.3.0 0.0.0.255 eq 2150

access-list 100 permit tcp any 192.168.3.0 0.0.0.255 eq 28784

access-list 100 permit udp any 192.168.3.0 0.0.0.255 eq 28784

access-list 100 permit tcp any 192.168.3.0 0.0.0.255 eq 2200

access-list 100 permit udp any 192.168.3.0 0.0.0.255 eq 2200

access-list 101 permit tcp any host 192.168.1.3 eq 90

access-list 101 permit udp any host 192.168.1.3 eq 90

access-list 101 deny   tcp any host 192.168.1.3

access-list 101 deny   udp any host 192.168.1.3

access-list 101 permit tcp any host 192.168.1.13 established

access-list 101 permit tcp any host 192.168.1.13 eq www

access-list 101 permit udp any host 192.168.1.13 eq 80

access-list 101 permit tcp any host 192.168.1.13 eq 443

access-list 101 permit udp any host 192.168.1.13 eq 443

access-list 101 permit tcp any host 192.168.1.13 eq 5900

access-list 101 permit udp any host 192.168.1.13 eq 5900

access-list 101 permit tcp any host 192.168.1.13 eq 3668

access-list 101 permit udp any host 192.168.1.13 eq 3668

access-list 101 permit tcp any host 192.168.1.13 eq 5869

access-list 101 permit udp any host 192.168.1.13 eq 5869

access-list 101 deny   udp any host 192.168.1.13

access-list 101 deny   tcp any host 192.168.1.13

access-list 101 permit ip any 192.168.1.0 0.0.0.15

dialer-list 10 protocol ip permit

!

no cdp run

!

!

New Member

Same PPPOE session ID for different sessions

the config seems to be normal , post result of "debug pppoe events "

Cisco Employee

Same PPPOE session ID for different sessions

Hello Jose,

I am somewhat concerned about seeing the pppoe enable group global in your configuration. They make your router behave like a PPPoE concentrator itself. I suggest removing them, just to be sure they do not interfere with the proper operation of your PPPoE client configuration.

I advise caution here: as soon as you enter the no pppoe enable command on your Gi0/0 and Gi0/1, the pppoe-client configuration will be removed as well, surprisingly enough. Therefore, after you remove the pppoe enable group global commands, you will need to put the pppoe-client dial-pool-number X command back. Be aware that this will lead to a loss of connectivity until the PPPoE client reestablishes its session with the remote site.

Best regards,

Peter

942
Views
0
Helpful
4
Replies