Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Same Static route to different destination

Hello Friends,

Can i configur a static route for prefix x.x.x.x/y to different destinations a.a.a.a & b.b.b.b ?

Router 1  -------- Router 2 directly connected.

I want to do this thing because i have port-chanel between R1 - R1 with two interfaces, one of them is carrying 990 Mb but 2nd one is only carrying 60 Mb.

Config is identical on bundle members.

Please advice.

Regards,

Ahmed

6 REPLIES

Same Static route to different destination

That is possible, the traffic will load balance across the routers, I believe per packet is the default but I could be wrong.

Cisco Employee

Re: Same Static route to different destination

Hi,

I believe per packet is the default but I could be wrong.

If CEF or Fast Switching (route-cache) is in use, per-destination load balancing is the default. Per-packet load balancing can be accomplished only by reverting to process switching (deactivating both CEF and the route-cache), or by using CEF and configuring the ip load-sharing per-packet command on egress interfaces.

Best regards,

Peter

Re: Same Static route to different destination

Thanks for reminding me Peter.

Ahmed this link should be helpful,

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094820.shtml

New Member

Same Static route to different destination

Thanks Guys.

You may find below config:

at R1 ( 7606 )

interface Port-channel10

description To-ASR

ip address 192.168.70.17 255.255.255.252

ip tcp adjust-mss 1400

speed nonegotiate

end

interface GigabitEthernet1/20

description To-ASR-MEMBER-1

no ip address

speed nonegotiate

no cdp enable

channel-group 10 mode on

end

!

interface GigabitEthernet1/21

description To-ASR-MEMBER-2

no ip address

speed nonegotiate

channel-group 10 mode on

end

At R2 ( ASR1002 )

interface Port-channel10

description Bundle

ip address 192.168.70.18 255.255.255.252

negotiation auto

end

interface GigabitEthernet0/0/0

description To-7606-MEMBER-1

no ip address

no negotiation auto

channel-group 10

end

interface GigabitEthernet0/0/1

description To-7606-MEMBER-2

no ip address

no negotiation auto

channel-group 10

end

Please advice.

I dont know what i am missing.

Same Static route to different destination

Not sure what your issue is. I thought you were looking to load balance across two routers for a particular destination? Is the issue you are having with the port channel configuration?

Super Bronze

Re: Same Static route to different destination

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

A port-channel is seen by the device as one logical link.  I.e. route entries do not influence port-channel load balancing.

What you might want to do, is examine your port-channel hashing algorithms.  Another might better balance your traffic.

You could split your port-channel into logical links, then routing load balancing would come into play.

PS:

BTW, any per flow load balancing might result in unequal link utilization because of the nature of your traffic.

209
Views
0
Helpful
6
Replies
CreatePlease to create content