Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Scenario Regarding Policy based Routing and Floating Routes

I have a 1841 router with a serial port and 2 ethernet ports.

Where as I have to ISP providers what I want to do is I want to set my router in such a way that when ever any one ISP went down the other takes up.

What configurations do I need and is there any link which explanins me teh configurations according to my Scenario

3 REPLIES
Green

Re: Scenario Regarding Policy based Routing and Floating Routes

This is what you're looking for.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

Let us know if you need help setting this up. I am currently running it on an 1841 myself and it works very well.

Please rate helpful posts.

New Member

Re: Scenario Regarding Policy based Routing and Floating Routes

Can u send me your running configurations.

Green

Re: Scenario Regarding Policy based Routing and Floating Routes

This should get you started. Timeouts, thresholds etc. are all configurable. Change values to suit your needs.

ip sla monitor 25

type echo protocol ipIcmpEcho 20.x.x.45 <====upstream neighbor ip

timeout 10000

threshold 7

frequency 10

ip sla monitor schedule 25 life forever start-time now

track 123 rtr 25 reachability

delay down 60 <=== this delays the track from going down until down for 60 seconds

interface FastEthernet0/0 <===primary connection

description outside

ip address 172.25.0.2 255.255.255.252

interface FastEthernet0/1

description inside

ip address 172.25.0.5 255.255.255.252

interface Serial0/0/0 <====backup connection

description outside

ip address 172.26.0.13 255.255.255.252

ip access-group 120 in

ip local policy route-map FAILOVER-POLICY

ip route 0.0.0.0 0.0.0.0 172.25.0.1 track 123

ip route 0.0.0.0 0.0.0.0 172.26.0.14 119 <====119 because I'm running rip, could be anything less than 120

ip route 20.x.x.45 255.255.255.255 172.25.0.1

access-list 101 permit icmp any host 20.x.x.45 echo

access-list 120 deny icmp host 20.x.x.45 any <===makes sure ping replies don't come from secondary link

access-list 120 permit ip any any

route-map FAILOVER-POLICY permit 10

match ip address 101

set interface Null0 Serial0/0/0

set ip next-hop 172.25.0.1

So, to explain all that in plain english. An ip sla process starts and pings 20.x.x.45 every 10 seconds. As long as that ping is successful, the default route is to 172.25.0.1. If it fails, for me I have it set for 60 second delay, then the default route is 172.26.0.14. The process continues to ping until successful. At that time it reinstates the original tracked route.

Please rate helpful posts.

220
Views
5
Helpful
3
Replies