cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
882
Views
0
Helpful
2
Replies

Seems like QoS is not quite working

d.hodgson
Level 1
Level 1

Hi experts,

can you please help me?

Lets call our data centre site A and our remote site site B, we have many remote sites connecting to the data centre but I'll leave them out for the purpose of simplicity. The link at the Data Centre is 14Mbps with CIR of 4Mbps, the remote site is 6Mbps with CIR of 2Mbps.

Voice calls are breaking up between site A and B if someone from either site starts a large file transfer (WAN utilization is normally at around 20% but shoots upto 80% to 90% during file transfer, also pings from Site A to Site B change from a stable 8ms to 15ms to a very eratic 20ms to 130ms, at the time the reply is above 100ms the voice call starts breaking up). Both sites are connected to each other via Frame-Relay over a MPLS cloud. I think I have implemented QoS correctly and the frame relay config but I may be mistaken, can someone please run your eye over the remote site WAN router config and see if something isn't quite right?

class-map match-any five
  description VOIP
  match access-group name aglevel5
  match ip precedence 5
  match ip precedence 3
  match ip dscp ef
  match ip dscp af31

class-map match-any four
  description Video Conferencing
  match access-group name aglevel4
  match ip precedence 4
  match ip dscp cs4

class-map match-any two
  description high priority apps
  match access-group name aglevel2

class-map match-any one
  description medium priority apps
  match access-group name aglevel1

policy-map cos
description cos policy map
  class five
   set ip precedence 5
    priority 512

  class four
   set ip precedence 4
    priority 512
  class two
   set ip precedence 2
   bandwidth percent 10
  class one
   set ip precedence 1
   bandwidth percent 10
  class class-default
   fair-queue

interface Hssi2/0
description Frame-Relay
bandwidth 6144
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation frame-relay
ip route-cache flow
no ip mroute-cache
serial restart-delay 0
frame-relay traffic-shaping
frame-relay lmi-type ansi

interface Hssi2/0.100 point-to-point
description IPWan/FR (10.255.10.9)
bandwidth 6144
ip address 10.255.10.9 255.255.255.252
frame-relay interface-dlci 100 IETF  
  class shaped-voice

map-class frame-relay shaped-voice
no frame-relay adaptive-shaping
frame-relay cir 6144000
frame-relay bc 2048000
frame-relay be 4096000
frame-relay mincir 2048000
service-policy output cos

3640#sh policy-map interface h2/0.100
Hssi2/0.100: DLCI 100 -

  Service-policy output: cos

    Class-map: five (match-any)
      75878 packets, 6236310 bytes
      5 minute offered rate 38000 bps, drop rate 0 bps
      Match: access-group name aglevel5
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip precedence 5
        71180 packets, 5982576 bytes
        5 minute rate 37000 bps
      Match: ip precedence 3
        4698 packets, 253734 bytes
        5 minute rate 0 bps
      Match: ip dscp ef
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip dscp af31
        0 packets, 0 bytes
        5 minute rate 0 bps
      QoS Set
        precedence 5
          Packets marked 75878
      Queueing
        Strict Priority
        Output Queue: Conversation 136
        Bandwidth 512 (kbps) Burst 12800 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: two (match-any)
      59111 packets, 9083981 bytes
      5 minute offered rate 25000 bps, drop rate 0 bps
      Match: access-group name aglevel2
        59111 packets, 9083981 bytes
        5 minute rate 25000 bps
      QoS Set
        precedence 2
          Packets marked 59110
      Queueing
        Output Queue: Conversation 137
        Bandwidth 10 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: one (match-any)
      184189 packets, 26666411 bytes
      5 minute offered rate 81000 bps, drop rate 0 bps
      Match: access-group name aglevel1
        184189 packets, 26666411 bytes
        5 minute rate 81000 bps
      QoS Set
        precedence 1
          Packets marked 184273
      Queueing
        Output Queue: Conversation 138
        Bandwidth 10 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: four (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name aglevel4
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip precedence 4
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip dscp cs4
        0 packets, 0 bytes
        5 minute rate 0 bps
      QoS Set
        precedence 4
          Packets marked 0
      Queueing
        Strict Priority
        Output Queue: Conversation 136
        Bandwidth 512 (kbps) Burst 12800 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      283270 packets, 42341824 bytes
      5 minute offered rate 198000 bps, drop rate 0 bps
      Match: any
      Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 128
        (total queued/total drops/no-buffer drops) 0/0/0

many thanks

Dave

2 Replies 2

Tharak Abraham
Level 3
Level 3

Dave,

What is obeserved is that your VoIP traffic is not getting prioritised.

What does the access list aglevel5 match on ?

If thats the case then how will the IOS classify VoIP traffic ?

If its a generic match for a subnet or so

you need to pull down your generic ACL aglevel5

and

you need to place your "match ip dscp ef" on the top if you have marked voice with ef somewhere earlier

or

classify the VoIP packets with

"match ip rtp 16384 16383" which should also be the first in the match any class "five".

Lets know how it went.

Tharak

Hi,

it turns out that the Frame-Relay Tc Interval was at 1 sec instead of 10ms, I changed the following and it's all good...

map-class frame-relay shaped-voice
no frame-relay adaptive-shaping
frame-relay cir 6144000
frame-relay bc 61440
frame-relay be 0

frame-relay mincir 2048000
service-policy output cos

See the link below for more info.

http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a00800942f8.shtml

thanks

Dave

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: