Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Separate routes for separate hosts

Hello! I have 2 networks that are conected with one wan link. I have 2 database servers that have some replications.... I want to add one more wan link and want to route traffic just between these database servers over this wan link. I have eigrp implemented. Can I accomplish this using static routes on this other wan link to these database servers nad access lists?

THANKS!

12 REPLIES
Hall of Fame Super Silver

Re: Separate routes for separate hosts

Enes

I am not sure that I thoroughly understand your situation. On the simple level yes what you describe can work: you can run EIGRP on one link and route most of the traffic over that link and you can have static routes to the specific host addresses of the servers which will use the other link. This implies that if the link with EIGRP goes down the two networks will be isolated and will not use the second link. Is that what you intend?

An alternative solution to this would be to run EIGRP on both links and manipulate the metric so that EIGRP preferred the first link and would use the second link only as a backup. Then you could configure Policy Based Routing to send traffic between the servers over the second link. The advantage of this is that while you are normally separating the traffic of the servers from general traffic, if there is a failure of either link then all traffic will use the surviving link.

HTH

Rick

New Member

Re: Separate routes for separate hosts

Thanks! Can You give me the example of Policy Based Routing with diiferent EIGRP metric?

THANKS AGAIN!

Re: Separate routes for separate hosts

Rick and Enes,

Just one doubt here. What if we put just two static routes. e.g.

If 10.10.10.10 is servers IP and 10.10.30.2 is new Link's IP on remote end 10.10.40.2 is current link's IP on remote end

then

ip route 10.10.10.10 255.255.255.255 10.10.30.2

ip route 10.10.10.10 255.255.255.255 10.10.40.2 50

Here 50 can be specified as admin distance to make this route a floating static route

New Member

Re: Separate routes for separate hosts

The thing is that I want just server to server traffic over this secondary link. In this case all traffic form source network to 10.10.10.10 will go over 10.10.30.2.as I can see.

New Member

Re: Separate routes for separate hosts

What about this idea.

Eigrp Networks 10.10.0.0 and 10.10.40.0

Static route over 10.10.30.2 to 10.10.10.10

and Ip access list on database traffic interface allow only ip from database server?

Hall of Fame Super Silver

Re: Separate routes for separate hosts

Enes

I think that you must have not understood part of my original post. Getting the new link to carry the server traffic is easy if that is ALL that you want it to do. Your suggestion of EIGRP on both and an access list on the new link to permit only the server traffic will work - it is much more complicated than the suggestion of configuring a static route for the server addresses to use the new link. It seems to me that the question that needs to be looked at is the question of what if the primary link has a failure: do you want the secondary link to carry all traffic or do you want the secondary link to still carry only the server traffic. Either of the solutions suggested here will allow only the server traffic and the rest of the traffic will fail if the primary link fails.

Can you clarify what you want to happen on the new link if the primary link suffers a failure?

HTH

Rick

New Member

Re: Separate routes for separate hosts

The perfect solution would be a redundant links and if all is up the the server traffic will use one link and all other traffic will use other link. If one of the links go down the other will take all traffic. How to accomplish this?

Silver

Re: Separate routes for separate hosts

I will suggest you use an offset list with the eigrp configuration. It could require you to have a different subent for the database server. You can configure a secondary address to achieve this.

10.0.0.0 - Site 1 LAN

20.0.0.0 - Database server network in Site 1

30.0.0.0 - Site 2 LAN

40.0.0.0 - Database server network in Site 2

Router 1

interface Ethernet0/0

description TO LAN

ip address 20.0.0.1 255.255.255.0 secondary

ip address 10.0.0.1 255.255.255.0

interface Serial0/0

desc Link for other traffic

ip address 172.16.0.1 255.255.255.252

interface Serial0/1

desc Link for Database

ip address 172.16.0.5 255.255.255.252

router eigrp 1

offset-list 40 in 100 Serial0/0

offset-list 20 out 100 Serial0/0

offset-list 30 in 100 Serial0/1

offset-list 10 out 100 Serial0/1

network 10.0.0.0

network 20.0.0.0

network 172.16.0.0

no auto-summary

!

access-list 10 permit 10.0.0.0

access-list 20 permit 20.0.0.0

access-list 30 permit 30.0.0.0

access-list 40 permit 40.0.0.0

!

Router 2

interface Ethernet0/0

description TO LAN

ip address 40.0.0.1 255.255.255.0 secondary

ip address 30.0.0.1 255.255.255.0

half-duplex

interface Serial0/0

desc For other traffic

ip address 172.16.0.2 255.255.255.252

interface Serial0/1

desc for Database traffic

ip address 172.16.0.6 255.255.255.252

router eigrp 1

network 30.0.0.0

network 40.0.0.0

network 172.16.0.0

no auto-summary

Note that if you do not want to create a secondary subnet, you could configure a specific static route and redistribute, then apply an offset to the prefix. Also ensure that the bandwidth and delay on both links are the same.

hope this helps

Silver

Re: Separate routes for separate hosts

This will be the config without secondary subnets

10.0.0.0 - Site 1 LAN

10.0.0.10 - Database server IP on Site 1

20.0.0.0 - Site 2 LAN

20.0.0.20 - Database server IP on Site 2

Router 1

interface Ethernet0/0

description TO LAN

ip address 10.0.0.1 255.255.255.0

interface Serial0/0

desc Link for other traffic

ip address 172.16.0.1 255.255.255.252

interface Serial0/1

desc Link for Database

ip address 172.16.0.5 255.255.255.252

router eigrp 1

offset-list 40 in 100 Serial0/0

offset-list 20 out 100 Serial0/0

offset-list 30 in 100 Serial0/1

offset-list 10 out 100 Serial0/1

network 10.0.0.0

network 172.16.0.0

redistribute static

no auto-summary

!

ip route 10.0.0.10 255.255.255.255 Ethernet0/0

!

access-list 10 permit 10.0.0.0

access-list 20 permit 10.0.0.10 0.0.0.0

access-list 30 permit 20.0.0.0

access-list 40 permit 20.0.0.20 0.0.0.0

!

Router 2

interface Ethernet0/0

description TO LAN

ip address 20.0.0.1 255.255.255.0

half-duplex

interface Serial0/0

desc For other traffic

ip address 172.16.0.2 255.255.255.252

interface Serial0/1

desc for Database traffic

ip address 172.16.0.6 255.255.255.252

router eigrp 1

network 20.0.0.0

network 172.16.0.0

redsitribute static

no auto-summary

!

ip route 20.0.0.20 255.255.255.255 Ethernet0/0

Hope this helps

New Member

Re: Separate routes for separate hosts

THANKS A LOT!

The serial bandwidth is different . First serial is 1 MB and other for database is 4 Mb.So what about propagation?

Silver

Re: Separate routes for separate hosts

Configure both bandwith to be the same. Either 4 or 1 Mb. The offset-list concept wil not work well if the bandwidth are not the same. Furthermore, your requirements defeats the purpose of routing based on the link with higher capacity.

New Member

Re: Separate routes for separate hosts

I already have a secondary ip on these LANS

THANKS!

144
Views
0
Helpful
12
Replies
CreatePlease to create content