Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Serial Communication between two PC's using router

Two routers are configured back to back frame-relay connection for the purpose of getting communication between two PC’s through serial communication(Not IP based). There are no problem between frame relay, can able to ping each other. but cannot communicate two Pc's using serial port.

Example Diagramand configuration- Attached on the post.

Now if i connect CaMaU the Com port using router serial DB9-RS232 link its go to router prompt. And PC-A system also the same.

BR-A Router Configuration

interface Serial0/0/0

description *** Link to BR-A ***

bandwidth 64

no ip address

encapsulation frame-relay

load-interval 30

no keepalive

max-reserved-bandwidth 100

interface Serial0/0/0.300 point-to-point

description *** PVC to BRA ***

bandwidth 64

ip address 192.168.10.10 255.255.255.252

frame-relay interface-dlci 300 CISCO

  class BRA

interface Serial0/0/1

physical-layer async

description ** MODBUS data From BR-A **

no ip address

load-interval 30

keepalive 10

!

line con 0

login local

line 0/0/1

exec-timeout 0 0

transport preferred telnet

transport input all

transport output all

autohangup

stopbits 1

line vty 0 4

access-class 23 in

privilege level 15

password cisco

login local

transport input telnet ssh

CaMaU Router configuration

interface Serial0/0/0

bandwidth 64

no ip address

encapsulation frame-relay

load-interval 30

no keepalive

!

interface Serial0/0/0.300 point-to-point

description *** 64K PVC to CaMau office ***

bandwidth 64

ip address 192.168.10.9 255.255.255.252

frame-relay interface-dlci 300 CISCO

!

interface Serial0/0/1

physical-layer async

no ip address

encapsulation slip

load-interval 30

no peer default ip address

keepalive 10

line 0/0/1

transport preferred none

transport input all

transport output all

Please anyone review the configurations and let us know your suggestion. Thanks

3 REPLIES
New Member

Re: Serial Communication between two PC's using router

I'm sure alot of things are possible. But when I look at what your asking, correct me if I'm wrong... You want BR-A to pass PC-A signal to PC-B via your CaMaU router. I look at this similar to an ISP passing a T1 signal from one site to another.

To me there is a disconnect between each sites internal to external int's. I don't see how you are associated BR-A inside interface to its outside interface. So, essentially, you want to router to route traffic without telling it to route something. To eliminate L3 you would need some kind of L2 tunneling protocol that will pass seemingly through the Frame-Relay connection.

And maybe, I'm an advocate for L2TPv3 but this seems like a tool that may be needed.

My first questions would be: Do you have registered MAC addresses for the PC's in the routers MAC table? If not, you have a L1 issue that you would need to resolve first. I'm going to see if, I can lab this up, but I can't get pass how to make a strickly L3 device into a L2 only device and pass IP based traffic.

What traffic are you looking to pass w/o using an IP? Even ICMP is a mild form of IP. So, even a ping test cannot be accomplished without an IP addr.

Standby....

Look at the following articles

http://www.cisco.com/en/US/tech/tk827/tk369/technologies_tech_note09186a00800b451e.shtml#stunconfig

or the root

http://www.cisco.com/en/US/tech/tk827/tk369/tech_configuration_examples_list.html

New Member

Re: Serial Communication between two PC's using router

Hi karim,

Thanks a lot for your reply,

I describe the scenario and I need to clarify few things to you,

Sorry, In my last configuration I forgot to add encapsulation slip on serial 0/0/1.(See the new attachment)

My customer want to access PC-A to PC-B which is PLC (PC-A and PC-B-PLC) which only knows Serial communication language ( Modbus). And its passing through Vsat which is S0/0/0. We can able to reach from BR-A to BR-B (CaMaU) through V-Sat. But from the PC-A and PC-B cannot access. Using the existing configuration able to access PC-A to PC-B. Attached the existing configuration in the post. But due to some reason cannot access now.

We suspect the cable could be a problem (DB60 – RS232 – DB9) and changed still the same.

But we try to simulate the same scenario in our lab, Using back to back frame relay and using the encapsulation SLIP for the S0/0/1 interface on both side Which is almost same config. From the router can able to reach each other. But from the PC-A and PC-B cannot access.

Objective - From PC-A using Hyper terminal whatever I type should see (PC-B) other end and could not see the anything from PC-A.

If I am not wrong we do not need to see our PC Mac address on the router ARP table which we did not connect the Ethernet.

Thanks once again for your understanding. Please let me know if you need more clarification.

New Member

Re: Serial Communication between two PC's using router

Thanks for the detailed config and drawing. I think, I understand what you are trying to accomplish. But to go back to a layered approach, I see on RouterA S0/0/1 doesn't have a L1 connection, something isn't there.

But when you get L1 working, I think you are trying to telnet from PC-A to PC-B. I'm at a lost on how to accomplish this without some kind of IP networking. But in the documents I attached there are Cisco methods of passing L2 traffic w/o a L2 addr. Standby as I try to lab this up.

Aqeel

1119
Views
0
Helpful
3
Replies